Roon crashes Mac mini 1 after installing OS Monterey

Roon Core Machine

Mac mini M1 8gb, headless

Networking Gear & Setup Details

UDM router, all devices wired

Connected Audio Devices

Matrix Audio Element X/Naim ND5XS (through Sonore uPNP bridge)

Number of Tracks in Library

Around 140.000

Description of Issue

After installing OS Monterey, Roon crashes the Mac mini +/- when is re-indexing song #60K. Is not that Roon crashes, is the Mac mini M1 that crashes. It worked seamlessly before the update to Monterey (previously Big Sur)

1 Like

I get a message that the computer re-started because there was a problem and get the details below:

panic(cpu 3 caller 0xfffffe0028ac9fb0): busy timeout[0], (60s): 'IOHIDInterface' @IOService.cpp:5520
Debugger message: panic
Memory ID: 0x6
OS release type: User
OS version: 21A559
Kernel version: Darwin Kernel Version 21.1.0: Wed Oct 13 17:33:24 PDT 2021; root:xnu-8019.41.5~1/RELEASE_ARM64_T8101
Fileset Kernelcache UUID: 39AE122AC7508C4798C8CF27369575F7
Kernel UUID: 65055A0F-950D-365E-BE19-6B3D6230C622
iBoot version: iBoot-7429.41.5
secure boot?: YES
Paniclog version: 13
KernelCache slide: 0x0000000020a7c000
KernelCache base:  0xfffffe0027a80000
Kernel slide:      0x00000000212a0000
Kernel text base:  0xfffffe00282a4000
Kernel text exec slide: 0x0000000021384000
Kernel text exec base:  0xfffffe0028388000
mach_absolute_time: 0x702d307b1
Epoch Time:        sec       usec
  Boot    : 0x61772b05 0x000c7811
  Sleep   : 0x00000000 0x00000000
  Wake    : 0x00000000 0x00000000
  Calendar: 0x61772fe8 0x000270bb

Zone info:
Foreign   : 0xfffffe002e854000 - 0xfffffe002e868000
Native    : 0xfffffe1000514000 - 0xfffffe3000514000
Readonly  : 0 - 0
Metadata  : 0xfffffe759c008000 - 0xfffffe75a7f50000
Bitmaps   : 0xfffffe759c00c000 - 0xfffffe759ec34000
Largest zones:
Zone Name                      Cur Size  Free Size
kext.   kalloc.32768              2479M         0K
        vnodes                      29M         2K
        APFS_INODES                 24M      9473K
        kalloc.type1.32              3M        12K
        vnode pager structur         2M         3K
CORE 0 recently retired instr at 0xfffffe0028510640
CORE 1 recently retired instr at 0xfffffe0028510640
CORE 2 recently retired instr at 0xfffffe0028510640
CORE 3 recently retired instr at 0xfffffe002850ef90
CORE 4 recently retired instr at 0xfffffe0028510644
CORE 5 recently retired instr at 0xfffffe0028510644
CORE 6 recently retired instr at 0xfffffe0028510644
CORE 7 recently retired instr at 0xfffffe0028510644
CORE 0 PVH locks held: None
CORE 1 PVH locks held: None
CORE 2 PVH locks held: None
CORE 3 PVH locks held: None
CORE 4 PVH locks held: None
CORE 5 PVH locks held: None
CORE 6 PVH locks held: None
CORE 7 PVH locks held: None
CORE 0: PC=0xfffffe002840eb5c, LR=0xfffffe002840eb5c, FP=0xfffffe6081de3ef0
CORE 1: PC=0xfffffe002840eb5c, LR=0xfffffe002840eb5c, FP=0xfffffe6006483ef0
CORE 2: PC=0xfffffe002840eb5c, LR=0xfffffe002840eb5c, FP=0xfffffe6081a2bef0
CORE 3 is the one that panicked. Check the full backtrace for details.
CORE 4: PC=0xfffffe002840eb5c, LR=0xfffffe002840eb5c, FP=0xfffffe6081d73ef0
CORE 5: PC=0xfffffe002840eb5c, LR=0xfffffe002840eb5c, FP=0xfffffe608154bef0
CORE 6: PC=0xfffffe002840eb5c, LR=0xfffffe002840eb5c, FP=0xfffffe6f80d03ef0
CORE 7: PC=0xfffffe002840eb5c, LR=0xfffffe002840eb5c, FP=0xfffffe6081d53ef0
Panicked task 0xfffffe151601ee98: 251 pages, 4 threads: pid 2977: watchdogd
Panicked thread: 0xfffffe1510f3af08, backtrace: 0xfffffe600642b470, tid: 22285
		  lr: 0xfffffe00283da464  fp: 0xfffffe600642b4e0
		  lr: 0xfffffe00283da134  fp: 0xfffffe600642b550
		  lr: 0xfffffe0028515c30  fp: 0xfffffe600642b570
		  lr: 0xfffffe0028508e84  fp: 0xfffffe600642b5f0
		  lr: 0xfffffe002850684c  fp: 0xfffffe600642b6b0
		  lr: 0xfffffe002838f7f8  fp: 0xfffffe600642b6c0
		  lr: 0xfffffe00283d9dac  fp: 0xfffffe600642ba60
		  lr: 0xfffffe00283d9dac  fp: 0xfffffe600642bad0
		  lr: 0xfffffe0028bd7c5c  fp: 0xfffffe600642baf0
		  lr: 0xfffffe0028ac9fb0  fp: 0xfffffe600642bb90
		  lr: 0xfffffe00284da438  fp: 0xfffffe600642bbc0
		  lr: 0xfffffe00283dfe24  fp: 0xfffffe600642bc70
		  lr: 0xfffffe00283b781c  fp: 0xfffffe600642bce0
		  lr: 0xfffffe00283cf334  fp: 0xfffffe600642bd70
		  lr: 0xfffffe00284fc19c  fp: 0xfffffe600642be50
		  lr: 0xfffffe0028506d10  fp: 0xfffffe600642bf10
		  lr: 0xfffffe002838f7f8  fp: 0xfffffe600642bf20

last started kext at 2767170305:	4.0 (addr 0xfffffe0028289980, size 64483)
loaded kexts:	4.0	11.3	8.2	3.0	20.036.15	1	1	452.30.4	100.1	1	493.0.0	493.0.0	493.0.0	493.0.0	1	11.0.0	1933.41.2	161.0.0	5.0.0	4.0.3	3.0.1	1.9	1	1	1.0.0	582.40.4	1	40	1.0.0	1.0.0d1	1	1	1	1	1.0.1	502.6	502.6	1	1	140.0	415	187.57	1	1	4.7.8	501.6.9	100.51	1	1	1	1	1	1.0.0d1	1.0.0d1	1.0.0d1	1.0.0d1	1	1.0.0d1	1	1	1	1.0.0d2	1	1.0.1	1	1	1	126.40.1	2.0.0	402	1	1	1.0	6.0.0	1010.2	1010.2	1000.11	1.1.0	1.0	100.99	1	5.0.0	412.8	300.10	1.2.0	102.2	493.0.0	1	1	1	1.0.1	1	1	1	1.2	1	3	1.0.1	5.0.0	4.1.1	1.0.4	8.5.0	8.5.0	1.0.0	1.9	3	1	1	1	187.57	187.57	2.1.0	1.0.0	1.0.0	1.0.1	502.6	502.6	100.1	3.4.4	1.0.0	3.0	1	343.0.0	1	1	343.0.0	35.11	1	1	5.33.0	1.0	1.0	2.0.0	1	1.2	1	1.2	1.2	1.0.1	600.95	100.9.1	1	1	1	1.0	1.0.0	1	7.2.8	1	9.3.2	1	1	1	1	1.0.0	1200.12.2b1	1.0.0	1	1.0.4	1	1.0.0	1.0.2	1	1	1000.11	493.0.0	593	9.0.0	9.0.0	9.0.0	9.0.0	9.0.0	9.0.0	68.13.0	1	9.0.0	9.0.0	1.0	2	532.40.7	209.40.6	2.9	452.30.4	452.30.4	1.0	28.30	1.0	1.0	1	1.2	1.2	1.0	3.1.9	1.0.0	1.0.0	1.0	1.0.0	1.0	1.0	1.0.1b8	3.4	11	1.0.1	1.0.2	1	2	2.0.0	1.0	1.0.0	1.0.0	1	1.0	100.1	100.9.1	265.0.0	302.9	1	4	300.0	1.0.0d1	1.0.5	4.1.0	1	1.0.1	1.0.2	2.1	1.0.0	47	1	1	12.0

** Stackshot Succeeded ** Bytes Traced 81797 (Uncompressed 243888) **

I erased Roon Database, uninstalled Roon and intsalled it again. Same problem. I’m in panic mode now…

I had a similar problem recently (using Big Sur - I haven’t updated to Monterey yet) which seemed to be caused by a combination of factors. First, running apps that install system extensions (e.g. Little Snitch, DriveDX and Avast), and second, piggy-backing one USB hub off of another.

What I would suggest you try first is unplugging all the accessories that you can (hubs, hard drives etc) and see if that makes a difference. If not, take a look at the apps you’re running, particularly those that load at start up (and/or install system extensions or kexts). Maybe try disabling all of those. If one of those helps, try adding things back in one at a time to narrow down the culprit. If neither help, hopefully support will have something useful to add.

I did a clean re-install of OS Monterey, so no apps apart from those from “factory”.

I reinstalled Roon from scratch and the problem persists. The sequence of events is:

  • Tidal resynch fine
  • When resynching my music collection (110.000 tracks in a NAS), when the scanning reaches +/- 60-68K tracks, the following happens:
  • First, the scanning in Roon freezes
  • Second I get a message saying something like “iCloud Drive might not be working properly”
  • Then, the Mac mini starts to behave oddly (bluetooth gets off and on randomly, sometimes the top bar dissapears, apps do not respond for sometime…) and I start getting prompts of apps wanting to get access to my the “session start” in my keychain. Those are “assistantd”, “callservicesd” and “CommCenter”. I enter the password, but messages keep popping up. Then sometimes the mini freezes after some time or crashes.

If Roon is not in use, nothing of this happens.

Really is super panic mode now. It used to work seamlessly with Big Sur. Damn upgrades!

Please help!

It seems the issue has to do with scanning the files on my NAS.
I was able to build up my library from my back-up HD, which is USB. So USB HD works, NAS doesn’t.
Tried “n” times to sync the files from my NAS and it always ends up crashing the Mac mini M1 when reaching +/-60-70K files scanned.
All this is very strange. It worked flawlessly with the NAS in the same Mac mini M1 with Big Sur and -some months ago- with a Mac mini of 2012!

Any ideas from support?

How do you access the NAS share from Roon? For ages I was running Roon on a mounted AFP share using automount, which is tolerated by macOS but not fully supported. I’d lose the mount after every OS update.

You probably know this but ensure you let Roon mount the share from the core. Usually the path is like this:
/Users/[user]/Library/RoonMounts/RoonStorage_[long random hash in hexadecimal]

I had a lot of issues when I would have the Roon core access the files at a mount point under:
/System/Volumes/Data/mnt/[NAS name]

My 2c. Hope it helps. I have an Intel iMac
Still on Bug Sur.

same issue. crashes instantly

1 Like

I have exactly the same issue - just installed Roon on my new Mac mini M1 running MacOS Monterey. My library is on a Synology NAS and while scanning the folder it crashes around 65000 tracks. This triggers failure of the Mac mini as well (with requests tot access the keychain, shutting down bluetooth and in the end freezing the system). Was any solution given to this problem?

Hi Simon,
Before I migrated to the new Mac mini, I indeed saw that Roon referred to the files on the NAS in the way you describe. Currently I can only connect with the //System/Volume at the moment. Could be that this causes the problem, but how to connect differently?

Start with the share unmounted. Then go to the storage tab of the Roon settings and select add folder. There is a dropdown selection that includes your Mac HD, but you will also be able to select you NAS. Select this then choose the share. Roon will them mount it for you to it’s own randomised Mount point.

I have my music folder also mounted normally for Plex to access the same folder.

I ended up fed up with the whole thing, got rid of the Synology NAS and bought a Thunderbolt HD, connected directly to the Mac mini M1. I share that drive with the rest of my network. Now everything works much, much, much faster. Very much faster. No turning back to the NAS…

It seems there is an issue of non compatibility Synology NAS/Mac OS Monterrey. I had been using Roon with the Synology NAS for >3 yrs with different Mac OS versions without major problems and it was when I upgraded to Monterrey when it started to get stuck when reindexing at +/-65k songs, without any change in the mounting path vs. previous OS Big Sur

Thank you both for the suggestions. I have downgraded the Mac mini to Big Sur and now it all works fine. The NAS is mounted as //System/Volume and no issues. If this is indeed a Monterey version it feels like a Roon/MacOS problem to me. I hope support can pick this up.

Same issues described by Dave N on October 21.
Running Mac on Monterey and libraries stored on a Synology NAS. Libraries mounted by Roon (SMB).

I was looking for a plug and play handoff solution when I acquired the license but Roon only brought headaches and pushed cost up with all the attempts to find a dedicate server solution. Since I bought the license I spent my 90% of listening hours connecting my devialet directly to Qobuz or Spotify.

Really painful!

Dear all, I am also experiencing some issues - I am using a Mac Mini M1 with a 2.4T base on an external HD. My issues are not as dire as what is reported in this post but Monterey has had two effects for me: (i) when I scroll through the albums page it is not smooth but rather a sort of staggering effect (with some album art which doesn’t immediately show), and (ii) every now and then Roon freezes (causing me to have to force quit the app).
This never happened when my OS was Big Sur.
Hopefully this is being looked at?
Best wishes to all.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.