Roon Crashes on Launch - Started by Refusing to Play Local Files

All technical info is in my Profile.

As it says in the Subject, Roon is refusing to play local FLAC files. Not showing artwork, either.
RoonServer>Roon on same Mac>Line Out to Amp.
There is no network involved in playback, this is Core Audio out.
Verified all drives are online and Roon is looking at them.
Have rebooted the Mac and Roon.

Restarted again; Artwork is showing.
Now Roon skips through a bunch of tracks and starts playing, say, track 8. On another album, it might be track 6. If I stop playback and hit the main Play Now button, sometimes it starts at track, but not always.
Oops, Track Failed to load, Too Many Errors, stopping playback.
Oops, now nothing plays again.

If I fire up Roon on a MacBook Pro, it can’t find the Core; I choose Use Another, and the Core shows up, but says it’s initializing.

Let’s make a little bet. I bet that, pretty soon, there will be a hard Roon crash, and my DB will refuse to load afterwards. Any takers?

Update: When I Quit Roon on the Core Machine, leaving RoonServer running, the MacBook can see the Core and connect. It cannot play files through Roon, though, they behave as above.

As always, all other methods of playback on this machine including QuickLook work fine.

Hello @Andrew_Webb,

Thank you very much for the thorough description. I was hoping we could ask a couple of things, so we can help in the best way possible.

Could you please try reproducing this error and sharing a couple track names + timestamps? Would you please also zip up a set of logs and send them our way?

Thanks in advance :pray:

I can’t. Roon crashed and took the computer with it. Roon crashes on launch now.

I’m though with this. I wonder why I come back and try again every few months?

I’m very sorry to hear @Andrew_Webb. I’m looping in @dylan so he can jump in as soon as possible and see what other alternative is there :nerd_face:

Hey @Andrew_Webb — I ran diagnostics on your Core and I’m seeing some errors I need to talk to the team about. I’m sorry for the frustration! I’ll be in touch as soon as I’ve been able to discuss with them.

1 Like

might be a stab in the dark but how full is your Mac SSD and how much memory is available?

DB is on hardware RAID 0 2xSSD; all drives check out fine. Mac Pro Trashcan, dual 700/32GB RAM. 12 TB of music or so. Music files are on 7200 RPM drives in an ARECA RAID enclosure attached via Thunderbolt 2. All drives online and reporting no problems.

I dont understand is your dustbin is booting of a raid 0 external? if not then how is your database not on your internal boot drive?

Boot SSD less than 50% full.

Plenty of unused RAM left. Roon uses ~4GB of 64GB. More than 40GB free.

Core is on external hardware RAID via Symbolic Link.

Not sure that is a supported config but see what support says.

There is no reason any of that should make any difference. Roon has no trouble following symlinks, and it’s worked fine in the past.

Hi @Andrew_Webb

I spoke with our senior technical team today about the issue that you’re seeing.

Can you please navigate to the following path in your Roon Database Location and let us know how large this file is?


You can click on this broker_2.db folder and press File -> Get Info in MacOS to see the file size.

Path is actually RoonServer/Database/Core/332b61d96c5b4984acd083600bf0dee8/broker_2.db

Size is 8.2GB

Hi Andrew,

First, I wanted to thank you for your patience and collaboration as we’re looking into this.

Your report has been an important subject of conversation with our senior QA team. While we hoped this wouldn’t be the case, it seems the issue you’re experiencing is a tricky one: in certain rare conditions, databases can become unstable, due to parts of the database that grow too large.

We’re currently testing some potential solutions to recover databases that get into this state, but I don’t have any timelines I can provide just yet. It is unlikely that this will be an immediate release, as this is a very complicated area where any changes require an intensive testing and iteration period.

Until we have this fix available, the best option to get up and running with Roon is to use a fresh database (I’ve included directions for this below). I know this is far from ideal and all I can do is share our sincere apologies for the trouble.

If you can think of any questions that we can answer, please, don’t hesitate for a moment to let us know.

Reset Database

  • Create a Backup of your current database if you can
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old” (Keep this Roon_old folder handy)
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

Thanks for the update.

Bummer. That was not a bet I wanted to win.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.