Roon crashes on startup Win 10

Core Machine (Operating system/System info/Roon build number)

Using my laptop that runs Windows 10 Home edition. Version 18363.1379. Latest build of Roon off the website. Reinstalled several times.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Directly connected into ethernet. Networking gear is lots of WAN Miniports. As well as Intel Wireless AC 9560 160MHz. Realtek PCIe GbE Family Controller. Plus some other adapters.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Audio is USB through a GoXLR audio system. Through the back of that is my amp and headphones. Audio works with every other site and music service such as Tidal and spotify.

Description Of Issue

I was listening to Roon as soon as I got my new audio setup (i saw built in EQ for my Audeze) and listened for approx. 2 days. After those two days (about a week ago), everytime I launch Roon it just crashes on startup. It launches a pure white blank page and never loads anything before shutting down. I’ve uninstalled it, cleaned the registry, and reinstalled. Still no luck. Updated my Nvidia drivers and audio drivers so everything is newest. Really hoping to get some help out if I could! Even disabled firewall and redid the exceptions for it.

Hello @Alec_Mason ,

Welcome to the forum and sorry to hear about the difficulties.

Can you please see if a fresh database helps with the issue?

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

If this does not help, can you please use these instructions to upload a log set for review? Thanks!

I’ve tried that! Unfortunately didn’t work. however, starting today it now launches fine but detects no audio anymore. States “No Audio Devices Found.” The audio currently works everywhere else. I attached the logs below! :slight_smile:

Hi @Alec_Mason — Unfortunately we aren’t able to open that link that you shared. Can you try uploading the logs here instead? Thanks!

I uploaded them! Sorry for that

Back to being just a white screen as of now. No longer loading. I think it might have to do with the goXLR inputs? When I unplug the goXLR and just feed the amp/headphones straight into the computer, roon has been working fine. Do you know of any conflicts or how to solve that?

Hello @Alec_Mason ,

Thanks for sending those logs over and for your patience here! Looking over the log, it appears that Roon is failing to start because the install is incomplete.

For follow-up steps please:

  1. Perform the Roon_old rename once more and make sure to download a new installer from our Downloads page (don’t use the already downloaded one):
  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if issue persists on fresh database before restoring the backup
  1. Then please perform a Disk check of your Windows 10 PC

  2. Make sure that Roon is allowed past any Firewall or Antivirus, I would check to see if your antivirus hasn’t flagged Roon as a “false positive” and prevented the full install of the app

Let us know if this helps!

It seems the third reinstall was the trick! So far it’s been working fine. If it breaks again, I’ll let you know! Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.