Roon crashes when I try to edit settings of DLNA device

I just installed Roon Core-Server-Control on my Lenovo Windows 10 laptop.

It detected my Meridian USB DAC with ASIO driver just fine. But it wasn’t detecting my Hegel H360 DAC/amp connected to my home network via ethernet.

Then I realized I needed to install Bridge. Now the Hegel appears in Audio Settings and I can send music to it… BUT

the settings say Roon’s using Airplay and down-sampling a hi-res 24-bit FLAC to 16-bit. JRiver never did this.

I want Roon to send FLACs in bit perfect mode to the Hegel using DLNA.

But when I click the Gear icons to edit the settings for the Hegel, Roon just disappears.

Known bug? How can I workaround this? I need to set the Hegel to use bit perfect mode.

Any responses appreciated.

Also, when I click the RoonBridge shortcut on my desktop, nothing happens. No app appears.

Does Bridge work only “under the covers” to configure stuff? Or should I be seeing an app where I can set up DLNA devices like the Hegel?

My understanding is that Roon does not support UPnP/DLNA. The Hegel sounds like it is not Roon Ready, correct? If so, AirPlay may be the only way to send audio over the network from Roon to the Hegel. And AirPlay is limited to 16 bit.


Thanks for the response.

Roon doesn’t support DLNA? Wow, that’s wildly disappointing.

JRiver supports DLNA plus it has a browser-based remote that works on my Windows Phone, BUT JRiver has extremely poor support for classical recordings, which is most of my collection. Ripping classical CDs there is a nightmare.

Roon has fairly good support for classical metadata, BUT doesn’t support DLNA.

Between a rock and a hard space here…

I’d recommend a raspberry pi with a hat for digital outputs. It’s fairly easy to set up and can support RAAT, which is the protocol roon uses instead of DLNA.
It works like a charm for me, and is more stable than anything DLNA-related I tried.

Roon crashes out when I try to get to settings for an airplay network device. Happens in OSX and android. This is the first mention of a simiksr problem I’ve found.

Yes, this is a known issue and shouldn’t have any real effect – there aren’t any settings to configure :wink:

You can read more about this here: