Roon crashing and then restarting

Roon Core Machine

Windows 10.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I had a well functioning Roon server installed.
However, today my remotes see the server, they connect but after x-seconds they loose the connection.

Any idea what this can be?

For support to be able to offer advice they’ll need a bit more to go on. I would suggest editing your original post to include further details about your core machine, network, and so on (i.e. add detail to the provided headings).

1 Like

hi All:

Since today Roon Core Machine upgrade tot WIndows 11. problem stays
Networking Gear & Setup.
Roon server on Intel NUC

Device name NUC-
Processor Intel(R) Core™ i9-9980HK CPU @ 2.40GHz 2.40 GHz
Installed RAM 64,0 GB (63,8 GB usable)
Device ID 07CC3963-1BE0-4F8F-ABFC-76C29D81455B
Product ID 00330-71425-60337-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Number of tracks in DB a few 1000
worked like a charm untill last week

connected audio device 15 streaming devices, but no difference then befor it use to work.

I assume it could be becase Ive installed itunes on the nuc, but uninsstalled it in the mean while.
its like or the database gets unavailable or the port to connect to roon is taken for a while by another process.

Can’t find what it actually is

Faulting application name: Roon.exe, version:, time stamp: 0x6141ee73
Faulting module name: ntdll.dll, version: 10.0.22000.258, time stamp: 0xb99d09f4
Exception code: 0xc0000374
Fault offset: 0x000000000010be19
Faulting process ID: 0x2f0
Faulting application start time: 0x01d7cc24dd7142f1
Faulting application path: C:\Users\Bert\AppData\Local\Roon\Application\Roon.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report ID: 034ff9a9-67cc-4801-bd4c-4003e34a7163
Faulting package full name:
Faulting package-relative application ID:

found this error in windows


  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

and trying to restore database backup. Fingers crossed

it looks like it is working again :slight_smile:

it worked fot 15 minutes, it started to upgrade database and since then same (old) story…
crashing and it stops working statup you can see for 30 seconds or something the interface and then it crashed again…

ok done the bove procedure again.
got a working roon config
connected tidal stayed - stayed working
restored database - stayed wordking
relaunch started with upgrade database - stayed wordking
for some reason it starts to import lbums and there it crashes. after the crash its impossible to use roon again.
I can start it, i see my data, but after about 45 seconds its crashiing again

hi @DaveN, the information has been added :wink:

Hey @Bert_Leeman,

We’re so sorry that for over three weeks we didn’t get a chance to see and reply to this thread. I am so sorry :pleading_face:

I was wondering, is Roon still crashing constantly? Has anything changed? We’d love to help :nerd_face: