Roon Crashing on Library Import/Update [Resolved]

Core Machine (Operating system/System info/Roon build number)
Roon 32bit core
Which appears to tick the minimum requirements.
Additionally, I have about 11GB free SSD space.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
A laptop, running Roon connected via USB to and RME Adi2 DAC.

Description Of Issue

Hi all,

I was hoping to get some advice.

I imported a wav library with no issues, about 500 albums.
Roon did its thing, grabbing album art etc.
I then tried to import a larger FLAC library, which gives a total track count of around 25,000.
My Core software keeps crashing on imports, audio analysis.

I have tried turning audio analysis off to keep things stable, but no luck.
It seems I need to disable folders, just to keep the software from crashing, this is without streaming to any end points. Is this normal?

Once it crashes, I have to disconnect my USB storage, to allow the core software to load.

I’ve moved your post to the Support category of the forum, where it will be seen, and responded to, by a member of Roon’s support team.

I noticed that you said:

Could you clarify what you are doing here to “disable” your folders? And a screenshot of the Settings/Storage screen of Roon would be useful to show the root folders that you have set as Watched Folders in Roon

It is still necessary to enable smb1 in Windows? Perhaps this is your problem?


Hi Geoff,

I have deleted the instance of Roon core from my NUC PC.
When I controlled the folders, I simply disabled them under the storage section of Roon, which provides three or so options, disable, enable, delete.
Please refer to the post below this one.

I also turned off audio analysis to try and free up resources.

I am now running my laptop as a core and player.

This laptop has 322gb of free space, and has higher specs.

I am completing a flac import atm.
Wavs imported fine again.

On a side note, I tested Audrivana against a Roon Core, running Roon end point on a separate laptop. There was a noticeable quality difference, in favour of Audirvana.

Using my laptop as the core and player, with a direct connection to my RME ADI 2 dac saw both players (Audirvana & Roon) sounding the same/similar.

My network uses an Orbi Ac5000 Main and wireless satellite.
Connection is via a 5ghz link.

Thanks this is enabled.

Watched folders are accessing a USB 4TB HDD.

waiting game…

Thanks for the screenshots. I have to say that it all seems to be proceeding OK - can you say what you meant when you said it was “crashing”?

During the initial import phase, as well as identifying albums and setting up the metadata, Roon also does Audio Analysis, which can be cpu-intensive.

BTW, you shouldn’t need to have SMB 1.0 services enabled in your Windows. That’s only necessary in a particular setup scenario, where your Roon Core is running on a NUC using ROCK, and you need to access it from a Windows PC. That’s not your setup in this case.

Edit: I note that on your original setup (a NUC using Windows 10), you say that you only had 11GB free on your SSD. That’s not much free space, and that could explain the “crashing”.

1 Like

Thanks for everyone’s help.
Using the higher spec laptop has worked.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.