Roon crashing - Playback issues

@support
Hi,

Been doing some more testing and it seems that ALAC on occasion causes the distorted sound.
In each such case, reboot of ROON fixes the issue.

The tracks are ripped from CD using XLD Secure Ripper, bought from HDTracks.
The only common trait is the format - ALAC.

Setup:

Roon on ROCK - Intel NUC Corei7, 16GB RAM, Internal data SSD
Sonore microRendu
Chord 2Qute
Gigabit switch with Cat 6 cables
Signal Path always: Source (ALAC 44.1Khz 16bit 2ch) -> Sonore microRendu -> USB Output.

DSP is disabled.

Update: On one track (re-ripped to FLAC), it appears that playing FLAC version will just skip (no sound) the bad section (of less than 1/4 second or so), whereas ALAC version will add audible distortion. Undeniably handling of FLAC is better.
Had to listen in headphones to detect that one. ALAC was clearly audible.
Also, the FLAC appears to sound a bit better than ALAC.
In the rest of the cases, rebooting the ROCK fixes the issue. I just didn’t test this track, sorry. Noticed the difference in FLAC by chance. On my main system that hiccup was inaudible on FLAC and a very audible (repeatable) distortion on ALAC.

Question: is that ROCK specific (decoder), or Roon specific?
I even started to consider installing Windows 10 and running Roon Core on that one (not a preferred option).
I really don’t want to get forced into re-ripping/transcoding everything to FLAC.

Thank you very much in advance!

Update 2: Happened again on known good files. Reboot fixes it.
Replayed the same track after restart - played just fine.
This happens fairly regularly with random albums.

Tried to establish a pattern of what could cause the observed behavior. So far I’m unable to do so.
Roon doesn’t mark any files as corrupt when scanning.
The only pattern I see is that ALAC (any Khz/bit) could cause the distorted sound, which gets repaired by a ROCK reboot.

There was only one file I haven’t tested the reboot on, just re-ripped the CD in FLAC, and it had some issue (FLAC).
I’ve played that same track and album countless times before (I really like that album) with no issues.
The rest of tracks - corrupted sound, reboot, replay - plays fine.

Hi @roon_lover_007 ----- Thank you for the report and the updates, the insight is very appreciated and my apologies for the slow response.

Moving forward, I had a chance to touch base with a few members of our tech team today in regard to this behavior you are experiencing and as per the conversation may I kindly ask for the following:

  • Can you provide some further insight into the distortion being heard. We want to have a better sense at what the “failure” sounds like.

  • Can you please provide us with a sample of media you are experiencing this issue with via a shared dropbox link for testing?

-Eric

@Eric
Hi,

The distortion sounds like a fairly loud screech.
Unfortunately, I’ve re-ripped one album as FLAC and downloaded the hi-res version of the other from hdtracks.com as FLAC. I’ve had the second one as CD ripped as ALAC previously.

A question: Does Windows version behave better?

ALAC decoder is the same on all platforms.

@mike
Hi,

Thank you!
I thought it was using ffmpeg on Linux and native support on Windows.

Michael

@support

Hi,

Was playing the Eagles FLAC 192/24 and ROON crashed hard (music stops, the ROCK UI shows Roon being down).
The ROCK IP is accessible.
Restarting Roon (not the whole ROCK). Trying to connect to IP of the NUC running it through the same IP.
Not working.
Had to force shutdown (press and hold power button).
Please note that I’ve owned the tracks involved for years.
They play just fine on anything else. Including the Roon.

My purpose is to have the system where I can enjoy my music, is all.
I just want to listen to the music, any time of the day or night.

The initial version worked much better.

As usual - reboot, music plays.
This is getting worse, not better.
It is NUC, suggested configuration with more memory.
It is just a bit frustrating, sorry! :frowning:

Looked through the logs, found:

12/16 04:06:03 Critical: Library.Init: System.NullReferenceException: Object reference not set to an instance of an object
   at Sooloos.Broker.Music.LibraryUtils.TransformLinks (System.String text, System.Int64 selfid, System.Func`2[T,TResult] transform_link) [0x00008] in /home/roon/roon/Broker/Core/music/music_library_utils.cs:284 
   at Sooloos.Broker.Music.LibraryUtils._TransformLinks (Sooloos.Broker.Music.Library library, System.String text, System.Int64 selfid) [0x0000d] in /home/roon/roon/Broker/Core/music/music_library_utils.cs:328 
   at Sooloos.Broker.Music.LibraryUtils.Convert (Sooloos.Broker.Music.Library library, System.Int64 selfid, System.String text) [0x00005] in /home/roon/roon/Broker/Core/music/music_library_utils.cs:347 
   at Sooloos.Broker.Music.LibraryGenre._Load (Sooloos.Broker.Music.LibraryMutationEnv env, System.String name, System.String description, System.Boolean isdefault) [0x00028] in /home/roon/roon/Broker/Core/music/music_library_genre.cs:71 
   at Sooloos.Broker.Music.LibraryGenre..ctor (Sooloos.Broker.Music.LibraryMutationEnv env, System.String name, System.String description, System.Boolean isdefault) [0x00010] in /home/roon/roon/Broker/Core/music/music_library_genre.cs:47 
   at Sooloos.Broker.Music.GenreHierarchy.Flush () [0x00090] in /home/roon/roon/Broker/Core/music/music_library_genre.cs:869 
   at Sooloos.Broker.Music.GenreHierarchy.Load () [0x000de] in /home/roon/roon/Broker/Core/music/music_library_genre.cs:808 
   at Sooloos.Broker.Music.Library.Init (Sooloos.Broker.Database db) [0x00490] in /home/roon/roon/Broker/Core/music/music_library.cs:303 

The song and where/when it stopped playing:

12/16 05:01:56 Warn: Error in web request https://push.roonlabs.com/push/1/connect: NetworkError (System.Net.WebException: Aborted.
   at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00058] in <f05d2be90efa4e2db9df164a992617f6>:0 
   at Sooloos.HttpClient+<>c__DisplayClass10_1.<POST>b__2 (System.IAsyncResult resp_ar) [0x0000d] in /home/roon/roon/RoonBase/httputils.cs:234 )

The Roon/microRendu are connected through a gigabit switch using 2ft Cat6 cables.

Regards,
Michael

Hi @roon_lover_007 ---- Thank you for the update here and sorry to hear of the continued troubles.

Moving forward, the second log trace you shared can be ignored as it has nothing to do with playback in the application. The first trace can be caused by a few different things and we we need to investigate more to understand the exact cause. In regard to this crashing behavior you are experiencing, can you please provide the following:

  • How often is it occurring?

  • Is the issue readily reproducible?

  • Is it happening only during playback? If yes, is it when the same content is played each time?

  • Is it happening when you are browsing? If yes, is it when the same content is selected each time?

-Eric

@Eric

Hi,

Please find my responses below:

This is fairly intermittent, but would happen once or twice a week at least.
The issue is not readily reproducible.
It happens only during the playback. When that happens, it will produce the distortion on the same track at the same location of that track. Reboot clears things up.
It hasn’t happened when I was browsing.

Regards,
Michael

Thanks for touching base with me and taking the time to answer my questions, @roon_lover_007. The insight is very appreciated and my apologies for the slow response.

Moving forward, if I am understanding your follow up correctly this issue is occurring on the same track every time during playback, is that correct? If so, I would definitely like to get a sample of media over to our QA department for testing. Can you please provide us with a copy of the media you are experiencing this issue with via a shared dropbox link for testing?

All the best to you and your family this holiday season!
-Eric

@Eric
Hi,

It happens at the same spot on the same track until I restart the Roon (the ROCK).
Then that same track plays just fine.

For the last tracks I’ve encountered to be problematic, I do not have them in ALAC any longer, as I’ve re-ripped one album in FLAC, and downloaded a hires version of another album in FLAC as well.

Michael

@Eric
@mike
Hi,

One suggestion, if I may:

The ALAC decoder (at least the one bundled with Linux version of Roon) seems to be rather buggy.

There are also known well-working ALAC decoders (in some cases bundled with the OS).
I would strongly urge to replace the one being used now with something that just works.

The problem with all these tracks is that they were Playing just fine for years on other software.
So, the issue is not with tracks, but with the decoder.

Please strongly consider using decoders that just work.

Many thanks in advance,
Michael

Hi @roon_lover_007 ----- I wanted to reach out because Brian brought your posts in this thread tp my attention.

The last we had left off here you had mentioned that the file(s) causing the crashing behavior had been re-ripped and were not available for analysis any longer. If this issue is still occurring with different media can you send us over a copy for evaluation?

-Eric

Hi,

Last time when we spoke you said you would reach out to HDTracks.com for these files.
I just re-rip into FLAC or re-buy as FLAC when I hit this issue.
And a small distortion on one file (which would then play just fine upon OS reboot), wouldn’t be a problem.
General OS instability after that - is. And that is the biggest problem IMHO.
Sorry, I can’t help with the actual samples, and the problem is intermittent, so I totally understand your frustration.
If I get a file I consistently (at least somewhat) hit the issue on, I’ll try and figure out a way to share a sample with you, if that would be at all possible.
Right now, it is very intermittent and Ican’t tell which track would cause that.

Regards,
Michael

@eric @brian
Hi,

I know that the conversation so far was support-related and revolving around ALAC decoder issues.

But I really wish to extend my gratitude for an excellent music playback platform (which ROON really is).
With the latest updates to ROON and endpoints, I’m enjoying the music more and more.
The user interface is top notch as well, as the overall experience and joy!

You are awesome!
Thank you all so, so much!!!

Happy Holidays!

Warmest wishes to you all!!!
Michael

1 Like

Thanks for getting back to me @roon_lover_007, appreciated!

I spoke to Mike in regard to the above and tracked down the PM conversation were the potential of you sharing media with us for analysis had been discussed. Continuing forward, I will be working with Mike in order to try and obtain some media from HDTracks for testing purposes. I will be sure to keep you in the loop :wink:

-Eric

@eric
Hi,

Thank you so much!!!

Michael

1 Like

@support
Hi,

It looks like I might have found the culprit :slight_smile:
It turned out I’ve had a bad SO-DIMM in my NUC (the lower slot), so it explains why my issues were intermittent.
It also explains OS crashes. Should’ve clued into that way earlier!!!
I have re-ripped or converted my ALAC to FLAC, so that probably helped as well.
Back to ROCK :slight_smile:

Thank you so much again!
Michael

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.