Roon crashing when adding Qobuz albums

@johan - I have the same problem as you since months and I also hoped it would get fixed one day.

@noris I had Roon crashing today several times while adding (+) qobuz albums.

I do not use any gaming graphics, just integrated Intel graphics with Windows 10 drivers coming directly from Microsoft. Roon is now crashing also frequently with other activities.

Please let me know how I can support you to fix this issue.

@noris It happened again:
2022-02-20 20:04 CET

Hi @Christian_M ,

Thanks for the report! I’ve pulled logs from your Core, but it doesn’t appear to have much info from the crashes. I’ve also activated diagnostics for your Roon Remotes, but it seems that these reports have not yet come in. Are these crashes happening on the Core or on a Roon Remote? For the time being, I’ve split your post into its own thread, let me know the above when you can!

Hi @noris,

thank you for supporting me! I have installed the latest updates today and the problem is still there. The first album from qobuz I tried to add, the process hang and the circle turned forever. I have taken a video which I can share with you if you tell me how.

Tried it again today:
Roon still hangs when I try to add this album from qobuz - circle does not stop turning:

When I click on the turning circle, it shows:

But even after minutes of waiting, when I close roon and start it again, the album is still not added:

When I search for it again, the Plus sign is still there and I am back at start:

I can repeat this as often as I like…

When I added the following album, roon crashed, but after restarting the program, the album was added:

Roon crashed again when I added this album:

Crashed again when adding this album:

When I search for “Joachim Raff” and click on the COMPOSER link, Roon freezes:

Roon crashed when I added:

Roon did not crash when I added:

Happens to me from time to time when adding Tidal albums. What crashes is the Roon Remote on my iMac running macOS 10.15.7. After restarting the Remote, the album sometimes appears added, other times not so. Can’t see any pattern, though. Most of the times adding Tidal albums doesn’t crash the Remote. Difficult to debug…

Thank you for your confirmation that this problem is not isolated. In my case it is the roon client on Windows 10 while adding albums from qobuz. I see three different effects:

  1. The album is added as expected, no crash - all OK - that shows that the configuration is correct.
  2. The Roon app crashes and closes without message, after restart of the app the album is added
  3. The circle turns endless, the app does not crash, but the album is not added, even after manual restart of the app, the album is not added - I can repeat this on and on.

I also did not find any pattern, therefore I post now each time I add an album what happens and I hope that one day @noris will check the logs.

Christian, that also happens to me. But, every time this occurs, I find out that the album already is present in the library. I go to de artist’s discography and there the albums is shown as part of the library. Problem is that Roon still has many interface elements where it doesn’t clearly distinguish between in-library items and not in-library. And, intending to add an album which is already in the library, Roon doesn’t give an error message, but the circle turns endlessly… as you observe.

Hi @Christian_M ,

I checked your RoonServer logs and I was able to locate the above attempts that you mentioned, however, I do not see RoonServer crashing after adding these albums, I suspect that there is something impacting just the Roon Remote in use.

I’m not able to locate the Roon Remote you’re using in our diagnostics system, would it be possible for you to manually send me a log set via these instructions and upload them here?

Since this issue looks like it’s occurring on the Roon Remote, I suggest reinstalling the UI part of Roon, you can use these instructions to do so:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location (Under %localappdata% on Windows)
  • Find the folder that says “Roon” (not RoonServer)
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Connect to the existing database
  • Verify if issue persists

Also, I noticed that your Roon Core is running an older build of Roon, please update to build 918, as additional stability improvements have been made with this build.

Hi @noris,

thank you for your support. I have updated to the latest version, uploaded the logs of Roon and RAATServer of the Windows 10 Remote that was crashing to the link you have provided. I have then created a backup of the database (on the RoonServer), renamed the Roon folder on the Roon Remote and reinstalled the Roon App. I have changed the settings as I am used to.

Then I tried to add the album above that repeatedly did not add before and now it added at the first attempt:

I have then searched for the composer that made the Roon Remote freeze and this also works now at the first attempt as expected:

Based on this first two tests I can already say that it fixed both. If you could nonetheless check the logs and I will report any upcoming effects.

Thank you again for your support. Besides this little glitches, I am very happy with Roon!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.