Roon crashing when trying to add network share

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Small Green Computer Sonic Transporter, Synology NAS, Linksys Router, Sonore microRendu, Core on ST, Remote on Desktop Win 10 and iPad


System has worked flawlessly since initial install. Can access my Tidal within Roon Remote but have lost my ripped NAS network shares. All software up to date. Reinstalled Roon Server on ST and entered NAS share name in Drive Mounter. When accessing Settings > Storage on Desktop Remote cannot add folder > network share, when attempting, Roon immediately exits. What ??? Tried to add network share via iPad Remote. Settings > Storage > Add Folder > Add Network Share which allowed me to enter Share Location, User Name and Password. Received the following message. " Could not connect to share: Host not found." Entered \DISKSTATION\directory for path. Any assistance sincerely appreciated!


Hi @Clarence_Vann,

Can you please try using the IP address instead? I would also suggest you try using a Reserved IP for both the Core and the NAS to ensure that the IP never changes, you should be able to do this in the router settings.

Here is more information on how to add the share (Add Folders By Path):

Content Stored On a NAS Drive

  • To add network storage, we recommend using your NAS drive’s hostname, such as \\DISKSTATION or smb://MyNASDrive . You can usually find this information by logging into your NAS., and examples are below.
  • You can also use your NAS drive’s IP address, but note that this can change, depending on your network’s settings.
  • Note : AFP Share are not supported, you must use SMB or hostname to connect to the NAS share. You can find more information about why AFP is not supported here.
  • If you are still having issues with setting up the NAS share, further suggestions can be found in our NAS Troubleshooting FAQ


  • If your Roon Core is running on Windows, the path to your networked folder might look like this:


  • If your Roon Core is running on Mac or Linux, the path to your networked folder might look like this:


  • After you’ve entered the network path in Roon, enter the credentials required to access your NAS. If a username, password, or workgroup isn’t required to access your NAS, just leave the relevant fields blank and click Add Folder

Was able to add NAS share via Remote on my iPad and added share appear in my Desktop Remote. The foolowing problem, however, persists.

Win10 Desktop > Roon Remote > Settings > Storage. When I click “Add Folder”, the Folder screen appears and then Roon exits BEFORE I can select Add Network Share. So Roon Remote allows me to add Network Shares on my iPad but not on my Desktop.

Hi @Clarence_Vann,

Can you please reproduce this issue and note the exact local time + date it occurs at? I would like to enable diagnostics mode and see if there’s more info in logs regarding the error.

It occurred at 8:16 Mountain tine on 3/28.

Hi @Clarence_Vann,

Thanks for letting me know that timestamp.

I have tried to enable diagnostics mode for your account and what this should have done is upload a log set to our servers, but I don’t see this log report coming in unfortunately.

Can I please ask that you use these instructions to manually access your Roon Windows logs and upload a set to Dropbox / Google Drive / and post a link here?

My Roon Core runs on a SonicTransporter, are the “Roon Server Diagnostics” in Manage > Apps > Roon what you are looking for?

Hi @Clarence_Vann,

No, I am looking for the Windows Roon logs in this case. If you open up Windows Explorer (the app you usually use to navigate to C: drive and type in %localappdata%/Roon/Logs into the address bar, that should bring you to the Roon logs folder on the Window PC.

Here you go.

1 Like

Hi @Clarence_Vann,

Thanks for sending the log over, I can confirm I located the error trace and I have passed it to QA for further feedback. Once I hear back from them, I’ll be sure to reach out once more. Thanks!

Thank you!

Hi @Clarence_Vann,

Thanks for your patience here! I spoke to QA and it appears that a file or folder in the Sonic Transporter root folder may be causing this behavior.

Can you please access your SonicTransporter via the network (outside of Roon) and post a screenshot of what you see in the root of it?

Capture No problem, see screenshot.

Hi @Clarence_Vann,

Thanks for the screenshot, I have added this to your case notes.

You mentioned that your Roon Remote does not display this behavior, could you also please share a screenshot of what you’re seeing on the remote end when you open up Add Network Share?

Hi @Clarence_Vann,

I’ve discussed this behavior further with QA and they believe that this issue could be due to you having already browsed into a folder with illegal characters in its path. Have you had a chance to take a look at this yet?

You may also want to try reinstalling the Roon client on your Windows PC and see if the fresh install of Roon also has this issue. If you are able to initially access the Storage tab properly, but it stops working after navigating into a specific folder, please keep track of which folder you navigate to causes this issue to start occurring.

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location on the PC
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App to generate a new Roon folder

HI Noris,
I reinstalled the Roon Client on my PC as suggested and generated a NEW Roon folder. Unfortunately that did not solve the problem. I’ve taken a couple of screenshots of the Add Folder screen and the Add Network Share screen which I will send to you via Firefox Send. I’m not sure why the HDD folder shows up in my ST as I access my music from my Diskstation network share. I see no way, however, to delete the HDD folder. Suggestions?

Screenshots from iPad

Hi @Clarence_Vann,

Thanks for the screenshots, I’ve re-uploaded them below for anyone else following this thread (for future reference, you can upload screenshots directly here by using these instructions):

On the screenshots it looks like there is a special character n the root of your SonicTransporter folder name (M:|), and this might be causing the issue.

You don’t want to delete the SonicTransporter root folder. What I would suggest here instead is to rename the M:| Music-FLAC Archival Music folder not to contain any special characters in it (without the : and | characters in it).

You should be able to access the SonicTransporter by locating it under the “Network” tab in Windows Explorer (the app which you usually use to navigate through files/folders on Windows). If you can’t locate it, these instructions may also help:

It not sure how you added the m: folder to the /root folder that should not be there.

The /storage folder on the sonicTransporter is where all the music is.

If you are still having issues with a sonicTransporter contact Small Green Computer for help

1 Like

Hi Noris,

Success, Andrew at SGC was able to delete the offending folder in the ST’s root. Everything working now as it should be. Thanks you for your timely assistance. You guys rock!

1 Like