Roon Database Backup Problems

I have two Roon Database backups scheduled for my ROCK:

One every day at 2am to the 2nd SSD in my ROCK i7 NUC.
It reports the Last successful backup 21 Mar 2018
But it doesn’t say why none have been done since then.

One every day at 3am to a NAS.
It reports Last Successful Backup at 20 Mar 2018.
Reason given is that the last backup was unsuccessful because music was playing.
But again, why didn’t it run the next morning?

I’ve just forced these backups to run now, and both compled okay.

So it seems if one backup doesn’t run for some reason, they all stop running until there is some intervention by me.

Surely that’s not how it’s supposed to work?

Where are you? It may be trying to back up while you are using it and from memory timings are UTC on ROCK so you have to adjust UTC to sync with 2am or 3am where you are.

1 Like

Henry is spot on, the NUC with ROCK runs on UTC time, so you will need to add the offset for your time zone to get the right backup timing. Get that right and see if that’s working out for you :smiley:

So the backups are set in the Roon program, which reports in terms of the time on the computer running Roon. In my case in Melbourne, Australia, where the Time Zone is currently AEDT (Australian Eastern Daylight Time), UTC/GMT +11 hours.

But you’re saying the backups run based on the time on the ROCK server, Well that’s a huge of a disconnect. Would be nice if this was mentioned when setting up and editing the backup time.

Makes it even harder when the ROCK web page doesn’t display the time it’s using, and the ROCK doesn’t seem to have any way via its interface for me to tell it what time zone I’m in. Or, I just haven’t found that setting.

Setting up backups is important. Having a disconnect like this in the process just makes it needlessly hard for people to do.


Also, what is the definition of ‘music is playing’?

Does the music have to be actually playing, or does having it paused also count in this case as playing?

I can’t answer your specific concerns, I am just a Roon user like you but you can make the suggestion this is highlighted to Roon direct by flagging those who administer ROCK. @ben is a good place to start.

We agree, and have a fix to make the back time display using the time zone set on the remote device, whatever that is. I can’t comment on release schedules, but this will get fixed.

The music has to actually be playing, paused does not count.

I don’t have enough information to be sure, but my suspicion is that the reason you’re having trouble with your other scheduled backups is that they’re actually attempting to run at 1/2pm, and music is often playing. Roon should retry every day, even if you have a longer interval between normal backups set.

1 Like

I suspect you’re not correct about this. At 1 to 2 pm on most days I’m at work, so no music is playing.

My backups are scheduled to run daily. If Roon is retrying daily, then it’s not working.

Just to be sure…your BIOS settings are all good right? Its not going to sleep in your backup window?

Well I setup the BIOS as instructed.
What BIOS settings are you suggesting might be wrong and what should they be?

If you followed all the load defaults etc you should be ok. I’m traveling this week so can’t check my settings, but maybe @support would be able to elaborate what the load defaults should setup for power saving options.

Well the backups did automatically run today.
The 2 am one at 1 pm, and the 3 am one at 2 pm, as @ben had suggested.

I suspect me running them manually earlier this morning cleared up whatever blockage was in place.

I’ve now changed the settings in Roon to 3 pm and 4 pm to get them to now run at 2 am and 3 am as originally intended.

I’ll keep an eye on how the backups work over the coming days.

1 Like

Update: This is still an issue. Roon 1.5 has fixed the time offset issue, which is great. However, if the scheduled backups fail because Roon thinks music is playing, it also fails the next day. The schedule doesn’t resume until after I run manual backups.

My Intel i7 NUC has the default BIOS settings. If they need changing can @support please tell me what needs to change?

Hi @Lloyd_Borrett ---- Thank you for the update and sharing this observation you have made with us after updating to v1.5. The insight is appreciated!

Moving forward, I have enabled diagnostics on your accounts so our tech team can take a closer look into this behavior you are reporting to us. What this action will do is the next time the application is active on your core device a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers.

Once the mentioned reports have been received I will be sure to update this thread so you know that we have it and then I will swiftly pass them over to the team for further analysis.


Sounds like a plan @eric. Tonight, I’ll try and make the backup fail by having music playing. Then you can see what happens over the following nights.

Hi @Lloyd_Borrett ---- I wanted to touch base and see if any new observations have been made on your end concerning the above, and secondly to let you know that the mentioned diagnostics report has been received.

The report is now attached to your ticket and is in our queue fore evaluation by a member of the tech team.


Unfortunately I actually got some sleep last night and didn’t have music playing to cause the problem to be triggered. I’ll try to make sure it triggers tonight.

Thanks @Lloyd_Borrett, I will be on the look out for your feedback.


Okay, so both backups have failed because music was playing. If the problem persists, then they won’t work again unless I do a manual backup. Thus they should fail tomorrow morning.

And we have replicated the problem. Backups worked on the morning of the 11th. Backups failed on the morning of the 12th because music was playing. Backups failed on the morning of the 13th even though music wasn’t playing. I hope you’ve been able to get the data you need @eric

I you haven’t, I’ll leave it in the failed state for you. If you have, please let me know so I can run a manual backup and get the scheduled backups working again.

Update: Scheduled backups again failed to run on the morning of the 14th.

Update: Scheduled backups again failed to run on the morning of the 15th.