Roon disappeared from PC (take two)

Core Machine (Operating system/System info/Roon build number)

Windows 10

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core PC connects to network via Wifi, some devices are ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node 2, although I don’t think it’s relevant

Description Of Issue

Was listening via Roon on the Bluesound Node, suddenly the music stopped. This happens sometimes, so I went to the Core PC to restart Roon. Roon was open and seemed fine. Closed it to restart, and when I tried to restart, it had vanished. The pinned icon changed to a generic one, and when I tried to open it, it said it couldn’t be found and wanted me to locate it. I can’t find an operable .exe file to open.

I have restarted the PC, to no effect.

Why would it just disappear?? I could re-install the software, but I don’t want to lose my library!

The only thing that changed on my system lately was the download and installation yesterday of VLC Media Player.


Hi @Ryan_Posly,

Are you still able to navigate manually to Roon’s install location and open it up from there?

I would open Windows Explorer (the app you usually use to navigate to your C: drive) and type this in the header:


There should be a Roon.exe file there, try to open it and see if it works. If it does, then right click the Roon.exe file -> send to -> desktop (create shortcut).

Hi @noris
There is a Roon.exe file there, but when I try to open it, it says “You’ll need a new app to open this .config file” and points me to the app store.

There’s also a Roon.exe_old file in that location, which doesn’t open. See below for contents:

Hi @Ryan_Posly,

It looks like your PC is picking up the Roon.exe as an .XML configuration, that’s very strange. Can you confirm if you have any Backups of your Roon database made prior to this issue occurring? Also, can you try to access the Logs folder and send me a copy of the contents there? Full path for logs: %localappdata%/Roon/Logs

Unfortunately, I don’t think I’ve ever actively done a backup. It’s possible I set it to backup automatically when I first installed it; is there an easy way to check if that’s the case?

What’s the best way to send you the most recent log? I don’t see a way to attach files, unless I’m blind. I could paste it, but it’s extremely long. The sheer number of “this isn’t good” lines in it is a bit concerning… :grimacing:

Hi @Ryan_Posly,

If you have Dropbox / Google Drive /, that would be best. If not, let me know and I can create an account for you on our diagnostics servers. Please send the entire log folder, not just the most recent one in case the other logs contain further clues.

Yes, but only by using the Roon app, which you’re missing in this case.

Another thought comes to mind here, do you have any antivirus turned on? I’m wondering if the AV might have (wrongly) picked up Roon.exe as a false-positive and put it in a virus locker.

I have been experiencing exactly the same problem recently!

Here are all the logs: LINK REDACTED
In the most recent log, you can see the trouble starts when it was switching from the Bill Evans track to the Stan Getz one, which never started playing.

I do use Avast Free Antivirus, but that’s not new. Also, it doesn’t look like Avast has found any threats or taken any actions in the last 30 days (according to its log summary).

Could it be that file extensions are hidden in Windows Explorer and that those exe files are really (incorrectly) name with a .XML extension that is not being shown?

You could check by turning on filename extension visibility assuming it isn’t already.

Edit: realise the above might be stating the obvious but you could at least rename the file back to Roon.exe to try and work out what caused the problem. And get Roon to work again.

File size is only 1Kb though… I think it might be more fundamental…

Good point! The exe_old is a possible but still seems small.

Could you rename the entire Roon subfolder and the reinstall it? Then copy the exes back to the old folder, rename folder back and then try it again?

Or create a new windows user, login as that user and try installing Roon in that user profile?

Hi @Ryan_Posly,

Thanks for sending the logs over, I took a look through them, but it doesn’t explain this issue.
The “This isn’t good” messages you were seeing were due to problems playing back to the Bluesound zone, it shouldn’t have caused this issue.

I haven’t tested these steps, but theoretically you might be able to recover the database in this way (if it’s just the .executable is missing):

  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Copy + replace the new “Roon/Application” folder into the “Roon_old/Application” folder
  • Rename the new “Roon” folder to “Roon_temp”
  • Rename “Roon_old back” to “Roon”
  • Try starting the app from Roon/Application

Success!! Taking Tim’s advice, I simply changed the extension on the Roon.exe_old file (back to just .exe), and it immediately popped back to the Roon icon. Opened it and voila!

It did need to run a quick update to a newer version, so I’m not sure if that truly was an older version of the program that had been renamed on purpose, or if perhaps it was my antivirus software that did it. Another possibility is that something happened in the midst of Roon updating, after it had automatically renamed the old version but before it had fully installed the new version. So it was in a weird limbo state.

I’ll monitor the situation and let you know if it happens again. Thanks all for the help!


Hi @Ryan_Posly,

Glad to hear that you sorted this issue out! Just for future reference, I would suggest performing regular Backups of your Roon database as a precautionary measure in case there are other issues down the line. Hopefully this one is resolved though!

First thing I did was set up automatic backups!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.