Roon disconnecting every few minutes while playing Qobuz

Core Machine (Operating system/System info/Roon build number)

Asus B450m/AMD Ryzen 7 2700/AudioLinux OS/Roon 1.7 rev505

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet from server to Eero Pro router, then to Xfinity cable modem, model Arris TG1682G. Server runs Roonserver while Intel NUC i717DNBE endpoint runs Roonbridge and is connected over 5GHz WiFi .

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Connection from NUC to Soekris DAC is via USB

Description Of Issue

Playing Qobuz results in a disconnection of Roon every few minutes. Connections drops and is reestablished right away. Doesn’t matter whether 16/44.1 or hi-res. Happens either while using iPhone running latest release or iPad running latest release as the remote.

I tried changing the audio device from my NUC to my iPad and I get the same issue. If I log into Qobuz on my phone or iPad music plays perfectly and it is using the same wireless network and path to get to the internet. Local files play just fine from my external HDD.

Hello @Colin_Reilly,

Just to confirm - you are still playing to the Soekris DAC zone even when using the iPhone/iPad and are noticing this issue? Is the behavior the same if you try to route the output to the iPhone/iPad itself (you need to enable this zone first in Roon Settings -> Audio.

Hi @noris

Yes, I am using the iPhone or iPad as remote, and the issue is the same if I change the audio setting to route to the iPad. Music can play for 4 or 5 minutes then I get the “lost connection” message, then I wait a few seconds and it connects again,

Hi @Colin_Reilly,

Thanks for confirming that multiple endpoints exhibit this behavior. Since local files play as expected, but Qobuz ones do not, it sounds like this behavior is limited to streaming services that rely on the external network. I have a few follow-up questions:

  1. What is your network speeds? Can you run a speedtest on and share the results?

  2. If you by any chance have TIDAL, does it display the same behavior?

  3. Have you tried logging out and back into Qobuz on Roon? This is located in Settings -> Services -> Edit button next to Qobuz

Hi @noris

My internet speeds are 360 Mbps down and 12 Mbps up. I already logged out and back in to Qobuz with no change. Last night I signed up for a Tidal free trial, and the issues are the same.


Hi @Colin_Reilly,

Thanks for clarifying that behavior. I’m looking over the symptoms again and it seems that your Roon remotes might be losing connection to the Core itself, not just to Qobuz.

Do you by any chance have another PC that you can use to temporarily host the Roon Core on? If you do, is the behavior the same on the different PC?

Hi @noris

I tried another pc as the core and did not have the same issue. I suspected the nic in my server, but local files play just fine so it can’t be that. The new pc core has to follow the same path to get to the internet, so it’s a mystery. It doesn’t seem like it’s Roon, so I guess you can close this ticket and I’ll continue troubleshooting.


Thanks for the update @Colin_Reilly. You may want to try installing Windows or Ubuntu on the Core to see if the OS has any impact into the behavior as well. I’ll go ahead and close the thread as you requested but if you have any further questions do let us know, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.