Roon disconnects every time I close the lid on my Macbook Pro

Core Machine (Operating system/System info/Roon build number)

MacBook Pro (c. 2013); latest Mac OS; latest Roon build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Macbook Pro with Core connected with cat5 to network. Synology NAS connected via Cat5 to Sonos Connect and Xfinity Cable Modem. I also have Google Mesh connected to the Cable Modem.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Living Room: Hardwired speakers connecting to Sonos Connect, which is using Cat5 to connect to the network and the NAS
Kitchen: Sonos 5 connecting to the network wirelessly

Description Of Issue

I’m a new user and everything seemed to be going swimmingly with Roon recognizing the NAS and my two audio devices (Living Room wired, and Kitchen (wi-fi). Everything worked fine from both the MacBook Pro with the Core and from my iPhone remote UNTIL I closed the lid on the MacBook Pro. Within 30 seconds the stream stopped and Roon stopped seeing the network and the devices. I have triple-checked that I have the MacBook set to “never sleep” under Preferences/Energy Saver. I’m assuming there must be a problem somewhere in the MB Pro settings but I cannot see what it is. (I also made sure that wi-fi is turned off so I’m only connecting via the cat5. Please help! So near yet so far,

Hello @Misha_Weidman,

Closing the lid on a MacBook Pro will cause the computer to sleep when there is no external monitor connected. This is not affected by the System Preferences > Energy Savings configuration.

-John

Thanks for the reply, but This is very disappointing. I’d asked about “repurposing an old Macbook Pro” to host the core before signing up for Roon. Given the number of people using macbooks, I’d have thought that the fact that they CANNOT be used with the lid closed if no external monitor is connected would have been addressed somewhere. Now what do I do?

Maybe search for other solutions? Like this, maybe:

https://code.google.com/archive/p/macosx-nosleep-extension/

Hi @Misha_Weidman,

When using Roon on a MacBook, it will need to be open in order for Roon to run. Many Roon users will instead opt to use a dedicated, headless Core machine running RoonServer. With this type of configuration, you can close any remote device when not in use and Roon will continue to run from the Core using RoonServer.

I use nosleep on my MacBook 12" and used it when using Audirvana. Not only can you prevent your Mac from lid sleep and idle sleep but can also set a timer to disable both. If the album I was playing was 60 minutes long would set the timer for 90 minutes which saves you from opening the lid and disabling manually.

@Speed_Racer@
@Terry_Fell1

Thank you both for that suggestion. I’ll give nosleep a try.

Unfortunately nosleep didn’t work. Before I hook up a monitor, can someone tell me whether doing so WILL prevent my Macbook Pro from going to sleep with the lid down if I have the “never sleep” functions selected?

When you say " it does not work " is the nosleep icon situated in the task bar?, Looks like a quarter Moon. If so check the version you are running?.

I did have this running on a MacBook Pro a couple of years ago and never had an issue with overheating even when using with a monitor. To be fair was only using it for short periods 90 minutes to 2 hours listening to albums and then using no idle sleep, No lid sleep when using MacBook only. Don’t think it is designed to be run permanently anyway.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.