Roon disconnects with phone screen off [Ticket open]

Hey everyone,

Sometimes I want to listen to Roon through my phone’s output directly, through my Bluetooth headphones or Bluetooth speakers. I do this while I work primarily, and am usually away from my phone.

For some reason, Roon works perfectly in this scenario, until about 5 minutes after the phone screen shuts off. Then it disconnects from my core, and I need to turn my phone back on to reconnect and manually resume playback. I tried keeping my phone unlocked when the screen is off, and the same thing happens.

Obviously this is a game breaker as far as just playing an album or playlist and being able to let it go. keeping my phone screen on would be a silly battery killer, so that is not a solution. Consequently, and disappointingly, I need to just use Tidal directly through their app, where this same scenario works perfectly. Their app is pretty good, but I would prefer to use Room and have access to my local library as well. Since Tidal works perfectly while the screen is off and the phone is locked for long periods, this tells me the issue is somewhere in the Roon app and not my phone settings.

I’m using a Google Pixel XL, and my core is a Nuc7i7 running ROCK. Hopefully someone knows of a solution to this, or at least the cause.


@support should get some traction…but I think I might have seen this asked before. Maybe was a different phone type.

Are you on the latest roon app?

Yup, everything is up to date all around… Every device running Roon is up to date, and my phone is on the latest Oreo 8.1.

I’ve gone through my phone settings with care to see if I could find something that would prevent an app from ‘sleeping’, and the only thing I could find of relevance was an option called “Background Activity - (an app can run in the background when not in use)”. However, this was already checked, and doesn’t seem to have any mitigating effects on the pertinent issue.

Hopefully support catches this, because I would imagine many others are in a similar situation as myself, where they don’t always want Roon to playback on their dedicated systems, but just want some tunes around the house with the convenience of uninterrupted direct mobile device playback. In my situation, I love my AKG K845 Bluetooth headphones for many situations… And I love my big system for true audiophile moments as well… But I certainly want / expect Roon to be able to deliver in both scenarios.

I’m not using Oreo so things may be a bit different there but on my Android 7 devices under Settings -> Power management there was an advanced setting which listed apps to exclude from power management. Adding Roon there seemed to work for me - I also had to add Tidal to prevent frequent momentary dropouts. This may be similar, though, to the setting you have already found so not much help.

Hi @Ybwly ----- Thank you for the report and sharing your feedback with us. Both are very appreciated and sorry to hear of the troubles.

Continuing forward, I just took a look around the community site (and our ticketing system) and I noticed that we have a ticket open investigating a similar behavior based on another report (example). Can you verify for if the following improves behavior with the Pixel:

“…keep the Roon app running is switch it to the background (press home button) before the screen turns off (no, not very user friendly :frowning: ). I never had a crash with the app in the background.”


Hi @Ybwly (and ccing @Eric).

Eric has received videos about this to verify the behavior (which they have verified), and I certainly hope they end up fixing it soon.

I have found that the only way to really solve it has been to set my screen to not turn off, which is (of course) a significant battery drain. Other than that, sometimes going to the home screen solves it. I have not found changing the battery management setting to have any effect, on multiple devices.

I hope this helps,


Hey @Eric

I’m glad you’re here! I hope I can be of help in solving this issue.

Ok, I just ran a battery of tests based on your suggestion. I’ll list them in a sort of bullet point fashion, hopefully it will help keep everything clear. In all these scenarios, the phone is set to sleep after one minute.

1 - Roon open as active app

Positive: Playback is perfect. It never disconnects from the core.

Negative: The screen never turns off (it prevents sleep mode), regardless of whether music is playing or not.

2 - Roon open in the background (not the focused app)

Positive: It never disconnects from the core.

Negative: Playback pops in the way that a USB DAC does when it needs more or less of a buffer… Popping seems to get less as playback continues for a few minutes. The screen never shuts off, whether music is playing or not.

3 - Roon open as active app, sleep activated manually by pressing the phone power button

Positive: Playback is perfect while it works.

Negative: Roon disconnects from the server after a short, seemingly variable amount of time, and consequently the music stops. I just timed this, and playback continued for 9 minutes after the screen was shut off, then stopped.

4 - Roon open in background, sleep activated manually

Positive: ehh…

Negative: Again, there are popping audio dropouts as in scenario 2. Also, again, Roon disconnects from the server after a short, seemingly variable amount of time, and consequently the music stops. I just timed this, and playback continued for 6 minutes after the screen was shut off, then stopped.

Well, ok, that’s all I have for now. To note, all other endpoints in my house work perfectly. Also, my version of Android is untouched and unmodified. Lastly, the app never (or very rarely) crashes… It just disconnects from the core.

I wonder if there is a way to mimic or reverse engineer whatever the Tidal app (and other music apps) do to work so well in all the scenarios listed above… I don’t know, I’m not a programmer… Just spitballing here.

Thanks for the help!

1 Like

Thank you for the follow up @Ybwly, the feedback is very appreciated and my apologies for the delay. A few things continuing forward.

I am going to add the information you have provided to the ticket we have in our system that is being used to track this behavior. As @Vog mentioned, he did provided the team with video examples on how to reproduce this issue which our team has been able to replicate successfully. While I cannot comment on when this will be addressed I can assure you (and our other users) that I will be sure to keep everyone up to date on the team’s progress.

In the meantime @Ybwly, I would like to see if we can trigger a change in behavior with your remote device by having you make the following adjustment:

On the Google Pixel XL

  • Go into “settings” and select “Battery”.
  • In the right hand corner of the screen please select “battery optimization” from the “3 dot menu”.
  • You should see a header at the top of the window saying “not optimized” with a little drop down next to it. Click the dropdown and choose “All apps”.
  • Once the “All apps” window is open navigate to and select “Roon”.
  • Once Roon has been selected please choose “Don’t optimize”.
  • With this adjustment in place please verify what the experience is like with the Roon remote app.


1 Like

@eric - Ah, man, that’s it! That was the exact fix needed! I never knew that option even existed on my phone… I Never had a need for it until now. Awesome, man… Thank you!

On my end, everything is working perfectly now… Yesterday I was able to put my phone to sleep for hours with uninterrupted playback. It didn’t run my battery down very quickly either… I would say in the same general timeframe as when the Tidal app is being used for playback.

I hope this helps you guys find what needs to be tweaked. Thanks so much again for the help and support!


1 Like

I’m back. I wanted to update this after spending some time with Roon after adjusting the phone settings as described above.

It does indeed still work perfectly, but I realized that this is true only if Roon is the focused/ active app (i.e., it is what is occupying the phone’s screen). In this case, it works whether the phone is on or asleep, and never disconnects when the phone is asleep.

I realized that it still does not work if Roon is not the active app or is minimized (not displaying on the phone screen). Now, regardless of whether the phone is asleep or awake, Roon will disconnect from the core and stop playback after around 5 minutes or so.

Now, this isn’t a huge problem for me as I know to just leave Roon as the active app when I want to set the phone down and go about my work while listening to music. The only time this is an issue is when I want to use my phone for something else while listening to music… In this case I need to keep flipping the focus back to Roon to either prevent it from disconnecting, or to get it to reconnect.

So, ya, it seems that my last post stating everything was working ‘perfectly’ was a bit premature. I wanted to come back here to tell you this for the sake of being thorough in my reporting of this issue, and so there won’t be misleading or discrepant information for future troubleshooting.

I’m still a very happy camper with Roon overall though - this is just a little wrinkle that needs ironing.

I had the same thing happen with a Galaxy S8+ … I went into battery settings and changed it so Roon would not be able to be put to sleep by the phone. We’ll see if this works.

Having the same problem with galaxy note 9. Turned battery optimisation off, still no go. Getting dropouts as soon as the screen goes dark.

1 Like

Same problem too.

Reposting this in the hope of a reply from @support
Having the same problem with galaxy note 9. Turned battery optimisation off, still no go. Getting dropouts as soon as the screen goes dark. Im using a SGC i5 as transport. This problem is a real pain as I like to fall asleep with headphones and now im having to use vlc media player and bubble upnp.

1 Like

Hello All,

Thank you for your reports regarding this issue. We have been taking a look at this issue internally for a bit of time and have tried to reproduce several times on our end but it is not entirely clear what is causing playback to stop on Android when the Roon App exits the foreground.

We have a ticket open with our development team regarding this behavior — This type of issue requires a pretty major overhaul of how playback works on the Android app. I can’t provide any specific timeframes, but this is something we are planning to address in the future. I appreciate your patience until this work is completed.



Thanks for the support Noris! I hope you guys find a solution, hopefully one that isn’t too taxing to develop, and one that won’t necessitate compromise somewhere else. I would imagine this thread represents only the very tip of the iceberg that is the body of users who would like to use Roon in this way, and certainly prospective new users as well.

Sometimes when I want to listen on headphones, I’ll just plug my phone in and leave the screen on with Roon active – at least that works for the time being. With it unplugged, however, the battery drain is pretty severe. In the mean-time, I’m still loving Roon as my primary playback software for my two channel systems.

1 Like