Roon does not find audio devices

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

TrendNet TEG-851SFP Switch
Lynksis Velop
Arris SurfBoard SB8200

Connected Audio Devices

Sonore Optical Rendu
Holo Audio May DAC Kitsune Edition

Number of Tracks in Library

749 Albums

Description of Issue

My system was working fine. Then I tried to substitute an Ether ReGen switch for the TrendNet switch. When I opened Roon, it could not find any audio devices. I put the TrendNet switch back in, but Roon still could not find any audio devices. Then I rebooted the Optical Rendu and the Roon Nucleus. But Roon still does not find any audio devices.

Power down the Nucleus, then reboot the router and switches, and once the network is up, power on the Nucleus.

Oh, and save yourself some money, and return the Ether Regen switch. It doesn’t do anything a $50 switch can’t do except generate heat.


Martin, thanks, but I tried this just now and it did not work. Help!!

Just adding to my original post here. I shut down the modem, switch, Nucleus and Optical Rendu. Then I rebooted the network. Then I turned the Nucleus and Rendu back on. Then I checked my network and verified that the Nucleus and Optical Rendu are connected to the network. But the Roon app still does not find any audio devices.

And now, suddenly, it is fixed. Thanks to Martin, I think his solution ultimately worked.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.