Roon does not find my M3U playlists

Core Machine (Operating system/System info/Roon build number)

Windows 10

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Gato PRD3 NPM + Squeezeboxes

Description Of Issue

Roon does not find my M3U playlists. They are placed in the same folder as my music. What am I doing wrong ??

The playlists are in the “SQL-playlister” folder.

SQL-playlister is a sub-folder of your musik folder. You should not need to add him separately. Information about how to import playlists in Roon can be found here:

Note: “tracks from other watched folders will be ignored” - So that’s why.

I still can not get this to work. Only my Tidal Playlists is visable in Roon. I have now tried this.
Changed my music folder to this:

Put a M3U playlist in the same folder. Here just called “c”. But Roon still don’t see it. What am I doing wrong ? :

I have a similar layout, and roon finds my .m3u playlists. Are the paths to the files in the .m3u playlist absolute or relative? Do they use a drive letter instead of the file share name? Don’t know if any of that makes any difference. Maybe post a snippet of the playlist file contents?

Edit: Just looked at mine. The playlists are in the media/music directory and the files are listed relative to the current media/music directory, like this:

.\The Beatles\Let It Be\06 Let It Be.flac
.\Pat Benatar\Precious Time\01 - Promises In The Dark.flac
.\Cyndi Lauper\She’s So Unusual\02 - Girls Just Want To Have Fun.flac
.\Pointer Sisters\Break Out\02 - Automatic.flac
.\Leon Russell\Will O’ the Wisp\10 Laying Right Here in Heaven.flac
.\Jackson Browne\The Very Best Of Jackson Browne\Jackson Browne - 206. Lawyers In Love.flac
.\Donald Fagen\The Nightfly\07 - The Goodbye Look.flac
.\The Beatles\Abbey Road\15 Carry That Weight.flac

Again, don’t know if it makes any difference, but maybe if roon can’t find the files it doesn’t import the playlist?

Tried this too


Same result. Find all my musicfiles but it does not import m3u playlists… :frowning:
Tidal playlists are fine.

Hello @Michael_Callesen, for that folder, do you have this option enabled? Also, do these files use an absolute or relative path?

I was having this exact issue. I checked the Playlist Import setting that nuwriy mentioned and mine was set to Yes. I turned it to No and saved. Then turned it to Yes again and saved and all of my playlists are now showing. Must have been something cached that needed a little nudge.

Thanks nuwriy!

Adding a bit more context. Originally my playlists weren’t working at all due to the the drive letter issue mentioned above. Instead of editing them to use the drive letter of my Roon library, I set them up with relative paths.

Since I keep my playlists in D:music\playlists\ folder, I changed the path from this

     D:\music\Esquivel\Space Age Bachelor Pad Music\08 Music Makers.flac

To this

     ..\Esquivel\Space Age Bachelor Pad Music\08 Music Makers.flac

This was working fine for a long time. Then the newer playlists started not showing, resolved by unchecking and checking the Playlist import setting.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.