Roon does not import all tracks

Core Machine (Operating system/System info/Roon build number)

MacMini 2012

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired ethernet

  • music archive Synology 218+ NAS
  • network switch Zyxel
  • switches: Apple Airport, Niveo NGS50, TPLink 5p

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Metrum Mini Ambre

Description Of Issue

new albums are imported on the NAS as maps and flac files. It takes a very long time for the album to appear in Roon, sometimes incomplete (missing tracks), it may take hours. When an album is not recognized this may end up in Roon messing up metadata. What are the correct settings?

Have you gone into Settings>Library>Skipped Files ??. That should tell you why it was skipped over during importing. It might be a file that Roon saw as corrupt, or an incompatible format, or whatever. Sometimes Roon sees a file as corrupt when other software might not. Don’t ask me why, though. I regularly looked under “Skipped Files”, as I’m a heavy importer of files into Roon. It normally shows nothing, but I have had some days where it was 100 files.

Hello @Han_Lauw, Neil has a good suggestion here. Have you checked your skipped files? If you force a rescan of your NAS do the missing files come in?

Hi Neal, thanks. I checked and the files are not in “skipped files” unfortunately

Hi there, I followed Neil’s suggestions, unfortunately the missing files are not in “skipped files”. I have deleted the album from the NAS and imported it again. I deleted the album in Roon, but when I look at the folder in the NAS the missing files were not deleted; the files that were visible in Roon are deleted.
And it takes forever to see the album (and files) appear in Roon.

Are all files definitely in FLAC? I had the same issue however some of my hi-res downloads from Qobuz in particular were in WMA format which Roon does not recognise.

I also discovered earlier this morning that Roon does not recognize ape files. I had to convert it to flac.

The files are definitely flac, ripped off the same CD with DBPowerAmp without errors

Worth checking - thank you. Have you done a forced re-scan of the relevant NAS drive and are all files in the correct folder that Roon points to? Again, I am sure they are but it is worth eliminating the obvious…

Just did that, forced re-scan from my NAS, Roon imported exactly the same files and omitted exactly the same files although I re-imported the whole album into the NAS.

Hello @Han_Lauw, I’d like to take a closer look at the media that won’t import. If you could upload it here, I’ll try on my side and see if I can get things going. Thanks! Please let me know when you’ve had a chance to upload these files.

Hi, thank you, I have solved the problem, it originated in DBPoweramp which uses certain symbols in the filename, which Roon does not accept. Changing these symbols solved the problem.

1 Like

Hello @Han_Lauw, that’s awesome news! Please let me know if you need help in the future.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.