Roon does not respond to commands and crashes

Core Machine (Operating system/System info/Roon build number)
My Core Machine is a desktop PC with Windows 10 pro - 64 bit - Intel i5-3550 CPU 3.30 GHz, 16.0 GB RAM
Audio files are located in an external USB WD 4TB drive - The library actually consists of 1768 albums - 25899 tracks
Roon Version 1.7 - Build 511 stable (64 bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Enabled audio devices: System output - Apple TV - 6 Sonos Connect devices (all wired connected to my home network) + 1 Sons One.

Description Of Issue
Hello, I’m having problems with Roon.

Everytime I try to navigate through genres, artists or search an artist or track, Roon freezes and stop responding for 10/20 seconds, occasionally crashes and I have to restart the program.

Could you please help me finding a solution?

Hi @Luca_Cipiccia,

Did this work for you on this machine previously? When did this start occurring? Were there any changes to your setup around this time?

Since experiencing this issue have you tried rebooting your Core machine?

Hi Dylan, thanks for your feedback.
I tested Roon on the same machine for the free trial period by uploading only a few albums and music files, it worked perfectly.
Problems started when I uploaded all my albums and music files in my USB drive to Roon’s library (I can’t know if it’s a particular music file that’s causing problems…) - no changes to my setup, hardware and software configuration in the meanwhile.
I tried to clear the library and reloaded all my music files, but it didn’t work.
I have problems only on the Core machine, while browsing genres, artists tracks and playing music with Roon apps on my mobile devices (iPad and iPhone) works fine.
Can it be useful to take a look at Roon’s logs? Possibly how can I send them to you?
Thanks again.

Hi @Luca_Cipiccia,

Can you elaborate on this? When there are no files in Roon does it work until they’re imported again? Or even without the files is Roon still crashing?

Yes, Roon works fine before uploading all my files into the library (I tested Roon by uploading only a few albums and music files, it worked perfectly…). It starts to freeze after uploading all my music files (when Roon freezes, I cannot access any part of the UI with mouse or keyboard, however it continues streaming and playing music that was already playing)

Hi @Luca_Cipiccia,

What’s your resource usage during this time? Is anything running very high?

Dylan, thanks again for your help. The resource usage is very low… No other programs running, the percentage of CPU usage is low (medium 20 - 25% with a maximum of 35%) , as is the memory used (35 - 50%).

Hi @Luca_Cipiccia,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi, Dylan, sorry for the late reply, but it took me a few days to do some tests and understand what the problems were.
First I installed all the latest OS updates, then I installed the Roon update.
After updating Roon, it seemed to work perfectly.
However, I decided to uninstall Roon completely (including database and settings) and reinstalled it from scratch - after reloading all my music files, everything seemed OK, Roon did not freeze anymore.
I waited a few days before replying, at the moment Roon works perfectly!
I’ll contact you if I have further problems or questions.
Thank you so much for your support.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.