Roon does not see PC

Core Machine (Operating system/System info/Roon build number)

Roon runing in docker on unraid latest roon I assume

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unifi/ubiquiti networks. UNTANGLE is routing

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

There are many however the problem on is on a PC running windows 10. It has 3 audio outputs I am aware of, a Soundblaster, analogue out and spdif out. Used to be fine.

Description Of Issue

This is a firewall issue but I dont know how to fix it.
Running windows ten build 1909
Seems specific to this PC, other windows on network same build work fine

If I turn off firewall, all is well.
If I turn it on the audio options from the pc are gone.
In firewall, roon is listed and I have check both public and private.
Tried uninstalling and reinstalling roon, rebooting core, no dice.

Any other ideas?

Perhaps this helps:

Thats an alarming amount of ports to open. Never the less I added them no dice.

If I switch off the firewall it all works.

I poked around in advanced sharing options and made sure private and public was allowed to share, I am really stumped on this one.

Come on guys I am being forced to use itunes here!

Well, the easy solution is to turn off the offending firewall. You only need a fw on the gateway anyway.

Yeah I guess so, I have Untangle with firewall and bunch of virus protection and stuff. Still would be happier to have it on.

More importantly its a annoying me I cannot work it out!

Hi Gareth,

Make sure the Firewall and antivirus software allows RAATServer as well as Roon.

Cheers, Greg

1 Like

Hi greg, ok, but how? And why anyway would it suddenly just not work any more?

Where is raat, is it part of the hundreds of ports listed above, I opened all those and still no roon on this pc.

Hi @Gareth_Irwin,

Is this just the standard Windows Defender Firewall? Or a different app?

When entering exceptions for different apps, you should see RAATServer listed in the same place that Roon/RoonServer is listed. Does RAATServer not show up in the list at all?

1 Like

OK I see now it was the raat server that for what ever reason had private networks unticked.

All working now thanks


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.