Roon does not see the external hard drive

Roon Core Machine

MacMini Late 2014, 8 Gb 1600 Mhz DDR3, 1 Tb local storage, MacOS Monterey 12.3.1

Networking Gear & Setup Details

Connected Audio Devices


Number of Tracks in Library

about 2000 tracks

Description of Issue

I just bought an external hard drive 2.5" WD 4TB Elements SE (WDBJRT0040BBK-WESN), formatted it as exFAT. The drive is mounted on the desktop, and I can browse it in the finder. After connecting to my MacMini, I transferred the entire music library to it, but ROON refuses to see it. Please tell me, what could be the problem?
Thank you very much in advance!

Just a thought, have you restarted Roon since you put the hard Disk in?

Was it a different version of the os on the desktop, permission differences? Might be a pain but format it on the mini and then copy a few filea across and see if you can access.

There are not really any permissions on exFat, that’s why I was wondering if Roon was started before the drive was in, then it might got a list of available storage before it was there.
Not seen this in Roon but been on Rock for 4 years so haven’t tried anything like this.

1 Like

Roon can see the drive, but can’t list the folder. This may be caused when removing the drive before it is unmounted. From the Mac Mini, if possible, type the following to identify the drive: diskutil list. It should be something like disk2s1.

Now run the following:

sudo fsck_exfat -d <disk id>

You may be prompted to update the boot region, so enter y.

This should tell you if there is a problem. Use Disk Utility to repair the drive.

1 Like

Thank you all very much. The problem is solved.
I just had to go here =>


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.