Roon does see my Denon X3400H but no sound

Core Machine (Operating system/System info/Roon build number)
OS Name Microsoft Windows Server 2019 Datacenter
Version 10.0.17763 Build 17763
OS Manufacturer Microsoft Corporation
Processor Intel® Xeon® CPU E5-2689 0 @ 2.60GHz, 2601 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 4.6.5, 4/24/2018

Roon Core version 1.7. Buikd 537 64bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet via Dell Router Wired

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Denon X3400H via wired ethernet

Description Of Issue
Roon does discover my Denon X3400H AVR and I can select it as Roon Tested Output. But there is no sound. Can select it as Zone and press play. It seems to play but no sound.

I own a Poly/Mojo and that works fine.
Via the HEOS app on my phone, the Denon works fine.

Am I doing something wrong?


Hi @Robert_Hendriksen,

Can you share a screenshot of Device Setup as well as a screenshot of the Signal Path when playing to the Denon?

Hello Dylan,

I hope these are the correct pictures. The Denon indicates to be playing but the bottom sound signal bar remains at 0:00 and no sound.


Hi @Robert_Hendriksen,

Have you set your Denon on the Airplay input prior to starting the Roon stream?
Is the Denon up-to-date on latest firmware?

Dear Noris,

I don’t see Airplay in any menu. The latest firmware seems to be installed. My X3400H might be too old. Is there another way to get Roon working with mu AVR?


According to the manual, Airplay is supported in the X3400H. More than that, I don’t know what is happening here. My Denon AVR is definitely too old to support Airplay. Sorry.

Mine would run as HEOS Music if I used roon via airplay.

I run directly out of my nuc rock hdmi in to my receiver now.

Dear Roon,

Thank you Billy and Geoff. I just tested Airplay via my wife’s iPhone and it does work when the AVR is switched to HEOS music. Via the iPhone we can play music. Still no luck via Roon though…


The only thing I can think of is that the issue may be connected with the fact that you are running the Roon Core on Windows Server 2019 Datacenter… I assume that you have the Media Foundation installed?

Do you have a Windows 10 PC or laptop available? You could test playing to the Denon by setting up the Windows 10 device with Roon (so installing Roon for Windows, but just using it as a Control and Endpoint component working against the existing Roon Core on your server), and defining an endpoint for the Denon on this device.

There seems to be a discrepancy between what Roon is saying is Roon Tested and what Denon is saying is Roon Tested. If you look at the Denon list, the X3400H is NOT on their list. However, it is in Roon.

There are several other receivers like that ( one one list and not the other) and I have compiled a message listing them and sent it on. So, might not be the issue, but?

And yet, the X3400H is listed in the Denon press release… Go figure…

Hi @Robert_Hendriksen,

I would second @Geoff_Coupe’s suggestion here. Do you have a non server edition PC you could try temporarily using as the Roon Core? To do so:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different OS

Dear People,

I tried installing the Media Foundation on the server. But that made no difference.

Next I installed a VM with Win10 dedicated to Roon server, switched Roon cores and now it works!

Thank you all for the suggestions.



Hi @Robert_Hendriksen,

Glad to hear that using the Win10 VM resolved this issue!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.