Roon doesn’t see itunes playlists

Roon Core Machine

mac mini, nucleus, os big sur

Networking Gear & Setup Details

wi-fi, eero

Connected Audio Devices

Number of Tracks in Library

9k tracks

Description of Issue

Ronn doesn’t see my itunes playlists — it finds my music library fine, itunes music and library are all in same place (eg sonos finds playlists ok)

Hey @John_Eaton1

Thanks for letting us know!

When importing your iTunes library, Roon should be able to understand the contents of your playlists as soon as the XML file is stored in the same folder. Have you made sure that the XML file is in the same watched folder as your iTunes files?

Checking out our iTunes Guide would provide a wealth of valuable information.

Let us know if you’re still having issues, we’re happy to help. Thank you! :slightly_smiling_face:


Hello Ashley

Thanks for the response. Yes, the xml file is in the same folder as the itunes library on my Nucleus, but Roon doesn’t see my playlists. On further checking I’m getting an error message that the Metadata improver is paused — how do I fix this? — my internet connection is working fine and I’m on the latest version of Room

Best wishes,

@John_Eaton1 Thanks for checking!

Can you share a screenshot of your Roon Settings -> Storage tab?

Regarding the the error message you received, have you rebooted your Core? If you haven’t already, please give that a try and see if the issue continues.

If that doesn’t help, I’d suggest taking a look at this article in our Help Center: Resolving “Metadata Improver: Halted” error messages. It has some great troubleshooting steps that you can try to resolve this.

Thank you :pray:

Hello Ashley Rebooting the core seems to have solved the Metadata improver issue – thanks!

Attached is a screenshot of Roon Settings – Storage as requested.

Thank you, John.

1 Like

@John_Eaton1 Thanks for the screenshot!

We’d like you to try adding your Music folder to the “Shared Folders” list in System Preferences and then adding smb://your-ip-address/Music in Roon.

To resolve this issue, try the following steps:

A. Open Finder.
B. In the menu bar, click “Go” > “Go to Folder”.
C. In the folder prompt type /usr/sbin/ and then click “Go”.
D. Locate the “smbd” file in the folder.
E. Open System Preferences > Security and Privacy > Privacy > Full Disk Access
D. Drag the “smbd” file from finder to the System Preferences list for apps given Full Disk Access
E. Restart your Mac.
D. Once your Mac has rebooted, attempt to add the directories via SMB again.

Let us know if you have any issues going forward. Thanks! :smiley:

Hello Ashley. Thank you for your help – and patience! I did what I think was what you asked of me, but still get no access to my playlists – my Storage tab now looks like the attached screenshot and i have 2 copies of all my albums, but no playlists. Best, John.

1 Like

@John_Eaton1 Thank you for completing that and sending the screenshot along with your reply.

Since my suggestion just created another identical folder, I will kindly ask that you revoke access to the smb connection folder that was created, as it will create issues down the line with Roon. I apologize that this was what had happened.

To make sure this doesn’t interfere with Roon, you’ll first want to disable the folder that was added and then go to Roon Settings → Library → Clean Up Library.

The next step would be to check a few settings regarding iTunes.

  1. If you click on the ellipsis next to the Nucleus Internal Storage folder, can you confirm that ‘Import iTunes Content’ is turned on?

  2. Please double check that ‘Share iTunes library XML with other applications’ in your iTunes application preferences is checked. More information about this can be found here in the iTunes article: Setting Up iTunes

Thank you kindly! :pray:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.