Roon doesn't allow me to find my DAC in audio settings

When I go to my audio settings I see no way to connect to my DAC. I have a Mac mini connected to a rega DAC. When I click the icon to scan for devices nothing happens. The zone name showing in system output is “local” The built in output has an enable button. Any help in finding and enabling the DAC? Thanks!

Hey @Jeffrey_Brown – so the DAC is connected via USB? Can you confirm whether it’s showing up in your OSX audio Settings? Does the DAC require you to select the USB input perhaps?

What are you seeing in the Audio tab of Settings in Roon? Nothing other than System Output? Screenshots would be great here, which you can just drag right into a reply here.

Let me know and we’ll figure this out. Thanks!

The DAC is connected via optical and show up in the output field in OS X. I wish I knew how to screen shot what I’m seeing. It’s basically;

Connected to this Mac. Scan button
System output. Local
This audio device will play out the default device

Built in output. Enable

Apple inc
Core Audio

Does this help?

Hey @Jeffrey_Brown – just to confirm is plugging in the DAC via USB an option here? That would be how I’d recommend setting this up, for starters.

1 Like

No, the first version of the rega Dac didn’t have a usb asynchronous option

Hi @Jeffrey_Brown – To set up your Mac Mini’s optical output, you’ll want to enable the Built In Output (on the Audio tab of Settings in Roon). Make sure you choose Built In Output, not System Output.

You’ll probably want to engage “exclusive mode” for this output as well. I have provided you with a link below to our “knowledge base” for step by step instructions on how to set that up. Please let me know if this works for you, thanks!

Hi Jeffrey,

On the Mac, use Command-Shift-3 to screenshot the entire screen and Command-Shift-4 to get crosshairs and shoot part of the screen. The pic will show up on your desktop.

Cheers, Greg

I have followed the instructions and named the output mega dad Does this screen shot showing the signal path confirm the mega dad is active and in the signal path?


Hi Jeffrey,

I understand you’ve enabled Built in Output (being the Mac mini Optical out) and renamed it Rega dac (although mega dad does have a certain ring to it :smile:).

Are you hearing music through your Rega DAC ? If so, well done, problem solved.

If not, can you post screenshots of both tabs of the Rega dac settings (Settings/Audio/ right click gear icon for Rega dac)

For clarification, I enabled the built in output and named it rega dac

. It wasn’t “discovered” I just named it. Music is playing: i just don’t know how to tell if the DAC is in the chain. Do these screen shots help?

I appreciate all the help, I’m sure we can figure this out

That all looks right to me Jeffrey and hearing music is always a good sign !

With optical or coax outputs I’m not sure Roon can “see” the DAC or other end device. The last step known to Roon is the audio stream leaving out of those outputs. Network endpoints running Roon Bridge or being Roon Ready report more back to Roon.

@eric may be able to clarify.

Thanks, let me know if Eric has any insight here. Given the issue would I be able to extend my trial by a week??


@Jeffrey_Brown, @andybob is correct. There is no way for Roon to detect or “see” your DAC over an S/PDIF interconnect. S/PDIF is a one way connection–we can send audio, but we cannot receive information from the DAC. As far as I can see, this is working correctly.

Virtually all other supported interconnects like USB, RAAT, AirPlay, Meridian, and Squeezebox let us see further down the chain, but there is no way to do that over S/PDIF.