Roon doesn't see ultrarendu

Core Machine (Operating system/System info/Roon build number)

Windows 10 PC and Laptop

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connected to ultrarendu, usb to iFi Pro idsd

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB to iFi Pro idsd

Description Of Issue

Just got the ultrarendu yesterday. It played for an hour or so, but now Roon doesn’t see it. I have re-booted everything, and checked all connections.

Hi @David_Finch1,

Is your Core also connected to the network via Ethernet? What router are you using? Any switches?

Can you confirm that the iFi is currently powered on while connected to the Rendu?

Are other endpoints working okay?

The Core is a Lenovo Ideacentre PC, the router is an AT&T BGW210. The PC and ultrarendu are both connected to the router by ethernet. The iFi is powered up. I don’t know what you mean by other endpoints.

Do you know the IP address of the ultrarendu and can you go to it through a web browser to access the software and diagnostics?

Did you ENABLE the Ultrarendu? Settings> Audio

I can’t, Roon dosesn’t see it. It did yesterday, but not anymore.

The next step is to make sure your ultrarendu is in Roon Ready mode. Enter the local IP address and reset Roon Ready. This screen is from my microrendu, but it should be the same. Basically, refreshing the ultrarendu to ensure Roon Ready mode.

I’ve tried that a few times, no help.

That’s the simple stuff. I’ve flagged the experts on Sonore for you.

Paging @agillis and @Jesus_Rodriguez

Note: Endpoints are other Roon capable players. The Ultrarendu is an endpoint.

That is the only one then.

Did you try rebooting the Ultrarendu?

Try this in order:

  1. Remove the power cable from the Rendu and the DAC.

  2. Connect the power cable to the DAC and power it on.

  3. Connect the power cable to the Rendu.

  4. Go to Apps / DAC Diagnostics and confirm the DAC is present.

  5. Go to Settings / Roon Ready and press Save.

  6. Go to Roon / Settings / Audio and enable the Rendu.


Music! Thank you!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.