Roon don't visualize my external Hard Disk

Core Machine (Operating system/System info/Roon build number)
Macbook Air/ MacOs Big Sur 11.1

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

External Hard DIsk/Usb

Description Of Issue
Good morning. I would like some help if possible. I’m trying to add files from my external hard drive, on a Mac with Big Sur installed, but roon doesn’t display it. Maybe because it is encrypted with software, Veracrypt? However, other applications display the external drive correctly. thanks for the answers.

I think Veracrypt (ex-Truecrypt) is the problem since this is an on-the-fly encryption product that sits on top of the OS, so Roon will not see the encrypted “partition”.

But why would you encrypt non-sensitive media files anyway? Moreover, why don’t you use MacOS FileVault which is built-in and will work with Roon?

Thanks for the answer. But when i open the storage with veracrypt, Is a normal hard disk, visible by all the applications. If others confirm that Is veracrypt the problema, i should change strategy.

Can anyone else on the staff confirm that the problem is veracrypt? I need to figure out if I need to change / format the hard drive. thanks

Do you have the latest version of MacFUSE installed? This software allows applications to use third party file systems. However, note that Roon uses its own file system dialogue rather than the familiar Mac Finder windows.

yes, also because veracrypt doesn’t work without fuse. it seems strange to me because all the other applications display the hard disk, only roon no

Hi @Stefano_Broccoli,

If you try to copy these files into a drive that is not encrypted by Veracrypt, do they import properly?
What is the format of the files, are they supported audio files?

yes, i copied a file (yes, they are all roon supported files) to an sd card inserted in the mac, and roon imported it correctly. It’s just that hard drive that still doesn’t appear…

so, do you think i can fix it somehow, or should i necessary change the hard drive? thanks.

Hi @Stefano_Broccoli,

Since other drives work as expected, this suggests that the drive with the encryption cannot be properly read. I would use another hard drive with Roon that does not have this encryption in place.

thanks, i had to change hard drive but now it works. thanks anyway for the support.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.