Roon drop outs for 15-20 seconds while still playing (track seconds ticking down)

Roon Core Machine

mbp retina 13", mid 2014 (still has combo 3.5mm jack/mini optical)
2.8ghz dual-core intel core i5
os x 10.15.7 8gb ram
Roon ver 1.8
ssd internal drive, 2tb ssd external where music is stored.

Networking Gear & Setup Details

Router shared with my neighbour. Hard wiring is not possible, please don’t suggest that as a solution. I’m a newb with Roon so don’t bite my head off. Does wifi matter much considering playback is 100% hard files with audio hard wired? No multi-point streaming involved here.

Connected Audio Devices

audioengine d1 dac connected via optical for audio and usb used for power. Audioengine dac is then connected hard wire to my amp/speakers.

Dac is connected to mbp via a powered usb hub. Realistically it’s not possible to directly connect as the mbp only has 2 x usb 3. The external ssd is connected directly into mbp with the other free port.

Number of Tracks in Library

68,000 tracks

Description of Issue

The music drops out for 15-20 seconds whenever a process happens in os x in the background. It can range from a pop up notification of my mail app, to moving files around in os x, to emptying the trash can. This applies to files anywhere, not just the folders I designated for roon to scan.

Also each time I engage an alternate sound source, ie. itunes or youtube in chrome. Switching back to Roon afterwards involve the same 15-20 second dropout lag. During all these instances I can hear the dac re-engaging, it makes a low level click when it does that.

The app doesn’t freeze while dropping out, the player still indicates it’s playing with seconds ticking down on the track, sans sound.

I don’t have many intensive apps running in the background. Usually it’s just Chrome, mail and maybe spotify. Activity monitor shows Roon is using about 35-40% of cpu on avg. Tracks I select to play are all hard files as I don’t use streaming compatible with Roon. I’m on trial testing out the app, if this persists I cannot reliably use it as an everyday player.

I just tried it with strictly USB, taking optical out of the chain. It eliminates the 15-20 second lag problem, but I can still feel micro jitters during playback randomly. Any reason why these 15-20 second lags are happening with optical?

could be that your library is being analysed this can cause some slowdowns. Maybe try turning off Audio analysis under library in settings while you are playing.

what if any DSP options are you using?

under signal path is there any processing speed showing…a screen shot might be nice here

No dsp involved.

Will changing “resync delay” or “max buffer size” help in the device setting area of Roon for the dac?

Any analysis still ongoing?

It was on (throttled), on demand (fast). I toggled both off and the 15-20 second lag still happened when moving files in os x.

For now the short term fix is to use “usb” only. Still don’t understand why optical is creating all these problems. It should not be happening and has never happened with any other app. Been using optical for years in this exact manner.

Hi @a_t, sorry for the late response, I just wanted to let you know we are looking into this with our device expert. We’ll be in touch once we have an update from them.

Hello @a_t,

Thank you for your patience here while we’ve had a chance to consult with our hardware team on this one. We’ve activated diagnostics mode for your Core and what this action does is automatically upload a set of logs to our servers for review.

Looking over the logs, it appears that playback is working as expected and then the device suddenly drops. Can you please confirm, if you try to play to this device with Exclusive Mode disabled from Device Setup, does the same behavior occur? Please let us know, thanks!


Thanks for replying…

I turned off exclusive mode while using optical, same thing happens. After my post I switched to using usb only. Each time I switch back to optical the same issue persists.

My trial is about to be expire today, can it be extended so I can troubleshoot this more. @accounts

Or else I’ll have to cancel because I can’t use it at its current state suffering these drop outs.


The dropouts also disappear if I use system output/os mixer. Signal downgrades to “high quality” as a result.

However direct lossless bypassing os mixer with optical still remains the same, with dropouts.

Hello @a_t ,

Thank you for that additional data point! Let us discuss your findings with our hardware team and we will let you know what they say, thanks!

Hello @a_t ,

Thank you for your patience here, I have had a chance to discuss your case with our hardware team further. There appears to be a similar report on our forum with this DAC, and the solution for the other report was to change the Buffer Size in Device Setup for the zone:

Can you please try to use different buffer sizes, such as the “Maximum Buffer Size” or to 5ms? Does that help with the dropouts you are experiencing? Please let us know, thank you!

ok I will try this out and let you know how it goes.

1 Like

Unfortunately changing buffer sizes didn’t help at all.

I’m guessing this dac and roon will never be friends. I quite enjoyed using it to be honest, minus this issue.

1 Like

Hi @a_t ,

Sorry to hear that changing the buffer size hasn’t helped with the issue. Can you please check to see if setting up a fresh database has any change in behavior? I have provided instructions on how to achieve this below:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page
  • Verify if the issue persists without restoring the backup

Thank you!

Yeah unfortunately my trial is over, so I can’t test it out anymore. I do appreciate everybody’s help, you guys are much more hands on than my previous experience with vox.