Roon Error Message - A new guard page for the stack cannot be created

Roon Core Machine

Dedicated WIndows 11 computer with 32GB RAM, 1TB of storage to run OS and Roon only and Intel 12thGen 12400 CPU. This computer was made to solely run Roon.

Networking Gear & Setup Details

Wired ethernet only to Lumin with a single switch between

Connected Audio Devices

Ethernet to Lumin and to WIndows file server that holds music

Number of Tracks in Library

150k tracks

Description of Issue

This error has been reported several times before from various people on this forum with no solutions and this issue/problem is always closed WITHOUT resolution. I get this problem everyday after not using Roon for several hours (usually during the wee hours of the night) and then I have to restart Roon.

My computer CPU is certainly powerful enough, there is more than enough RAM and primary disk storage space and my ethernet is working just fine which leads me to believe that it is a Roon coding error.

Is there someone on the Roon team that can chime in?

Not from Roon, but out of curiosity I googled the message.

It’s because of running out of memory and since you only run Roon on your machine that is probably the culprit. You already realize all this, I guess.

The other thing I noticed is, that for some replies, the video driver was implicated. Is your video driver up to date and from the maker of your video card?

I was going to say something along a similar line. Another remedy, mentioned a few times, is to completely remove and reinstall .NET and the affected app.

Yes, the whole roon setup is fresh, so to speak, brand new install for everything and the integrated graphics are on the Intel 12400. And proper drivers were installed and running

Obviously memory isn’t a problem in this situation with 32 gigs of memory roon uses a maximum of 9.6Mb of RAM when it’s really working hard. There is ample headroom.

I have been looking at this specific error outside of roon but did not find any solutions other than buy more memory… Which in my situation of course is not the case.

However later on this evening I will try to uninstall .NET then reinstall.

Well I reinstalled both .NET and Roon, lets see how this works. Roon support are you there? Any suggestions as to why Roon is specifically spitting our this error message?

So Roon support (who is not chiming in). This was so frustrating I decided to reinstall everything from start and just install Roon. Unfortunately I still have the same error. Can Roon support please reply… could this be a Windows 11 problem, do I need to be running Windows 10 only for Roon to work?

No. Tagging @support for this 2 week old post.

1 Like

Hi @James_Caldwell,

I appreciate your patience in awaiting a response from Roon on the matter. We’re working as hard as we can to get to every case.

I have a couple of statements and questions for you:

Your assertions are correct. 32 GB of RAM with a 150k library gives some nice headroom for Roon to operate. The only thing that could affect this is the environment (other applications running). Also, xxx is correct. Windows 11 should be working fine. I have Roon running on Nucleus, MacOS, and Windows 11 myself. @xxx is also correct in that video drivers have been to blame in the past. Please make sure you’re updating with the manufacturer directly rather than some of the Intel/Dell/HP updaters that exist out there. I’ve had some bad luck with those on my XPS.


Are you using multiple monitors with this laptop? If so, can the Roon window be moved to the primary monitor and still experience this issue?

What video card do you have? You mention the Intel 12400 but having the specific chipset of the integrated graphics card might help us.

I have seen this fix similar issues and there’s no harm in trying it. With Roon closed, navigate to C:\Users(username)\AppData\Local\Roon\Database\Registry\Client. You may need to show hidden files and folders in order to see this! Once there, delete the file saved_window_pos. You should see this rebuild when Roon re-launches.

You had mentioned you’d re-installed Roon but I want to give you the directions for a completely clean install just in case this wasn’t done.

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Before you re-import your database, see if you can duplicate the problem. Log into Tidal or Qobuz, queue up some music, and see what happens. If the issue doesn’t recur, then we can reimport the DBs and see how things are working.

Please let me know about the questions and how (if at all) this moves things along for you.


1 Like


So glad to make your acquaintance.

Let me first reiterate that this is a brand new Intel 12400 computer, on an Asrock B660M-ITX/ac motherboard with 32Gb of DDR4 RAM and a 500Gb Samsung SSD 970 EVO Plus. Then of course there is an ample power supply and a CPU fan. SO very simple, and made to exclusively run Roon. WIndows 11 Pro is the OS with all the latest updates. I do not have a multiple monitor setup nor is this machine a laptop, just as described an extremely simple Intel 12400 custom build HTPC.

I did reinstall the OS and Roon again, but this time as Server only, because I can easily use this computer headless.

BTW, I just didn’t reinstall Roon but the whole darn OS and Roon (and I always back up my Roon database automatically every 3 days) to try and make sure that my OS install wasn’t somehow bad. But to no avail because Roon Server still gives me the exact same error and then promptly crashes the whole system and I need to reboot. Ironically it always happens at night when I am asleep but not when I am listening to music. (at least not yet)

I am going to try one thing you and the other person mentioned and that is to replace all Microsoft drivers with the ones from Asrock specifically for the m-itx motherboard.

I will report again in 3 days time.


I will look forward to hearing good news from you, James.

Kindest regards,

I wish there was some good news but I received the same error sometime during the evening (2.53am appx.) and that error prompted a shut down of Roon yet again.

I am at my wits end.

I am looking through the MS Even Viewer as I type this to try and find a clue to the culprit.

Hi @James_Caldwell,

Perhaps we can work around this altogether by trying Roon server.

You can download it from Downloads - Roon Labs just like the normal client.

Essentially, you’ll make a backup of your DBs, then go to Roon>Settings>General and log out of your core. Install the Roon Server application and when you do, click it in your system tray and be sure to set it to launch at startup. Then you’ll re-open Roon and log into the new core. You’ll then be able to re-import your DBs. This may offer you better stability with the added benefit of not having to keep the Roon UI open in order for the PC to function as a core.



Thank you for getting back to me so quickly. Just to let you know that I had already implemented your suggestion of just loading Roon Server. But it unfortunately did not help – the same problem exists. But before I get back to you I have decided to buy a new motherboard to replace the (new) one I already have because I have a sneaking suspicion something else is going on with my brand spanking new machine that is out of my control. I think I am having Intel ethernet issues which maybe interfering with Roon as well.

Just ordered the motherboard and I should have it next week sometime. It will be a simple switch out and then test phase. As of now I have to be a bit more patient.

For the time being I have turned off all LAN and WAN on the motherboard and I am using a USB3 to Ethernet adapter. If this works without the error messages that I consistently get, I will have found my suspicions to be correct. If not, I will still be waiting on the new motherboard to test Roon Server with it.

Not enjoying this all that much.


New motherboard installed this afternoon, hopefully it was the cause of my Roon problems. But now I will give it 3 days. If no errors come up during this time I will consider my MS OS/Roon issue, maybe a motherboard issue, resolved. Fingers crossed.


One day later and the computer has so far not thrown an exception so poorly that it crashed. But I did a search over the last 24 hours that I have had the new motherboard in place and found the following in the Windows 11 Even Viewer:

Application popup: RoonAppliance.exe - Application Error : The exception unknown software exception (0xe0434352) occurred in the application at location 0x00007FF9063F06BC.

Application popup: RoonAppliance.exe - System Error : A new guard page for the stack cannot be created.

I am not sure this will be of use to you or not, but I am forwarding it none-the-less, only because it is happening in the Roon application.

I will still get back to you in 2 days more time to let you know if within my 3 day monitoring period everything goes well enough. (at least not to crash the computer)

1 Like

I definitely collect all information and appreciate your communicating it. Looking forward to good news.


Well, I have for several days now had to restart my system, it just isn’t working even with the new motherboard. However the internet is doing just fine now and no other problems except for when I look into the Windows 11 Event Viewer I still find the following messages:

Application popup: RoonAppliance.exe - Application Error : The exception unknown software exception (0xe0434352) occurred in the application at location 0x00007FF9063F06BC.

Application popup: RoonAppliance.exe - System Error : A new guard page for the stack cannot be created.

Next week I am going to do another fresh install of Windows 11 and then Roon Server. I will see how that goes. If everything is still a loss I will try and go back to Windows 10.

At least at the moment during the day I am able to use Roon but I always have to reboot come morning.

Well after yet another install of the OS and Roon, and finally it has been working for over 4 days now. My install differed this time only because I installed everything from absolute scratch. A ground up install. Now my media computer is up and running with no errors so far for the last 4 days. And I am still on Windows 11.

Don’t think that Windows liked the refresh of the old installs with Roon even if they were an almost identical motherboard. (same drivers except for the 2.5Gbe ethernet adapter.

Admittedly it took far too many hours / days and weeks to get past an error I have never seen before but it’s done. (almost 1.5 months!!!) It’s nice to start listening to my music again.

I have also for the first time nixed Plex for music altogether now that Roon Arc is working just fine. A pleasant bonus. I will call this issue resolved. (I hope)

1 Like

I am so glad to hear this, @James_Caldwell. It’s “music” to my ears.

Please let us know if the problems come back and feel free to tag support if you do.

Enjoy the music,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.