Roon Error: Qobuz Media is Loading Slowly

Trialed Roon on my laptop(core) worked great across the board. Bought the Nucleus and i constantly get the followign error when i stream music from Qobuz. The Nucleus is connected to an ethernet cord and the ethernet is plugged into a wifi puck. I am not going into any more detail about configuration. How do i resolve this. I cannot connect the Nuceus directly to the router its too far away. There is something wrong with the Nucleus, when i ran Roon on my laptop it was only on Wifi, it wasnt tethered to the wifi puck. And I dont want to downgrade the resolution of my music files, that is the whole reason i have Qobuz.


connect it to the router first to see if that helps and stream from the Nucleus to your laptop speakers. wifi for a core is not recommended despite that it might have worked on laptop the PUCK has goodnesses knows what connectivity

if you don’t want to send a screen shot of the WEB GUI from the Nucleus you won’t get much more help as this info will be needed along with the rest of the network chain for the Nucleus to the internet.

Hello @Scott_Ballard, and welcome to the community! My apologies for the trouble here, but I second wizardofoz’s recommendation to try Nucleus on Ethernet as we do recommend Ethernet for the core in our networking best practices. If you could please move the Nucleus temporarily to test with an Ethernet connection, that would be a valuable step in troubleshooting this issue. Thanks!

Roon Core Machine


Networking Gear & Setup Details

ISP is Comcast.1GB connection into house. Cable into house is wired into Comcast issued modem.
Nucleus is hardwired into Comcast modem.
Laptop also hardwired into Comcast modem.
Download speed to all devices is >500mb.

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Not a network engineer. Simple setup, I have rebooted everything, and downgraded internet to MP3.

Not switching DNS this product should work with an ISP provided service. If it can’t then the limitation is on Roon not an ISP.

Because there is a ton of tickets on this subject what can Roon do to better support this problem. This clearly indicates a limitation of there product.

Hi @Scott_Ballard,

It looks like this issue was not resolved the first time your reported it, I have merged you new topic with the existing one so the history is together.

Let me tag Roon’s @support for you.

1 Like

Hey @Scott_Ballard,

It’s hard to believe we’re closing in to a year since you first experienced this issue — we are so sorry…:pleading_face:

Thank you for letting us know this error (Qobuz Media is Loading Slowly) is still happening and your thoughts on what would fix it. Our collaboration with Qobuz is ongoing and our teams are constantly working on improving the integration.

In the meantime, I was wondering if you could try the following steps:

  • Stop Roon Server from running in the Web UI
  • Find and open your RoonServer database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon Server via the WebUI and verify if the issue still occurs

We have seen this issue resolved by changing the DNS to Cloudfare or Google. Is there a reason why changing the DNS is not possible in your case?

Thanks Rebeka.

My license expires in 8 days and I wont be renewing it if this issue isnt resolved by then so we need to figure this out sooner rather than later.

If i power off the device I cannot access the cache folder you mention because the device is powered down. So i didnt power off the device. I did move the cache folder with the power on and rebooted and this didnt resolve the issue.

I cant change the DNS because I have a Comcast device and it doesnt allow that. Second I wouldnt know where to do this. Searching the web doesnt provide any great suggestions. Third Roon should work with a Comcast ISP. I think its ridiculous that Roon would expect a customer to have to make this type of change. This product should be more user friendly than this.

Lastly I have a hard drive added to the Nucleus with music files loaded to this drive and I get a network error when I play files from the Nucleus

An audio file is not loading this may indicate a hardware or network issue

Hello @Scott_Ballard ,

Can you please note the exact local time + date of the issue and then use these instructions to access logs and upload them here?

What audio outputs are you using? Is the behavior the same across all zones or just one zone in partriclar?

Does local library tracks work as expected, and only Qobuz is affected? If you don’t have any local library tracks to test with, you can download a few from the 2L Test Bench (right-click on the file size → save as).