Roon essentials and Ropieee (XL) - Roon ready

Hallo everybody,

I am a happy Elac music server user. For using it in a second zone, I would like to establish a Roon ready endpoint via Raspberry 3 B, Digi+ hat and Ropieee.

After installing it I can only see Ropieee XL in “airplay”. There is no “Roon ready ropieee”. No matter with XL version or without.

See: identifier fa2bb246e76cb4b3
Is there anybody out there who can help me out?

All the best to all of you, Rudi

Using Allo Digione sig. and Ropiee xl. No issues.
You do need to set the hat as the output, make sure you can see the Ropiee xl on the network.
Are you hard wired or WiFi?

Roon ≠ Roon Essentials
Maybe that causes the troubles here (@spockfish)?

Hi @Rudiger_Sandig,

Just to confirm, you have followed the Ropieee XL Getting Started instructions? Are you able to access the Ropieee XL Web UI (http://ropieeexl.local/)? Can you please share a screenshot of that page?

Thank you, Michael, I have set the hat correctly. Yes, I am on lan.

Hi @Rudiger_Sandig,

You will need to make some more configurations in the Ropieee WebUI for it to function properly with Roon. Please take a look at this additional Setup Guide.

Hi Noris,

well I have installed Ropieee as suggested. As said before, airplay works fine here but no Roon ready.

Hi Noris,

now I additional changed the hostname and the timezone. No changes at all.

@ BlackJack: Well I had a test account of Full Roon some month ago. not anymore. At the moment I rely fully on Roon Essentials.

Hi @Rudiger_Sandig,

Can you show us a screenshot of the ‘devices’ section in Roon?
The HAT is properly configured and detected, also by RoonBridge (this is all on the Pi side).
But i’m curious at your device section in Roon.


Hi spockfish,

thanks for your reply. I hope that is the screenshot you where asking for…

Thank you for your support.

Ok. That’s weird. Can you do me favor?

Disable Airplay (set the output to ‘off’), save it, reboot the device, and send me feedback.

And @noris, question for you: is there any kind of limitation with the Essentials product wrt the number of RAAT endpoints that you can hook up?

So everything as you requested.

Hi @Rudiger_Sandig / @spockfish ,

Roon Essentials and Roon are different products, and Essentials customers are entitled to direct support from Elac. While we’re happy for both products to be discussed on Community, for support you will definitely want to contact Elac directly for any questions about Roon Essentials. Thanks!

Hi @noris ,

That’s all fine, but if I (try to) help out @Rudiger_Sandig I want to make sure I’m not spending his (and mine) time trying to do something which potentially is not possible: hooking up other RAAT devices besides Elac products, hence the question.


This won’t help you, but from the Pi side of things everything seems fine.
I’m having doubts (see other posts) if this is possible with the Essential product.

Is it an option for you to ‘quickly’ install the full product and use the trial period to test this?

Thank you very much for this idea. Yes, I will do so and give you a reply by tomorrow. I am curious about this.

Best wishes to all of you, Rudi

Ok, feel free to reach out, I’m pretty sure we’ll solve this in the end :wink:

Enjoy your evening!