Roon Extension: Arcam AVR390/550/850/AV860/SR250 volume control


#1

I just replaced my Denon AVR with an Arcam AVR-550 and thus needed a new integration for volume control. If you are already running the Roon Extension Manager, the Arcam extension will be available after updating to the latest repository.

If you want to run the extension without using the extension manager, it’s available in GitHub.

Please keep in mind that I didn’t have much time to perform any long-term testing yet :wink:


(Wim) #2

Too bad you did not buy an NAD AVR … :slight_smile:


(Ethan Garner) #3

Yeah. I’m hoping someone makes a NAD volume control. It’s just a bunch of serial commands over the network, but I don’t have the bandwidth to code it myself.


#4

Looking at the protocol, it should be pretty straightforward to adopt the Arcam extension to NAD. Changes would be pretty much limit to arcam_client.js, which implements the actual communication protocol.


(Ethan Garner) #5

Hmm. I’ll try and give this a shot. Can I hit you up for advice, if I need it?


#6

Sure. I’ll be happy to help if I can.


(Sander Jongeleen) #7

This looks great: thanks for putting the effort in!

I followed the install steps and Roon now tells me that the extension is connected to my AVR850. The external volume control options for my zones remain grayed out however. Any idea what I might be missing?


#8

Did you go to the setup for you zone to associate the receiver with that zone?


(Sander Jongeleen) #9

Associate you receiver with your zone you must. Dear Yoda, please Guide me :slightly_smiling_face:

The extension shows connected, the external volume control setting in the zone I want to use is grayed out. How do I associate the receiver with a
zone? Is this in Settings -> Audio -> Device, or in Settings -> Setup -> Configure?

The latter keeps searching for devices, but never returns.


#10

I am not in front of Roon right now, but if there is a menu for the zone itself. I believe you can get there by clicking on the zone (bottom right). There you can set up a volume control extension for the zone.

Let me know if you don’t find it and I’ll try to give better instructions over the weekend.


(Sander Jongeleen) #11

The setting is indeed in Settings -> Audio -> Device.
Initially the option remained grayed out. Not sure if there is a causal link, but once I had changed the IP address of the Arcam to the wrong address, the option became available. I could then correct the IP address and things started working.


(Sander Jongeleen) #12

Hello Boris, I found your Roon driver for Neeo on Github. How do I determine the correct settings in settings.json? If I just copy your example, startup fails with “Error: Cannot read property ‘reduce’ of undefined”.


#13

Yeah, I got a little bit stuck with the Neeo extension and they did work on the SDK quite a lot. Not sure if that can easily be made to work at the moment. Sorry.


(Sander Jongeleen) #14

That’s a real pity! I wrote some simple drivers for my devices, but your Roon driver is definitely more complicated.


#15

Might be something I’ll have another look at during winter.


(Paul Weedon) #16

Hey @Boris_Pruessmann

Excuse the linux newby simple question.

I have Roon core running on an Ubuntu 18.04 server. I installed it using ssh from my MacBook following the manual installation instructions on the git hub page and have the extension running happily in Roon. but my question is how do I make the extension run continuously as it stops as soon I close the terminal window and so disappears from Roon.

Thanks


(Mr Fix It ) #17

Most extensions are run in the extension manager in roon under settings. I dont use this extension so maybe others will chime in here if this is not the case for this particular extension


#18

As mentioned by @wizardofoz you can use the extension manager to run roon extensions. There are a few other threads that describe running it. Personally, I would suggest running it inside docker.

The Arcam extension is available there, so you just need to follow the instructions.


(Paul Weedon) #19

thanks @Boris_Pruessmann if that’s your suggestion I will look into it after the break.