Roon Extension: Deep Harmony - rich feature set for Logitech Harmony


(Brett Kerbel) #343

I’m not following. When I click play in roon app, it starts playing track immediately and triggers the harmony activity to switch my dac input to roon endpoint. I don’t have a roon play command in my activity start sequence to delay.

I only use roon from the roon ipad or pc app. I never use harmony remote to control roon.


(Dan Brown) #344

Ah, sorry @Brett_Kerbel, I was thinking of it the other way round.

I have an activity in harmony that switches on all my kit, with relevant delays between powering up and setting inputs, then, finally a command to start Roon playback in the relevant zone.

I would struggle to do it the other way round as Roon doesn’t even see my endpoint until it is switched on and set to Ethernet input. So there’s no zone to play within Roon.


(Brett Kerbel) #345

I use Ultrarendu or RoonBridge or squeezebox as end points which are all always on.

My typical use case is finish watching a movie or tv show through surround system with multiple amps, av pre/pro bluray and projector and want to listen to some music next. I switch from harmony app on ipad to roon app on ipad, find something to listen to, and hit play in the roon app.

Because your extension is so awesome, this immedietely triggers the roon activity which shuts down all the surround gear and switches to my 2 channel setup. The only problem is roon starts playing right away as shutting down and switching to 2 channel setup takes time. My work around is to just pause playback and restart the track once the switching is done.

In an ideal world, i could configure a delayed start for roon playback when switching activities.

I can try adding some commands to my roon activity to stop roon and restart track after the rest of the sequence finishes. Im travelling for. Few days so wont be able to try this until the weekend.


(Isiah Lau) #346

Thanks, I tried and it behaved as you said. But how about turned equipment off? Should I do it at the remote?


(Dan Brown) #347

@Brett_Kerbel

If you trigger the Roon activity from within the Harmony app before you change app to Roon, then would that not be ok?


(Brett Kerbel) #348

Yes - that wotks fine. Just one extra step in use case above.

The other obvious use case is going from all off to roon music. With the extension i can go directly to roon app, select music, and play. Selecting play executes the start up sequence and i never need to open the harmony app.

Admittedly, this is very minor and the extra few seconds and few clicks is not cumbersome. Just thought if adding a configurable delay is possible it would make the start sequence slightly more streamlined.


#349

My workaround to this is to press pause immediately after play, then press play again once the amp etc are powered up by the harmony.

I also explored using resync delay setting under device settings, but as it is universal it would add more delay all the time, i.e. even when not needed, so haven’t changed the value.


(simon arnold) #350

Can you not change the order of powering them on in the activity and change the delays on the Roku device that’s used as the dummy to take Roon controls?


(simon arnold) #351

@Adam_Goodfellow is there anyway to get the extension to discover hubs that are on a different Vlans? I have moved most of my IoT devices of my main network on to their own vlan with no direct access to my main network. But the main network has access to the vlan. Currently the extension fails to find them. Do you think discovery could be done?


(Isiah Lau) #352

After I switched the playing music from living room (associated with this extension) to another room, all the amp/TV are still on. Is there anyway to turn them off (without searching and using my harmony remote).


(JohnV) #353

I am running the above extension and have also installed the Roon Extension Manager with Random Radio 0.2.0.

I noticed that the “dual function” forward/skip on Harmony does not skip (long press) when using Random Radio.

I presume that the reason for this is that RR is queue-less, i.e., there is nothing to skip to.

I was thinking that (if I’m right) the skip logic could be expanded to include “skip to end” in addition to “skip to next”.

This change would add functionality to both extensions.


#354

For those of us who want this feature but are concerned about the integrity of the hub, would’t it be better if Harmony implemented this as a “device” in the setup?

Why would they not?

Why wouldn’t Roon want to expand their reach as much as possible?


(JohnV) #355

For those who have already accepted the marginal risk associated with the Logitech extension, my proposed change would not add risk, only add a nice bit of extra functionality.

I can’t answer your “why” questions; sorry.


(Jan Koudijs) #356

Yes, that’s the reason. Also the Roon Remote has the next button disabled in this case.

What would be most logical is to change the Random Radio extension. The change would be that the next random track is queued at the start of the current track instead of at the end of the current track. Then you have something to skip to.

I will keep this change in mind, cannot say if or when it will happen.


(Larry Post) #357

I’ve been using the Deep Harmony extension for months. I often listen to my 2 channel setup and view video on my completely separate home theater setup. Until yesterday, I could choose to control either I wanted on the Harmony remote but yesterday when I play music in Roon it causes Harmony to switch to that Activity taking control from HT to 2ch.

How do I prevent switching activities? I only need transport controls in Roon, nothing else.


(Isiah Lau) #358

When I do zone transfer, the equipment of previous “activity linked” zone remain on. How can I trigger the “off” action in that “activity” so the equipment can be turned off automatically?


(André Fluri) #359

Hi Community
I have roon core running on synology 918+ without problem.
I have installed deep harmony extension in docker in host mode on the same network harmony hub running.
So in roon extensions i see deep harmony and the extension shows up my harmonyhub.
If I select connect to this hub “yes” it will stuck in an endless save task and nothing else matters.
Therefore I’m unable to connect to my marmony hub!

Has someone get the same problem? Or does someone have a solution or a hint what is causing this problem?

Thanks in advance for replies!
Andre

add: LogFile from Extension:
[20190310-130827.244]!   e[36;1mroon-extension-deep-harmony:harmony-discover e[0mHarmonyDiscovery - hub online aa11d621832af7b5f403c681fc88c5c6bfc00e17 [Flans-MyHome] @ 192.168.5.133) e[36m+438mse[0m
[20190310-130830.558]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - connecting to 192.168.5.133 e[35m+5se[0m
[20190310-130830.578]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - connect failed Error: connect ECONNREFUSED 192.168.5.133:5222 e[35m+20mse[0m
[20190310-130830.578]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - retrying 192.168.5.133 (infinate attempts remaining) e[35m+0mse[0m
[20190310-130835.578]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - connecting to 192.168.5.133 e[35m+5se[0m
[20190310-130835.598]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - connect failed Error: connect ECONNREFUSED 192.168.5.133:5222 e[35m+20mse[0m
[20190310-130835.598]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - retrying 192.168.5.133 (infinate attempts remaining) e[35m+0mse[0m
[20190310-130840.599]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - connecting to 192.168.5.133 e[35m+5se[0m
[20190310-130840.622]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - connect failed Error: connect ECONNREFUSED 192.168.5.133:5222 e[35m+23mse[0m
[20190310-130840.622]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - retrying 192.168.5.133 (infinate attempts remaining) e[35m+0mse[0m
[20190310-130845.623]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - connecting to 192.168.5.133 e[35m+5se[0m
[20190310-130845.638]!   e[35;1mroon-extension-deep-harmony:harmony e[0mHarmonyConnect [1:1] - connect failed Error: connect ECONNREFUSED 192.168.5.133:5222 e[35m+15mse[0m

It looks like it cannot connect to Hub, but I dont know why. I’m in local network only and disabled firewall in Synology!


(Michael Kulig) #360

Hi,
I am experiencing the same problem. It’s not only with the extension of kazuhl but also DrBobo.


(Michael Kulig) #361

Problem solved. The firmware of the hub updated once again. Made the downgrade as described here:
Successfully downgraded my hub to 4.15.193 and restored API access. Full repro:

  1. Launch MyHarmony app on PC.
  2. Press Alt+F9 to open the advanced tools menu
  3. Scroll the window to find your Harmony model.
  4. Select “Factory Reset” for the appropriate model. This does not do anything immediately.
  5. Steps 1-4 will be displayed for completing a Factory Reset. We are only doing Step 1 . “Restore” here means “Rollback”.
  6. Connect your Harmony hub to the PC via micro-USB.
  7. Within a few minutes, it will be detected by MyHarmony and display Remote Model, Firmware Version, and Hardware revision. The Restore button will be enabled.
  8. Click “Restore” and wait. (Now is the first time that it actually describes that it’s a rollback!)
  9. When it completes, you should be on Firmware Version 4.15.193. Disconnect the hub from the PC and return it to its original location.

And the final, important step: eliminate the ability for the Harmony hub to access these domains, or the internet altogether. I used DD-WRT’s Access Restrictions feature to disable all internet access, because my specific implementation is entirely intranet-based. YMMV.


(simon arnold) #362

No need for that now as they added it back in the latest firmware, you just have to enable xmpp in the hubs setting, they just warn you now about secuirty