Roon Extension: Publish to MQTT broker

How I can do that? In roon setup under extensions, when I choose mqtt extension, I can only set IP adress of mosquito server, so roon after that, can connect to server.
There is no other options for setup.

Only if you doing that from linux cli?

My config window looks like this, yours too?

No, totally diferent, I have old version 0.1, i think this is problem. Tomorow I will try upgrade. Thx!

Wher did you find version 2.2.0 ? Im searching eveywhere withouth luck!

I did

Git clone
With his GitHub page

And then followed the instructions

The extension is also available in the Extension Manager.

By installing the extension manager you can easily install multiple extensions.

Still no luck, everything is working, except control roon.
Is there be topic command on path roon/(zone-name)/ when I send play command, to path roon/BeoSound/command/ , I see newly created topic command, but nothing happened.
Same issue with old version 0.1 and new version 2.2.0
Anybody have idea what is wrong?

Try topic roon/BeoSound/command without a trailing /

Hi.
I am trying to install the extension using the extension manager on a dietPI rpi.
When I trigger the install from a roon client the manager crashes with the error file /root/.roonextensions/lib/node_modules/roon-extension-mqtt/.npmignore not found.
I could install other extensions successfully.
Any idea?

Actually the path is wrong. The directory where the extension gets installed is roon-mqtt-extension, not roon-extension-mqtt

The Extension Manager expects that the name of the git repository and the name in the package.json are the same, which is not the case for the MQTT extension. Maybe @eFJee can align the two, that will probably fix the install issue.

1 Like

I changed the package.json, so the git repository and the package match as of now.

1 Like

It worked now. Thanks!

1 Like

Hi, big thanks for creating this extension.
I am using it on a QNAP with the extension manager in a docker container. My mqtt broker is running without any problems or advanced settings (no auth or ssl)
Currently, I must enable it daily (by Settings > Extensions).
Is there any way to keep it enabled?

Does the docker container stay online, or is it restarted daily? If so, maybe the config volume is not mapped/mounted correctly inside the container.

Seems like the extension manager starts update at 1:00 and stuck on (get a few hunderd of these messages)
-> CONTINUE 1 Changed {“message”:“Updating: roon-mqtt-extension…”,“is_error”:false}
until I connect to Roon again manually
Core lost: [CoreName]
I’ve set the logging on debug now, let’s see what tomorrow brings.
Seems like a roon-extension-manager related issue?

I think so, probably related to an issue with the docker volume not mapped to the config directory in the container.
When that is the case and the container is re-created or restarted it will have an empty configuration and will have lost the association with the core.

@Jan_Koudijs Did I miss something in the repository entry for the extension?

Hi @Robbert_N,

Please try the steps listed in this post:


In order to keep the configuration of the installed extensions it is important that you create a Docker volume for the extensions when you create the Extension Manager container.

At the command line this is done with:

-v roon-extensions:/root/.RoonExtensions/lib

If you use the web interface of the QNAP you have to check how to create volumes there.

I’ve de-installed, uninstalled and installed the MQTT extension. Currently it’s on 2.2.0.
Yes, my compose file is as follow:

version: "3"
services:
  roon:
    image: theappgineer/roon-extension-manager:latest
    container_name: roon-extension-manager
    restart: unless-stopped
    volumes:
      - ./roon-extensions:/root/.RoonExtensions/lib
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/Amsterdam
    network_mode: host

volumes:
  roon-extensions:
    external: true

You specified a relative path in the volume definition (./roon-extensions), I don’t know how that is treated by Docker. Please remove the leading ./ and create a new container.

1 Like