Roon Extension: Rotel Volume/Source Control


(Boris Schaedler) #1

Hi all,

I just published a first version of my new ‘Rotel Volume/Source Control Extension’ on GitHub:

It uses the network interface (not RS232) of a Rotel amplifier to control volume, source and standby. I’m using it with my Rotel RC 1590 preamp but it should work with other Rotel devices, too, as long as the protocol is equal. This depends on the exact model and/or firmware of the Rotel amp.

Are there any Rotel users around here? Which Rotel amp do you use?

Any feedback is welcome, have fun!


Roon Extension Manager v0.8.1
(Norwin van Mourik) #2

Many thanks, looking into buying a Rotel preamp RC 1572 so this is very helpful. Unfortunately I am not an expert on Linux but managed to get Roon extensions working o2n an RPI with Dietpi installed and can add additional extensions providing they are visible in Roon.

@Jan_Koudijs will this extension be taken up as well same as the other ones there are?

Regards,
Norwin


(Jan Koudijs) #3

If it’s OK with @Boris_Schaedler then it can be included.


(Boris Schaedler) #4

Sure @Jan_Koudijs go ahead! I did not look into the extension manager until now, so how or where are other extensions added?

@Norwin_van_Mourik let me know if everything works as intended with the RC 1572. Don’t forget to set the power mode to ‘quick’, otherwise the network part of the preamp will also be down when you turn it off…


(Jan Koudijs) #5

I have sent you a PM with more information.


(Jan Koudijs) #6

This extension is now included in the Extension Repository. Check this post for details.

Thanks @Boris_Schaedler for creating the Rotel extension!

Thanks @Norwin_van_Mourik for suggesting inclusion!


(Norwin van Mourik) #7

Thanks both. Now I can safely purchase the Rotel end of the month. Looking forward.

Regards,
Norwin


(J. V.) #8

I have a Rotel RCX-1500

however it seems to have different protocol, because the extension cannot connect to my rotel :frowning:


(Boris Schaedler) #9

Hi Jasper,
is your firmware up to date? What version do you have?


(J. V.) #10

boris,

i’m completely up to date

all firmwares from the bwsupport site are all installed:

http://bwgroupsupport.com/download/software --> select RCX1500 (all these are installed, latest version was BT from 2015… after that no new versions came out)

i allways get connection refused when i enter the ip of my rotel in the extension


(Boris Schaedler) #11

I had a look at the manual/docu of the RCX 1500:
Please correct me if I’m wrong, but as far as I understand the docu, this device is not capable of being controlled over IP, just over RS232. So there is nothing I can do, sorry.

I’m not sure, but what about an IP-to-RS232-adapter? Could this be a solution? Just an idea! The protocol itself seems to be the same…


#12

There’s a app that can control this receiver. That means their is a way to do it. Apparently (sadly) this way is not officially documented.


(Boris Schaedler) #13

Typically the TCP/IP port is well documented, in the case of my RC 1590 the port is 9590. In the RCX 1500 docu no TCP/IP port is mentioned, but there are Rotel devices listening at port 9596.
@goat Could you try port 9596 instead of 9590 (see extension settings)?


(J. V.) #14

Boris

still connection refused on both ports

the remote app on ios however is working

i just ran a port scan to discover open ports, but i cannot find open ports…


(Boris Schaedler) #15

Strange… By the way, how is your Rotel connected to the network? USB WiFi dongle? You could try to use telnet to establish a connection, just for testing purposes…


(J. V.) #16

Bob, yes connected to WIFI USB dongle

I’ll try telnet later today


(Boris Schaedler) #17

Hello again,

I found some document: http://iradioforum.net/library/RotelRemote/A%20remote%20control%20program%20for%20Rotel%20devices.pdf

According to that document:

  • The Rotel Remote iOs app uses UPnP to communicate with the device
  • To control your Rotel you will have to use the serial port. In the document some TCP/IP to serial converter is mentioned (Hexin HXSP-2108E-A).

Regards,
Boris


(Daniel LEVY) #18

Works fine with RA 1592 :wink:

I am testing roon but I think I will buy !

Daniel


(Scott Houston) #19

Boris,

Thank you very much. This is an excellent extension – much kudos to you for getting it up and running.

I am running it via Ropieee, using an OMSC remote control, on a Pi with display. Which then controls an Allo USBridge, connected to an RC-1590. So that seems like a relatively complex connection scenario, but it works just fine.

For any future users, the correct naming for the PC-USB connection is pc_usb (http://www.rotel.com/sites/default/files/product/rs232/RC1590%20Protocol.pdf).

Only one suggestion, if I might be so bold – I actually have three Rotel devices (2 x RC-1590, 1 x RA-1592 – lots of amplification in our house) – as far as I can tell, I can only control one device. This is much better than no devices; but if you are looking for a challenge, there you go … :slight_smile:

Once again, a huge thank you – a great little add in.

Scott.


(Boris Schaedler) #20

Thank you Scott,

Good news: this is already implemented :wink:

You can run multiple instances of the extension, just specify an instance name like so:

node . -inst:your_instance_name

In my case I have two rooms connected to my RC1590 (different inputs), one Raspi and one Sonos device. I start the first instance of my extension with no parameters:

node .

and the second instance like this:

node . -inst:sonos

This just makes sure the used ids of each instance are unique. In Roon it then looks like this:

Hope, this works for you, just start one instance for each of your amps!

Happy new year! :beers: