Roon Extension: Rotel Volume/Source Control

Hi Boris,
thanks for your response. Here is what I found:
Rotel FW version: 3.0-EU ( I think it’s the latest)
More details on the source control issue:
When Rotel is on Phono and I start Roon music play ( on Rotel zone), then Rotel source changes to COAX1, but no music although Roon is playing. To fix it, I manually switch back to Phono (this causes Roon music to stop). THen I manually swithch back to COAX1 ( Roon still in Pause mode) Musich starts when I hit PLay on Roon. Hope it’s clear… Karl

Hi Karl,
yes it’s clear now :wink:
I do not really know what is going wrong here. Do you know how to use ‘telnet’ or ‘putty’ or something like this? You could connect to your amp from command line and enter some commands, just to check if it behaves the same way. Do you know the protocol documentation? You can find it here:
RA1572 Command List
Would that be possible?

Thanks, Boris,

I’ve used putty to log on remotely to linux, but I never tried to send commands … I can play around and find out, but I won’t get to it till next week ( away over the weekend) … any hints how to do this would be appreciated :wink:

OK - I figured it out & tested it: the RA 1572 reacts correct to commands like vol_22! ( set volume to 22) or vol_up! ( increase volume by 1)

What I meant is: What happens if you switch the input to coax1! from command line, do you have sound or no sound?


Yes, if I switch to coax1 from command line, it works. But if I hit play in Roon (while Rotel was on Phono), the input changes to coax1, but if I queery ‘freq?’ using command line, it returns ‘freq=off’

This is what my extension does when it switches to your roon input:

        this._write(source + "!");

This results in: power_on!coax1!source?
What happens if you enter this as a single command from command line (type all and press enter once)? Can you somehow reproduce the freq=off-behavior?
When freq=off, can you somehow activate the input, for example with mute_on!mute_off! or something similar?

… I’ll test this early next week – need to focus on other business now… :wink:

Thanks for sharing and the great idea for Roon and Rotel product users.
I installed tonight the ‘roon-extension-rotel-master’ extension.
I can see the extension in the ‘Extensions’ section of Roon
The extension is I think well configured because it indicates to be connected on my Rotel product.
However, I don’t see how to use it since I don’t have an additional option for the target volume for listening.
What am I missing?
Thank you in advance for your help.

Hi Didier,

Did you go to device settings and select the extension as volume control (and source control)?


Hi Boris - many thanks for this, I have the volume control working successfully with the Rotel A14 Mk2. There is an issue with the Source Control though, which I suspect is nothing to do with your extension. I can put the amp into standby, but then it disappears from Roon and I can’t switch it on again with Roon Remote. This is different standby behaviour from my old Audiolab amp. I suspect it has something to do with this:

There is no reference to Signal Sense in my amp’s menus (I’m in the UK), though there is a setting for Power Mode, which I have set to Quick as suggested.

I’m wondering if I used a VPN at the router level and switched to USA the Rotel would update the firmware and unlock the functionality?

Anyway, excellent extension, great being able to use device volume!

1 Like

Hi Franko,

One question… How is your Rotel connected to roon? Roon bridge? USB?


It’s attached to a nuc via USB

And the Nuc is your roon core?

I think the problem is that the USB port is also turned off when you power off your amp, that’s why the endpoint disappears in roon. If you want to power on your amp automatically when you start playing some music, you’ll need a roon endpoint that does not get powered off. In my case this is just a Raspberry Pi (with roon bridge installed) connected to my Rotel (toslink), the Pi never gets turned off so the endpoint is always visible to roon.
Would it be possible to install the roon bridge on your Nuc (assuming the Nuc is always powered on) and use the bridge as always on roon endpoint? Just an idea…

Thanks Boris. Yes, to clarify, the Nuc is the core and is directly connected to the A14mk2 via USB/Wasapi. The Nuc is running Windows 11, and is kept on 90% of the time. I don’t see why a pi would behave differently. The change in behaviour seems like it is on the amp side, as my Audiolab M-one amp/dac used to be visible in Roon when on standby.

p.s - I think I see what you are getting at re. bridge. I am going to get around to seperating the core/endpoint in my living room at some point. But at present the Nuc doubles up on general video/media centre duties as well. Thanks

Haha - sussed it. I switched to Rotel’s Asio driver instead of their Wasapi driver and the source control now works properly. I was thinking back to my Audiolab and it only came with a manufacturers Asio driver, so I gave it a go.

1 Like

Thanks for letting us know the solution, I’m glad it works now!

Hi Karl,
I wnated to know how you were able to sent the command vol_22! towards the Rotel?
I am logged on via PuTTY (ssh) on the Raspberry Pi with teh Rotel Volume/source Control installed.
But when I type node . I am not able to sent any command towards the Rotel.
So I presume I have to do it in another way, but I couldn’t figure it out.
The Rotel Volume/Source Control is working 100% correct for the volume. I can change the volume via a Roon app. That is working perfectly.
But the source-control is not working. My input is bal_xlr, but when I change to whatever other source, the Roon-player is not paused. And when I push on the Roon-player on “Play”, the source is not changed to bal_xlr. So that is the reason that I want to check what is happening when I sent commands directly to the Rotel RC1590.
Kind regards, Frank.

Hi @Frank_M
You have to connect to your Rotel directly, you can use putty like this:


You have to use the correct IP address of your Rotel of course and you may have to change the port, depends on the model you have. Which Rotel do you have? (Ok, I saw it, RC1590 should be port 9590)

After the connection is established you will see something like this:


You will see what the Rotel sends und you can enter commands like vol_22!. Have a look at the documentation for your model.

Please note:
You may have to terminate the extension to be able to connect to your Rotel.

Hope this helps,

Hi Boris,
Thank you for this info.
I can now sent the commands and the Rotel RC1590 is reacting correctly.
Nevertheless, I cannot pause Roon when I switch on the Rotel to another source. And the source is not changed to bal_xlr when I push on Play in Roon. What could be the reason?
By the way, thank you so much for such a fantastic software! I like it very much to be able to change the volume of my Rotel RC1590 from the Roon app.
Kind regards, Frank.