Roon gets confused with two Raspi4 running Volumio

Core Machine (Operating system/System info/Roon build number)
Win 10, latest Roon build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Two Rasp4, each running Volumio

Description Of Issue

I have two identical Raspi4 both running Volumio. They have different names and fixed, different, IP addresses. Both are connected to a Win10 core via Ethernet. For one I enabled HDMI as output and named it accordingly. For the other I use an Apple USBC dongle, also named accordingly.
I can not see both Raspis when they are switched on simultaneously.
Roon has only one Volumio tag in devices and hence reports only one ip number, selecting one of the two at random. And then I can only see the output port of that
Is this a bug or a „feature“? With Raspi4s being a cheap Roon endpoint, I would imagine that more people will run into that issue. Is there an easy fix for that?

Are you running RoonBridge on the RPi’s?

At one point, I had 3 RPi’s running RoonBridge on Volumio. Worked fine.

(I still have the RPi’s, but I’m slowly converting them to moOde.)

Yes, I have the RoonBridge installed as Volumio plugin.

Hmmm. I’ve never tried their plugin. I simply installed RoonBridge directly, and have it running in parallel to the Volumio player.

Does it enable the HDMI port for output?

So it appears:

And what happens when you switch another Raspi4 on?

I have three of them. Roon has no trouble keeping track of which is which.

Evidently, your problem is with the Volumio plugin, not with RoonBridge on RPi.

How did you build your software on the Pi’s? Did you clone one to put on the other?

1 Like

Yes, I cloned. I then renamed one to Volumio2 from within Volumio. MyVolumio sees these different names, while Roon calls each one Volumio. I guess the Roon plugin does to read the new name somehow.

You can’t clone them, they have to be separate builds. The same happens if you clone Ropieee.


I was about to ask the same question and give the same answer.

1 Like

Good to know that it is not Roon‘s problem. I will try a rebuild and try again.

1 Like

I re-installed Volumio and all is good now: Roon sees both Volumios, all is fine.


Great news!

Glad to hear that you resolved this issue via a reinstall of Volumio @Joachim_Strobel!
Do let us know if you run into any other issues with Roon.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.