Roon hanging at login screen when Mac app starts

MacBookPro15,3 running macOS 10.15.1 (19B88) with Roon 1.6 (Build 475)

Running over wifi via Linksys Velop network running firmware All nodes up to date.

Using Apogee Grove DAC via USB

Had to re-install Mac Catalina operating system as it became corrupt and would not consistently operate. Restored my Mac data via a Time Machine back up. Been stuck at Roon login screen since. Also tried a restore from within the Roon app from both my Mac hard drive and a copy of a Roon back-up I keep on my iCloud Drive. Neither worked.


Time Machine recovery and Roon don’t mix well, so assuming you have a recent Roon DB backup …I suggest …

  • Uninstalling Roon completely (including the Roon DB).
  • Install Roon from scratch
  • Start Roon and then load your Roon DB backup.


Thanks - remind me where the Roon DB is on my Mac

I’m not a Mac, but iirc it’s documented in the Roon Knowledge Base.

Probably best to rename that folder, just in case, rather than deleting it straight off.

You should be fine going into your Applications folder, selecting Roon and moving this to the Trash. Then from Finder, click Go and press the option key and select Library from the list. In the window that opens look for Roon* and move this to the trash.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.