Roon has ceased to work

Description Of Issue

Roos doesn’t start anymore. I have rebooted the system with no succes. I have deleted the driver of the videocard and reinstalled it. Nothing seems to work. Please help.

Roon Error 03-11-2020 pc

Hi @Ronald_Kruit,

Does a reboot help?

If not, would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link? Thanks!

Hello Dylan,

A reboot doesn’t solve the problem. Tried to restart the program al lot of times today. I have send the logs over via the link below.

Best regards Ronald

Thanks for sending that over, @Ronald_Kruit. We’ll follow up soon with our findings.


Actually @Ronald_Kruit — Taking a brief look at the logs, they’re very short and not showing much information. In order to get the full picture I think we’ll need to see the Event Viewer logs:

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log... from the context menu
  5. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  6. Right click on the Application subsection again and pick Save filtered log file as.. from the context menu
  7. Enter the log file name, for e.g. Roon_USERNAME , and press Save

Send over this file and we’ll take a look. Thank you!

Hello Dylan,

I have made a copy of the Events. I listed it down below.

Best Regards Ronald

Hello @Ronald_Kruit, and thanks for uploading that! I’m passing this information over to our QA team and will return shortly with their feedback.

Hi @Ronald_Kruit,

We had a chat with our developers about this today. Based on what we are seeing in the logs you shared, the graphics drivers do not support OpenGL 3.0, which is a requirement for Roon.

Sometimes this can happen if generic drivers that aren’t GPU specific are being installed by Windows. You previously mentioned this:

How did you reinstall the drivers? Did you download them directly from the manufacturer’s website? Relying on Windows to automatically install drivers can be a bit unreliable, so trying to install them directly from the manufacturer’s site is going to be the best bet here. Can you give that a try and let us know if you see any change?

1 Like

Hello Dylan,

I had a problem in the past with an old machine. Last summer I invested in a new, professional, computer. I had no problems at all with Roon. Why does it goes wrong every time. Can’t figure it out.

Roon stopt from one day into another and then it has to do with my videocard witch is working perfectly fine.

I have updated the drivers from the Intel site directly. Also tried it thru the device manager.

If a new computer can’t run Roon because of a softwareupdate there goes something wrong.

Best regards Ronald

May be of use to you to check the supported GL versions of your currently installed graphics driver.

The software download OpenGL extensions viewer 6.1 will produce a report . This from my laptop

1 Like

Down below I have post a screenshot from my report.

To me that indicates you have the latest Intel drivers and support for OpenGL 3… As an aside the only issue I’ve had with Roon on windows recently was the October update 2020H2 which completely blocked core access and the firewall rules had to be removed and reinstituted to restore functionality.

Can you tell me how i can do that?

I hope you can help me. This is very frustrating. I have removerd Roon from the computer, restarted the computer and reinstalled it. Roos simply doesn’t wordk anymore. Can’t listen to music at all at this moment.


Can you try running the Intel Driver tool and let us know if that helps?


Hello Dylan.

I have installed the software and all the drivers are up to date. When I install Roon I don’t get the questions for the firewall. I got them when installing Roon Server. I have installed the server software because I can’t listen to my music anymore.

So could it be a problem with the firewall?

Regards Ronald

Hi @Ronald_Kruit,

It’s unlikely that it would be a firewall issue (we haven’t seen a firewall do this before) but it is possible — You could try disabling it completely temporarily and see if that changes anything.

To elaborate a bit on what is happening:

Roon requires OpenGL 3.0 support in order to function properly. What we are seeing in the logs we’ve looked at with our development team is that OpenGL is not working (it fails to even begin loading OpenGL capabilities) which results in Roon crashing, because those requirements are not there.

Normally this type of thing can happen if there’s a problem with the machine’s graphics drivers, which is why we suggested uninstalling/reinstalling the drivers.

The Intel Driver tool I shared also normally does a good job of making sure that all drivers are there and working properly.

Since this doesn’t currently seem like a driver issue, it’s possible there is something else suppressing OpenGL functionality. Firewall would be a good test, but there could be other apps doing this as well.

Do you have multiple monitors? Are you using something like Display Fusion to manage them if so? We’ve seen apps like that suppress OpenGL in the past.

Hello Dylan,

Apologies for the late reaction. I have found the problem. The videocard, I only use for hdmi audio, was causing the problem. There was no monitor connected to that hdmi port. It is a Nvidia GeForce GT710. I had it for a half year in my computer. All worked well till the windows update a few weeks ago.

The card is still present but disabled in the systemconfiguration. That cutts off my sound as well. Need to search for another solution for that.

Roon is working like before after I disabeled the card.

Best regards Ronald

PS. I have bought a Sonos Move for the kitchen and for outdoors. Is it possible that the batterycapasity becomes visible in Roon? Now I have to have the Sonos app installed on my phone. When it would be visible in Roon at the zone info (volume ect.) would be nice. Or that the icon of the Sonos Move could show it.

Hi @Ronald_Kruit,

Thanks for the update! That makes sense. One thing I would suggest is completely removing all drivers for the Nvidia GPU and reinstall them from Nvidia directly. We’ve seen Windows updates cause some issues with GPU drivers in the past so that’s worth a try here.

Regarding the Sonos — It’s not currently possible to display the batter status. I’d definitely make a #roon:feature-requests request for that, though!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.