Roon has not reindexed-added content since initial indexing / even when manually forced to reindex to find added content

Core Machine (Operating system/System info/Roon build number)
Roon 1.7 (build 511) stable (64 bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Router = Netgear R7000
NAS = ReadyNAS RN-214
RJ45 connecting Roon to switch to Router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Moon 280D that is RJ45 connected to the switch connected to the Router, running out to my Receiver by RCA Phono connections.

Description Of Issue
Since the initial indexing we have:

  1. Made new subdirectories under existing and previously indexed subdirectories.
  2. Moved some tracks (files) from the higher (in tree structure) original subdirectory to new subdirectories under that one. Also renamed and added some tracks in those new lower level subdirectories.
  3. Elsewhere within our indexed directory tree we created a two new subdirectories under a different, existing musician-named subdirectory and copied over two newly ripped CDs to there.

None of those files have shown up in Roon.

On two different days I have gone to Settings, Storage and did a Force A Rescan at the particular IP/directory (which reads Connected. Watching for files in real time. From that one folder (of two folders we imported and track) there have been 106066 tracks imported.

So, in essence, Roon’s indexing has only worked once. That said, we have heard our NAS disks spinning more often night and day since installing Roon. So, while it is ‘touching’ our data drives Roon is not updating itself, even not in real time.

Please tell us how to fix this problem

What is your OS?
Have you restarted Roon?

Win 10 Pro. No I have not manually shut down Roon and restart. I will try that. (But Roon should not have to be shut down and restarted every time a new directory is created and a new album is put there.)

After the cold shut down and reboot Roon reread the subdirectories and found and added what were the missing files. I’ve now added another new file in a new directory and am waiting to see how long it will take for Roon to find and list it.

Hi @B_roon,

Can you share a screenshot of Settings > Storage?

Just to confirm, forcing a rescan also doesn’t work, only the reboot of the Core machine has worked so far?

Forcing a cold shutdown and doing a cold reboot did result in a rescan and after about 45 minutes the subdirectories and files I added after what was there at first-time scan for Roon then appeared. Next, for a test, I added another single new subdirectory and moved a single MP3 file into it. I then waited to see when/if Roon would find it. Two hours past and nothing. I shut down my computer for the night. 9 hours later I boot up my computer and open the Roon app. There is my last newly added file. (So, in my mind, it took more than 2 but fewer than 9 hours for Roon to do a rescan update and find which files did not already have an ‘archive bit’.)

Question: When the first added group of files did not appear after 48 hours I ran a force rescan from Settings. No luck. About two hours after that I ran a second forced rescan. Still nothing. But after the reboot, it then read from the same drive/directory path it was set up to point to. What gives? What could cause this? And what, based on the detail of my explanations to you folks, do I need to keep on the lookout for? Thanks.

Hi @B_roon,

The real time watching feature requires the storage device to properly update Roon whenever new files are added. In the past we’ve seen that some NAS devices aren’t the best at reporting these new files and so we aren’t able to pick up on them right away.

What I would recommend is going to settings > Storage, clicking Edit for your watched folders, and setting the Automatic Rescan Interval to a lower settings. This will change how often Roon is automatically rescanning the folder for changes. See a screenshot of this setting below:

I note it already was set on 4 hours by default. You were suggesting it be on 4, right?

Question: If I change the setting to 24 hours will that reduce drive churn?

Typically, my NAS drives are pretty quiet. It is used to drag and drop/store files on. The NAS is not used to actively make and edit work related documents, for instance. If I am editing/EQing the occasional audio file that happens directly on the NAS,

Also, were I to move from 4 hours to 24, and then, say, a week from now add a bunch of new content that Roon needs to scan – if I change the setting from 24 hours to 4 hours would that kick Roon into immediately starting to read/index?

Hi @B_roon,

4 is the default, but you can set it to whatever you’d like. If you’d like Roon to check more regularly, then you can lower it to 1 hour. If you want Roon to check less regularly, you can set it to 24. If you set it to 24 hours, Roon will scan the much less often.

No, you would need to wait for either the 4 hours to pass or choose the force scan option.

Any thoughts as to why the Force Scan that I twice ran (before doing the cold shutdown and reboot) ran but failed to find and add the new files?

HI @B_roon,

Choosing force scan should cause a scan and find these files — Can you confirm that this behavior is still occurring (i.e. new music is added and Force Scan does not result in them being found)?

Since I did the one time cold reboot the system has been working as it is meant to. I’ve since tested further by deleting a file and, upon the next auto scan it was removed. Also, I re-ripped a CD and put that new copy in a subdirectory. It did NOT show up as a new entry on the Home screen (which is set to show latest additions. I then did a search on the musician. There I found, listed down at the bottom of albums, the album with the ‘New’ banner on it, and the notation of duplicate.

So, the OS is almost working properly. I since set the new duplicate as the Primary version. Now, I renamed the subdirectory in which it resides and will wait to see if/when Roon identifies this modification and updates itself to accommodate.

I assume you have no inkling as to why the cold reboot was required (and that force rescans prior to then did run but did not identify the added albums at that time).

Hi @B_roon,

It’s hard to say why things weren’t working prior to the reboot. If you get into this state again we can try to do some further troubleshooting to better understand why that occurred, but I’m glad things are working for you at the moment.

Me, too! Thanks Dylan.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.