Roon has stopped working on QNAP

Core Machine

QNAP HS-453DX 8G1 x 256gb SSD (Roon only), 2 x 6TB WD RED

Network Devices

Virgin Superhub, Modem Mode, Asus ROG GT-AX11000, Netgear Switch

Audio Devices

Library Size


Description of Issue

Roon has been working relatively fine for years, no changes at all to anything.

Woke up yesterday, Roon wouldn’t open, just spinning circle. Did the usual. restart Roon, restart NAS, still nothing, still wouldn’t load. Restarted Router, switch, all devices etc. Nothing.

Tried to reinstall Roon on QNAP but doesn’t work. Tried to download Roon log - nothing, fails to work.

Removed Roon OS from MacBook and reinstalled

Tried to upload music library, and it gets about six albums in and then stops. Circle just keeps spinning, no more albums get added.

Looked on QNAP and for some reason it shows my ROON database as 100% of 16mb? Checked the SSD in QNAP and its still showing healthy with full capacity.

Roon is not available in QNAPS App store currently, so cannot remove and reinstall.

Can anyone help?! I am completely at a loss with this…

@crieke ?

Try reinstall, you can download Roon for QNAP manually from here: RoonOnNAS – User your NAS as a Roon Core

It’s recommended to read this whole thread, might have somehing to do with your problem also:

1 Like

Thanks for your reply.

I cant see where I can download it from on the link, it just directs me to the QNAP APP store, where its been removed because of the security issue.

I’ve read through that thread, but can’t understand why I would be affected, or why not all QNAP/ROON users are having the same issue?

16 MB is definitely not enough for Roon – check the database location. Is (was) your DB stored on an external SSD? Maybe this SSD wasn’t ready for some reason when the system started and the App changed the path to some default location. Anyway, Mr. Riecke should know more about this issue.

1 Like

The DB is stored on an internal 256GB SSD in the QNAP, with media on WD Reds 6TB, in RAID.

I’ve just uploaded Chris’s new Roon and music seems to be being added, so fingers crossed it was all the QNAP issue that caused it!

The 16MB thing has baffled me as it still states 16mb even on Chris’s new release.

Hmm, good question. According to this message there should be a file on the site for manual installation: QNAP security advisory for Roon Server - #48 by crieke

And yes that 16mb is something to worry about. Check your SSD/HDD configuration on QNAP settings. Also make sure that Roon actually installs on the correct location.

I thought that since Roon released new version today it might have automatically update on your QNAP and maybe it had something to do with this because QNAP has removed Roon app from their official appstore due the security breach. I’m home in two hours so I have to try if mine still works :slight_smile:

1 Like

Sadly, it was all going well, then it stopped again. It loaded more albums this time, but now just spinning wheel.

I dont really know how to check where this 16mg issue is coming from tbh? Not very tech savvy although have limited knowledge that got it all up and working in the first place.

The problem must be that 16mb thing. Mine says 117gb space on my 128gb SSD and 52% in use so Roon uses ~60gb. Try to change database location from the button?

I installed the version released today and everything works fine on my QNAP TS-253D. I also installed the latest Roon app version by @crieke and everything works as usual.


Roon core obviously doesn’t use all 60gb but only little bit over 10gb. Roon databse backup takes about another 10gb.

1 Like

Ye I think you’re right. I’m not entirely sure what to do about it, as I can change location, but the drive is still where I need it to be! So realistically, Id just be making another folder say ‘Roon 2’ on that drive, and then choosing that as the location.

I presume Ill lose all my database info by doing this?

You shouldn’t lose your databse, it just moves it. Also be sure to make backup before moving anything.

But you should check from QNAP Storage & Snapshots app that everything is configured and works as it should with your SSD/HDD.


Thanks for your help @patouskii

I created a new folder on the SSD, “Roon2” and moved the DB to that folder and it seems fine now, touch wood!. Shows the drive size and all my NAS contents have been added correctly.

No idea what went on there at all…

1 Like

Good to hear! It’s almost weekend so it would have been a disaster if this was left unsolved. Weekend without music is no weekend at all. :slight_smile:

1 Like

Amen to that brother!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.