Roon has totally failed (Me)

Core Machine
(Windows 10 Home/Ver.2004 OS build 19041.631)**
Intel i7-2600K 16GB RAM
x64 OS

Network Details (networking gear)

My network
Netgear XR450 v2.3.2.66 The Core and 3 PCs AND Cambridge Audio CXN are on Ethernet
The Android and iPad Google home and smart speaker are on Wi-Fi {14 devices in total}

Audio Devices
iPad(Roon remote)>Win PC (Roon Core)>Cambridge Audio CXN v2>Rega Brio>Spendor A2

Description Of Issue

I had Roon working on my core with Roon x64 and Roon x64 server running. All of my devices worked normally and could interact with the core. I could also see the connected devices on the list of “enabled” outputs. I was trying to add a remote to the other computer in my network and the software asked me to deauthorize the core to allow the other computer to work. I was trying to bypass the nag screen and sad yes. After that I no longer have any working Roon infrastructure. I can only play from the core to the core, and oddly, to 2 Chromecast devices (One Google Home and A smart speaker) All other devices (iPad, Android smartphones, Allo end point (raspi), networked computers…) None of the Roon remotes work.
I have spent 4 days trying to fix the problem and am breaking down. So far I have tried.

  1. Reinstalling Roon x64, Roon x64 Server, Roon Remote on all devices.
  2. Updated firmware on Router
  3. Force updated Windows 10 x64 (all systems) Used the windows restore to go back to before changes. No luck.
  4. Removed Roon endpoint (Allo Usbridge)
  5. Check IP addresses of all devices and made sure they are online and visible to Roon
  6. The last straw was Last night I bought a 1000! dollar streamer Cambridge Audio CXN (V2) and it too is not connecting to the Roon Core. (The new version is Roon ready it is printed on the unit)
  7. I have also fooled with the firewall to no end. I am sure by now it is swiss cheese. (including disabling it completely and that did nothing.)

Is there a particulare reason why you are installing both Roon and RoonServer on the same machine?

Roon doesn’t ask for this unless you have indicated you want a new Core. Adding a Remote won’t generate this message. So, that’s a problem right there.

1 Like

Can’t help, Christopher, sorry - but for what it’s worth you have my sympathy, sounds like a proper pain :slightly_frowning_face:

At least when it’s fixed you can enjoy the new Cambridge…

1 Like

Thanks for the quick response @Slim_Fishguttz I did install the wrong software and thanks for pointing it out. :sparkling_heart: I wanted the remote and installed just “Roon”. That has been uninstalled from the other computer. I now know that was the wrong thing to do.
The reason both server and Roon are on my core is when Roon was working that is the way I had it set up. I am trying to reproduce a working system and it is not, still.

OK, you don’t need both.

If everything is working now, then good. Otherwise, to simplify things, just install Roon (as a test).

To be clear the Roon Core will not connect to any other device. I can play from the core to the core only. The remotes will not see the core at all.

Sorry, if it was working before, then that doesn’t make sense.

Tagging @support.

I had your exact same issue. I have my Roon Core and library on a NAS. I use a PC, phone and tablet as my remotes. One day every remote told me I had to deauthorize and I did just that and ended up where you are now. I tried reinstalling the remote apps and reinstalling the core and still had the same issue. I want to say that I had uninstall/delete everything from the remotes and deleted the core as though I was starting over for the very first time, reinstall without deleting/removing did not do anything. I have only had that issue once.

2 Likes

I guess I will do it again. I hope it works. I am all Roon’d out :face_vomiting:
UPDATE:
Installed Roon on all devices and the only remote working is on a Ethernet connected Win 10 PC. all others are not working

This does sound like a firewall or antivirus issue. They need exceptions to allow Roon and RAATServer through. It does look like you shut down the firewall and still had the issue. Can you check for the exceptions again.

Is your wifi on the same subnet as your Roon Core? Do you have a guest wifi or another network that your remote devices are connected?

Cheers, Greg

I just reinstalled windows 10 fresh and this did not fix it. The wifi devices are on the same subnet as far as I can tell. I do have a guest wifi but it is currently not in use. The firewall was disabled and it did not change the problem. My streamer is on the ethernet and is also not showing up as a endpoint. I did remove all of the fire wall rules and reallowed them. Side note the roonBridge software is working on one of my ethernet connected Win 10 PCs.

You can check by using a program like Fing on your phone or tablet. it will sniff out your network.

Have you tried deleting the Roon database and restoring from a backup? That can often take care of weird connectivity issues - it became second nature for me to have to do it with every update. You’ll need to replace the codecs as well on the server page when you do this.

I have removed the Database and re-cataloged it 3 times. I did try to run a backup and it removed my connection to the working roon remote on my ethernet connected PC. I updated my PCI network driver and it is now not working at all, as far as I can tell.

I do have Fing on my phone and it shows all of my devices on the Wifi network working normally. I do not see the ethernet devices on the Fing screen. I don’t know if that is normal

Fing should show you all the devices it can find on the network. If Fing can’t see the core or other ethernet devices, it sounds like they are running on a different subnet. You might verify by comparing the IP addresses Fing can find vs. the IP address of the Windows Core machine.

You can get that by ( copied from Microsoft’s site)

For Ethernet connection

  1. On the taskbar, select the Ethernet network icon > the Ethernet network connection.
  2. Under Ethernet, select the Ethernet network connection.
  3. Under Properties, look for your IP address listed next to IPv4 address.
1 Like

THANK YOU! This was the key to the whole problem. My second router had gone rouge. It is set up as a bridge to extend my Wi-Fi and “switch” to my audio components. It some how defaulted to router mode and changed all my IPs to 10.0.0.? The only nonaffected PCs did not use this device. Unplugging it switched all IPs back to the system router. At least now I have all the firmware and drivers updated and that new Cambridge Audio CXN sounds very nice.

3 Likes

Glad to have helped. Enjoy the music. :slightly_smiling_face:

3 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @christopher_labarre,

Thanks for letting us know that you were able to track this down to a subnet issue with the help of the other users and moderators! It looks like the issue was resolved before your case reached my queue, but if you have any other difficulties with Roon, please just let us know and we would be happy to assist!

1 Like