Roon high power usage

My instance of roon slows down, sometimes for a long time, after it’s been on for a few hours. I checked in task manager and I see that “power usage” is very high for the application. I have never seen this before for any other app. What am I doing wrong? Is my configuration causing this. I do have 448k tracks. Is the size of the db the cause? Any help would be appreciated. I have to restart roon all the time.

Hi Ayax, welcome to the Roon Community forum!

To be able to gauge your problem it would be of great help if you gave a more detailed description of your setup. On what hardware does your Roon Core run (processor, memory, etc.), what OS, how is it connected to your network, what endpoints are in use, where are the local music files stored…

448k tracks is a very large library, but you should be able to run this just fine on the right setup. There’s one resident forum member who runs a library of about 1500k tracks… this indeed must be quite a challenge!

I have a Lenovo i7 pc with 16gb of memory connected directly to my modem/router. I have an internal ssd running windows 10. Up to date. Several chromecast endpoints. My primary endpoint is an allo digione signature running ropiee. The music files are stored on two external 8tb drives connected directly to the pc

With a collection of 448k tracks, you most certainly would benefit from increasing your RAM size to 32 GB. For mere playback, the 16 GB may be just enough. But Roon’s background processes (as bulk metadata updates) increase the RAM usage for certain periods of time, which would possibly explain the observed slow-downs. Windows itself also happily eats some important chunks of RAM, so this is the most obvious thing to do.

Other than that, what i7 processor are you using? From my own observations I don’t think that processor speed is as important as plenty of available RAM, unless you do heavy DSP processing and streaming to several zones. As reference, my library of about 230k tracks runs happily on a Core i5 8600K with 16 GB RAM. My Core PC uses a fast M.2 SSD for OS (Ubuntu server) and Roon, and there’s a second SSD for local music files

When Roon is running certain massive background processes, Roon’s RAM usage on my machine can go up and above 8,5 GB. Now, you double my library in mere track count, and are running memory-hungry Windows…

Thanks. I am curious why it isn’t the memory or cpu indicators that are high instead of the power usage one.

Isn’t the power usage of a computer tightly correlated with CPU usage? What else would explain high power usage if not the CPU running under a high load?

The batch processes Roon is running in the background do indeed increase significantly the CPU load, in addition to demanding more RAM. But, these are temporary processes (which nevertheless on a large library can run for 1-2 hours…), and when completed, CPU load will go down again and power usage should also drop. Memory usage will drop, but it will take more time to recover. This is from what I can observe by monitoring my Roon server.

I will add that when such background processes are running on my server, I do notice an increase of the user interface response times on my Remotes… it becomes somewhat sluggish.

Windows is probably hammering it’s swap files to keep working at all. The Roon OS in the Nucleus would just stop but windows will keep on trying.


If this is the case, what should I do?

As @Andreas_Philipp1 said, add more memory.

Increase RAM on the Roon core server.

And, well, the obvious… With a library that large, you need a dedicated Roon Server PC. Don’t run other software, and I would use Roon Server instead of the full Roon package.

No body has mentioned this – Is this a new library ? Has Audio Analysis completed. A rotating circle to RH corner ?

goto Settings>Library

is there readout of tracks processed etc showing.

if there is , reduce the number of cores in use during the day and jack it back to max overnight

Also maybe post a Task Manager picture ?

1 Like

I have an almost identical Lenova i7 setup.

I regularly swap between two locations so it means that my library size is about 450k tracks at home and whatever fits on the 2TB internal drive plus Qobuz at the summer house. That’s about half at 225k tracks.

I have had all the symptoms you are describing. My experience has been that increasing ram to 32gb made no difference to performance/stability at all. What made the difference was switching off backblaze remote backup when playing roon. There seems to be some basic incompatibility with roon in that its background processes create files backblaze wants to backup leading to 100% cpu spikes. I never could figure out what the correct backblaze exclusions were so I just “pause” it when using roon.

I also regularly multi-task on the laptop (office apps, email, browsing, youtube etc.) so that leads to other issues in that I will get drop outs with 24/192k or DSD so I have just downsampled that content or excluded it from my library. The convenience of being able to transport the laptop from location to location far outweighs any marginal SQ improvements for me.

So I would suggest that you need to examine closely if there are other processes interfering with roon on the laptop or get a dedicated core as others have suggested if the compromises I make do not work for you.

He doesn’t say it’s a laptop, Lenovo PC.

Yes, you are right. My CPU is an i7-856u 1.8ghz, 4 core / 8 logical.

I don’t know the file paths for a PC, but I suspect you should exclude Roon’s database location from backblaze. You won’t be able to restore from it anyway, so there’s no point in backing it up, particularly if it causes a spike in CPU usage.

Thanks, but I already have that exclusion. There must be something else but I never did figure it out. The 100% CPU spikes stop when I pause backblaze.

But the point of my post was that the OP should look for clues of other incompatibilities in task manager first. Running other apps would be a common enough scenario on a laptop but as Ged points out, maybe its not a laptop and is already a dedicated core.

I have 32GB RAM on Win 10 and also see these power usage spikes. 141k tracks.

My guess is this is related to Roon’s predisposition to go off the deep end with resources and need a restart. Someone mentioned it seems to correlate to running multiple remotes. I do, so that is one data point.

Just a thought, Have you excluded Roon folders from AV scanning as well as excluded Roon folders from backup services.

Hello all thank you for the help. This is a dedicated desktop machine not a laptop. I do not use it for anything else. I have it in the utility room and I Remote Desktop into it when I need to. Most of the time, I have two iPads that I use as roon remotes. I must confess that I don’t know what backblaze is so I will have to do some research. Oh, and the db is fully analyzed. No spinning wheel.

It’s a backup software, I just referenced av and backup in my reply.
If it doesn’t do anything else maybe you can disable AV and see how that goes.
Memory does seem low for that size of library, but the sheer size of the database might require a more powerful pc.

What generation of Intel chip is it, as you might 2ant to look at a 11th it 12th generation if it is something like 5–7