Roon Icon for Ayre QX-5 Twenty

Hello @thyname & @Robert_Schaub,

We have received notifcation from Ayre that firmware 03.05.07 is the most up to date firmware for their device. You can find a link to the firmware as well as download and installation instructions here

If you run into issues getting your firmware updated, I recommend reaching out to Ayre support. They are aware of the issue and may have better insight into the particulars of the upgrade process.


1 Like

I fixed it!

Mine was a brand new that came with most recent firmware installed.

It is actually H.03.05.10

H is the General firmware that requires the thumb drive download, and the numbers are the over the network firmware.

If you have the latest firmware, you just need the network reset.

Get into the menu – hold right button for three seconds then left button for three seconds.

Toggle right with the control ring to network then hit green button. Toggle right again to reset and hit green button. It will say No – toggle right once to yes and hit green button.

Then restart your Roon server, and that’s it! The QX-5 is no longer “not certified “ and the correct logo appears on Roon.

See screenshot

Thanks for these instructions—I had the same issues with my QX-5 being “uncertified” after the recent Ayre network update. But I had no idea there was also a firmware update available by USB stick. My firmware was version C so it was quite outdated, I had no idea. I had some issues copying the downloaded update in the right format to my USB stick because like a previous poster I have a Mac. I finally got the QX-5 to update by formatting the USB stick to “MS-DOS (FAT)” and selecting “Master Boot Record” instead of the default “GUID Partition Map.” I discovered that trick by googling how to format FAT32 on a Mac. I called Ayre and they did not know that trick either, the guy at Ayre was going to mail me his USB stick with the download, but I was able to get the QX-5 to read the USB once I used “Master Boot Record.” Now I am running version H as well as the latest Network update. Nothing sounds any different but I am satisfied anyway.

OK, I finally have it all sorted out. It took a while because I’ve been a bit sick, just started a new job, and needed to have a thumb drive sent to me from Ayre since nothing that I tried with my MacBook Pro running High Sierra would seem to work, and–trust me–I tried everything that I read about and then some apart from buying a third-party disk utility program for formatting the thumb drive and possibly copying the downloaded and unzipped general firmware update directory to the root of the thumb drive (and did all of that with two different brands of thumb drives). In any case, the thumb drive from Ayre worked, so I have general firmware version H and network firmware version 03.05.10. A number of people have suggested a network reset, but–out of context–that implies resetting my home network and nothing in particular on the QX-5 Twenty itself; however, I read your instructions and assumed that they referred to the QX-5 Twenty because nothing else I have has a left and right button and a control ring. The QX-5 Twenty didn’t indicate anything had happened after I hit “YES” so I did it twice just to make sure. Then, yes, indeed Roon recognized the QX-5 Twenty as certified, the custom icon appeared in the remote Apps again, and everything seems to work just fine. Thanks very much for the suggestions and assistance.

1 Like