Roon Icon for Ayre QX-5 Twenty

I have a home network using a array of Apple Airport Extremes with Roon Server running on a 13" MacBook Pro. I run the Roon App on a new iPad. I have two endpoints, a Bluesound Node 2 and and Ayre QX-5 Twenty. Last Sunday, everything worked fine. This Sunday, after updates to both the Roon App and the Ayre QX-5 Twenty, it still works fine except that I have lost the custom icon for the QX-5 Twenty and just see an image of a loudspeaker. The Bluesound Node 2 still has the correct icon. The errant icon appears on all of my control devices including the iPad, my iPhone 7, and the 13" MacBook Pro itself. It’s a minor issue, but does anyone know how to get back the correct icon for the QX-5 Twenty in the Roon control Apps? Thanks very much. I have done all of the usual power cycling, etc. My NAS is a Melco N1A. Thanks again.

I may have found the problem. My QX-5 Twenty is now listed as uncertified. Apparently the QX-5 requires both a network update AND a firmware update, the latter by way of a USB flash drive (and I don’t have a spare one right now). After I get the firmware update then reset everything, including my network, the QX-5 may appear to be certified again, which I’m guessing will lead to the correct icon. Please don’t close out this topic until I can get all of that done. Other suggestions are welcome, too, of course, Thanks.

Hi @Robert_Schaub ----- Thank you for the report and sharing this observation you have made with us. The feedback is always appreciated!

I checked our partner device matrix and can see that the QX-5 Twenty is listed as Roon ready, so I wanted to touch base and see how the firmware update went.


Sorry, I haven’t done it yet but will report as soon as I do. Thanks.

What is your current firmware number on your Ayre QX-5?

Here is mine, check picture.

Just got my QX-5 today brand new.

@eric thoughts?

To clarify for @Robert_Schaub @eric and @support I am having the same issues, icon wrong, and NOT Roon Certified

I’m sure mine is outdated although I don’t remember the exact number. I just literally found two thumb drives five minutes ago so will do the firmware update and reset my network this weekend, then report. Thanks.

Funny part is Ayre website shows H.03.05.07 as current version, and mine has H.03.05.10. So from number sequence I should be ahead?!

Seems so. I’ll likely do the firmware update and network reset later this afternoon.

What format are you using for your USB flash drive? I have a Mac and would normally pick FAT32 in this case, but that doesn’t appear to be an option (anymore) in the Disk Utility. I’m sure MS-DOS[FAT] won’t do it and ExFAT doesn’t appear to work in the Ayre. I doubt the Mac’s proprietary file formats will be readable either. Any suggestions? Thanks.

OK, I did some research and there appears to be a bug under macOS High Sierra that won’t let you read or properly erase any drive, including a USB thumb drive, using the FAT32 (now called “MS-DOS[FAT]”) format, which I’m almost 100% sure is what the Ayre wants to see. So I either have to wait for Apple to fix it or, maybe, buy a third-party disk utility for macOS, which I’m not inclined to do at the moment (and I’m certainly not going to buy a Windows machine just to format a thumb drive). I can forgive Ayre for adopting (presumably) FAT32 as a standard although I don’t see why they can’t offer complete firmware updates over the 'net just like Simaudio does instead of splitting it between a thumb drive AND a 'net-based update. However, I’m profoundly disappointed with Apple for letting a bug like this into High Sierra and, apparently, not yet fixing it even though they’re already up to the .4 release of High Sierra.

What does this have to do with Roon not displaying the correct QX-5 icon, and for being shown as Uncertified?

I highly doubt it

Hello @thyname,

We’re investigating some issues with identification on Roon Ready Ayre devices. In the interim, although your device is showing as “uncertified”, it shouldn’t have an effect on its playback capabilities or functionality.


Thanks so much for looking into this @john!

Please keep us updated with your findings and potential solutions.

And I agree, everything looks and sounds fine, including the signal path.

For your reference, and just in case, here is the additional info on my QX-5 on Roon when pressing the “i” button:

There was another thread where someone’s QX-5 kept showing up as uncertified until he did a firmware update and restarted his network, so I’m just following his lead. If Roon Server thinks it’s uncertified, it’s very unlikely that it knows it’s a QX-5, so then would make sense that the custom icon would go away.

Well, I went into a High Sierra terminal window and used the command-line version of the disk utility as well as the UNIX cp command so I’m sure that my thumb drive is FAT32 formatted and that the unzipped firmware update directory is in the right place on it, but, even when I follow Ayre’s instructions, the QX-5 won’t recognize the thumb drive and update from it. There’s one trick left I can try (maybe later) but I’m feeling inclined to call Ayre on Monday and request some assistance.

Well, read the reply from @john above. But do you actually have the QX-5? You keep talking about it for a week, and have yet to check the firmware version. It is easy to do so.

And also, what does the disk formatting have to do with this?

I’ve been sick and am only getting to the firmware update today.

Yes, of course I have the QX-5, how else would I be inserting the USB drive (which can be formatted in many different ways) into the firmware update slot on the back of the QX-5 after I’ve switched it off, then switched it back on and watched it not indicate that it’s updating to the current firmware version?

I’m talking about the “general firmware version”, which has to be updated with a USB flash drive, not the “network firmware version”, which the QX-5 automatically prompts you about:

General Firmware Version: H
Network Firmware Version: 03.05.07


Did not mean to offend you by any mean. Sorry.

What I was trying to say, first step is to check your General firmware on your unit. If it is “H” (mine is), then you would have nothing to update.

I am totally aware of the General vs. Network updates.

As I mentioned above my General version is H, and network version is 03.05.10. Ayre website says H.03.05.07

As John from Roon mentioned above, this issue may have nothing to do with Ayre firmware version.

Yes, sorry. It is “E”, so quite outdated assuming the E precedes F, G, H, etc.

1 Like