Roon import issues

Roon Core Machine

ROCK version 1.0 (build 227)
Intel NUC7i5DNKE, 8Gb RAM, 256Gb SSD (Roon database and settings), 2Tb SSD (Internal Music Storage)

Networking Gear & Setup Details

DrayTek Vigor 2762n ADSL/VDSL router
NetGear ProSafe GS108E switch
NUC ethernet connected, fixed IP address

Connected Audio Devices

JBL Synthesis SDR-35, connection using ethernet

Number of Tracks in Library

I use a Tidal account on Roon to access music tracks and currently only use the internal storage to store downloaded tracks from NativeDSD. I only have just over 60 tracks stored at the moment.

Description of Issue

When I purchase new music from NativeDSD I use their downloader to initially store the music on my MacBook Pro. I then use the drag-n-drop method to drag the music folder/files from my Mac to the open Roon application. This has always worked perfectly, since November 2021 when I installed it.

I purchased a new album on NativeDSD a couple of days ago and performed the same procedure as described above. When I check on the little whirling icon at the top of the screen to check what is happening with the download I see something similar to the following -

Bizarrely both of the numbers on the copy are increasing with the proportion copied and to copy remaining roughly the same - all of the time, irrespective of how many hours you let it run. On an album with 12 tracks I let this run for over 24 hours and both figures ended up in the 10’s of thousands and it was still running. Nothing appeared to have been copied to the internal music drive although the space on the 2Tb drive had reduced by 16%!

In the end, because of the low number of music files on my storage drive I reformatted it, hoping that would solve the problem. I have tried to import the NativeDSD Music Starter Pack this morning and the same thing happens.

Any help, suggestions would be greatly appreciated.

I don’t use that method. I just copy the files directly to the drive using the PC file manager.

The internal music drive in a ROck NUC is shared and should be viewable in your PCs file manager.

I tried that as well. Unfortunately still getting strange results. Although I’m not getting the problem reported above, some of the albums copied across only appear to have one or two tracks available in Roon whereas all of the tracks are on the NUC. I’ve tried rescanning but nothing changes.

That is usually traced to a metadata issue and Roon will have split the album up. If this is the case, you can merge the split album back together again.

1 Like

Hey @John_Yendall,

First off, welcome to the community! We’re excited to have you here, and I’m sorry to hear you’re running into importing issues with Roon.

Does this happen no matter the album you’re trying to import, or is it a specific album? It is possible there is a corrupt file involved here, causing Roon to think it can be imported successfully, but it actually causes instability for the importing process.

If possible, please reproduce this issue and grab a timestamp (date, time) and share it here. That way, we can enable diagnostics on your account and take a look at what might be happening at the time of the issue.

With that, are there any odd symbols in the album in question? Sometimes albums use certain symbols in the filename, which Roon does not accept. Changing these symbols can solve the problem.

If you haven’t yet, I would also suggest giving your router and core a hard reboot to see if the issue persists. Thanks, John!

In trying to resolve the issue I was having, in the first instance I rebooted all hardware including routers and switches. Because I had only a small number of albums stored, I formatted the internal music drive and reset the Roon database and settings. I tried to import several of the albums by dragging the folders onto the open Roon app, all of which had worked in the past, but they all had the same problem as reported earlier. In the end I used the suggested second method of loading music by copying folders downloaded from NativeDSD and then connecting to the Data folder on the Roon Core and pasting them into the Internal Storage folder.

After receiving your email yesterday I purchased a new album from NativeDSD, downloaded it yesterday evening, and tried the import procedure this morning at 07:30 by dropping the music folder onto the open Roon app. To my surprise it worked without any issues.

No idea what the problem was or what solved it but I am glad to say that all is now functioning as it should.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.