Roon Intermittently Dropping Out and Losing Connectivity

I’m having an issue with Roon intermittently (and frequently) losing connectivity when listening to music on my server or creating playlists. I am not very tech savvy so please bear with me. My setup is as follows:

Device: Asus desktop computer with Windows 10, 64 bit
Music Server and Roon Core: Little Green Computer i7 Sonic Transporter, Linux/Roon (connected to router with ethernet cable)
Network: xFinity wi-fi router with three xFi pods distributed throughout the house (wi-fi connectivity is good)
DAC: Schiit Yggdrasil - latest version (connected to UltraRendu via USB 3 Cable)
Music Player: Little Green Computer UltraRendu (connected to xFi pod in basement via ethernet cable and connected to Yggdrasil via USB Cable)
Device: iPad for Roon interface
The Core is loaded with FLAC files mainly from CD’s uploaded to the music server although I have downloaded a few albums from HD Tracks.
This setup has been working great until a couple of days ago when we had a windstorm and the power went out for a little bit. Since then Roon drops out every 10 - 15 seconds - very frustrating. As I mentioned I am not computer tech savvy so please feel free to ask questions but if information is needed from the system please provide me with specific instructions in how to obtain and include it in my posts. Thanks!

Hello @Larry_Ragel,

Thanks for contacting support, I’d be happy to assist here.

I am wondering if the power surge has by any chance caused an issue with the XFi pods operating properly. Would it be possible to temporarily bypass them and connect your Sonic Transporter and your Asus Desktop directly into your Router via Ethernet to see if Roon still loses connectivity then?

Also have you tried rebooting all of your devices since the power surge? I would reboot the Sonic Transporter and your router/extenders to see if this has any change regarding the issue.

Are you able to properly play content to “System Output” on your desktop PC? If you are able to do so then we can possibly eliminate the DAC as being the issue.

Please let me know your reply to my above questions and we can continue from there.


Hi Noris, Thanks for your response. I did reboot the computer, Sonic Transporter and router twice and that did not resolve the issue. Currently the Asus desktop and Sonic Transporter are connected directly to the router via ethernet cable. O.K. I’ve just now been looking at some of the Roon software settings and apparently all of the audio devices had been disabled - not sure how that happened. I enabled them again and everything seems to be working fine so far. I will test the UltraRendu and Yggy DAC and let you know if I encounter any additional problems. I apologize for any inconvenience - still learning Roon and the equipment. Thanks!

O.K. The issue is still continuing but seems to only be occurring with remote devices, e.g., my iPad and the UltraRendu and Yggdrasil which is connected via the xFi pods. I’m not sure how to reboot the xFi pods but would try this as a next step. Could there be an issue with my router?

Hello @Larry_Ragel,

Glad to hear that the devices connected via Ethernet are working as expected. If you want to run a quick test to verify if the UltraRendu and Yggdrasil are still operational, I would recommenced temporarily connecting them to your Router. If they work as expected then the issue lies with the xFi pods.

Generally speaking, to reboot the xFi pods, I would unplug them from the power outlet, let it sit for about a minute and then plug them back in to ensure that they are in a fresh state. After you have done this I would try again to see if they show up in Roon. If they still do not, I would ask XFinity to make sure that the pods are ok and have not been adversely affected by this power outage.

Please let me know if my suggestions help.


Hi Noris, I’m leaning towards a network issue now. I was able to verify that the UltraRendu and Yggdrasil are operational but am experiencing the same issue with losing connectivity. The interesting thing is that I also use wi-fi connectivity for Sirius radio and that seems to work fine with no connectivity issues. When I check the connectivity of the xFi pods the xFinity app on my iPad says they are online. And I just now checked the Asus desktop and lost connectivity while playing from a playlist! Could it possibley be a bad ethernet cable?

Hello @Larry_Ragel,

Just to confirm, you have connected your Sonic Transporter and Asus desktop via Ethernet to your router and are still losing connectivity? It could be a bad Ethernet cable or it could be the router itself, it is not clear at the moment. Have you power cycled your xFi pods with the instructions I listed above?

Do you have access to your router’s configuration page? There are some troubleshooting suggestions listed on our Networking Best Practices Guide which may be worth to try and see if changing any of these settings allows proper communication to occur. Although they are meant for different router types, seeing if these settings are applicable to the xFi system will be a good step as well.

Please let me your findings when possible.


Hi Noris. Yes the Asus desktop and Sonic Transporter are connected to the router via Ethernet cable. I did reboot the xFi Pods per your e-mail and connectivity was good for about 30 minutes, then the same problem occurred. It also apparently affects connectivity between the router and the Sonic Transporter because I am experiencing the same loss of connectivity (intermittent). So the Pods may be the issue, however I am still able to connect to Sirius radio with no connectivity issues and before the Pods this was a problem in remote areas of my house. Also the xFinity app shows that the Pods are connected to the network. I/m not sure if I have access to the router’s (xFinity’s) configuration page and as I mentioned I am not computer tech savvy but know someone who is. Do you think contacting Comcast would be a good next step? Thanks.


Hello @Larry_Ragel,

Thank you for confirming the issue still persists after resetting the pods and posting your findings so far.

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. After receiving the diagnostics, I will then start a case for you with our QA team who can take a closer look at this behavior.

No further action is necessary from your end at this time, I will be sure to let you know once QA has finalized their report and has passed it back to me and will let you know their findings.

I appreciate your patience while the investigation occurs on our end and I will be in touch again after the investigation has concluded.


Thanks Noris! I will wait until I hear from you. I have also advised Andrew at Small Green Computer of these issues.

Hi Noris, I wanted to let you know that an xFinity tech came out to my house this morning and checked out the router, signal strength, = continuity of service, speed, physical cabling, etc. and found everything to be in good working order and he seemed very = knowledgeable. There was also a Roon software update that I enabled this morning. This issue still persists. Please let me know when QA has completed their review. Thanks!


1 Like

Hi Noris, I haven’t heard anything from QA yet regarding this issue. When should I expect to hear back from someone?

Hello @Larry_Ragel,

The investigation regarding your report is ongoing but we have an understanding of where the issue lies. Unfortunately, it looks like the issue is related to a dependency Roon uses for cross-platform compatibility (called Mono). This means that, while we may be able to fix this, it’s more complicated because the issue is not happening in code written by us.

We have seen this issue before, but generally it happens just once on rare occasions, and it’s not yet clear why this issue is affecting you repeatedly.

While we investigate, there are a few things that you can do as to help troubleshoot this issue:

  1. Your Roon Remote diagnostics is also showing signs of instability, I would completely remove and reinstall the Roon app on your Asus Desktop PC. The best way to do this would be to uninstall Roon using Window’s “Apps & Features” and then navigate to your Roon Database Location and locate the “Roon” folder and rename it to “Roon_old” as to ensure that you are running completely fresh here. This renaming step should look like this:

  2. It would be useful to see if you run into the same issue if you temporarily host your Roon core on the Asus Desktop instead of on the Sonic Transporter. After reinstalling Roon on your Asus desktop, I would select the option “Use this PC as the Core”.

If you are able to perform the above suggestions, that will at least get a clearer indication of what is going wrong and confirm our suspicions that something on the Sonic Transporter or elsewhere in your environment is causing Roon to drop out. We’ll be looking into this further on our end as well, but please let me know your findings when possible.


Hello @Larry_Ragel,

I had a meeting with QA and one of our developers regarding your case today and they have looked over the submitted diagnostics. As best as we can tell, there is something saturating your network and causing this behavior. This could be caused by storage issues, but its hard to say with certainty.

Can I please ask you to try disabling your current watched folders in Roon and just use TIDAL or a USB drive and see if things are more stable? Please let me know if you are able to perform this change and what your findings are after doing so.


Noris, Would you please let me know what you mean by “something saturating your network.” Does this mean that there is a connected device using too much network bandwidth or that too many devices are connected to the network? I feel like we’re using a dartboard approach here when what is needed is a serious diagnostic analysis of the Roon software and perhaps the SonicTransporter music server. I’ve replaced the xFinity router and rebooted the xFi pods and thus attempting by process of elimination to reduce the possible causes of this continuing issue. I have to say that it seems that you are placing an awful lot of responsibility on the users of your products to solve system problems and need to remind you that I am a consumer, not an IT technician. I purchased a lifetime subscription to what I thought was a ready for primetime audiophile software player only to find that it seems more like a beta system provided to users for testing purposes. I need sound technical help to solve this issue as right now I have a system that doesn’t work with a significant investment in both software and hardware. Thanks.

Hey Larry – I appreciate the frustration here, but unfortunately sometimes the only way forward is this sort of methodical troubleshooting, and the feedback you’re getting from Noris is coming out of discussions he has had with myself, our head of Engineering, and our CTO.

The symptoms you’re describing here are definitely atypical. Obviously, Roon can be set up in a nearly unlimited number of configurations, and in the vast majority of cases it works as expected, even when not everything in the environment is performing as expected.

When that doesn’t happen, like in this case, usually the problem is environmental, and there’s an additional complication in this issue, which is that the crash isn’t happening in Roon’s code, but in a dependency that Roon uses for compatibility on a number of platforms.

This means we have a bit less visibility then we normally would – it this was a crash in our code we would fix it, or help you work around it. In this case, something in your environment is causing issues in Mono, which Roon runs on multiple platforms, and in tens of thousands of installations. I know this may be more detail than needed but I want to be clear about why it may seem like we’re in the weeds here, and the reason is that this kind of issue is extremely rare.

The point is, something is different here, and in order to identify what that is, we need to work through the possibilities. These are some of the trickier issues we deal with, but I can guarantee you that you’re in good hands here, and if there was a more expedient way forward, Noris would start there, of course.

For now, all we can do is ask your patience, and we’ll try to get this pinned down as quickly as possible. Thank you!

If you had a similar problem with any software vendor you would have to go through a similar process.
Given there are ten if thousands of possible devices and billions of combinations getting to a solution requires narrowing down possibilities.
Roon is versatile and works on many vendors platforms so complexity is inherent.

Thank you Mike, I am glad to hear that you will help me get through this. The thing that baffles me is that I probably have one of the most vanilla type of computer and wi-fi set up of most of the folks out there. I am using the music server and Roon in the configuration that it came to me and as it was downloaded on to my computer and iPad. There’s nothing esoteric in my hardware or software, at least of which I am aware. Just an off-the-shelf Asus desktop from Best Buy, xFinity wi-fi and a few devices connected, two Oppo Blu-Ray players, the music server, music player, a couple of iPads, and a Kindle and Nook readers. I am also working with Andrew of Little Green Computer to help diagnose this issue. I will tell you that when it is working it sounds amazing, especially as the Yggy has some time to burn in. I’m very anxious to get this issue resolved.

Noris, I worked with Andrew at Little Green Computer this morning and with his help and expertise it appears that my issue has been resolved. Apparently I inadvertently created an extra storage location in Roon that caused problems with the software. Fortunately it was a simple fix and I really appreciate Andrew’s knowledge and assistance as he knew what to look for and was able to see the problem very quickly. I played music for nearly 5 hours this afternoon without any dropouts. Thanks for your help and assistance as well.


Hello @Larry_Ragel,

Glad to hear that you’ve been able to work with Andrew on this issue and that everything is working as expected! It is possible that this secondary watched location was the cause of the networking being saturated and removing it seemes to resolve the issue.

I will go ahead and set an auto-close timer for this thread for 2 weeks and if you run into any other issues, don’t hesitate to let us know and we can take another look. Thanks again for working with us to troubleshoot this issue and feel free to let us know if there’s anything else that we can assist with.