Roon is not allowing me to sign on

Core Machine (Operating system/System info/Roon build number)

ROCK on NUC7i7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

When I turn on the Roon Remote, its asks for Email and Login information, does not accept it…and shows Network error: Please check your Internet Connection Box.

You don’t say what device you are running your Roon Remote on, but I would suggest first uninstalling the Roon app, reboot device and then re-install Roon app.
I am assuming that your Username and Password are correct, of course and all devices are on the same subnet).

I did once have a similar issue, turned out to be a DNS issue (but I run my own internal DNS server - PiHole).

A screen shot of the rock GUI page might help us here too

Hi @Richey_Madison,

So we can better assist you, please verify the following:

  • Is this a new install of ROCK or have you used this device with Roon previously?
  • Are you able to access the ROCK Web UI? Can you share a screenshot of this?
  • What type of remote device are you using?
  • Can you explain what networking hardware is in use and how your remote and Core are connected?


Dylan - Roon was already set up and installed on Iphone 6s and a dedicated Ipad Pro. Neither of those devices has been modified except maybe automatic updates. I use it everyday and hadn’t made any changes, until one day it was asking for a login after selecting the ROCK to Connect on either remote. Core is via ethernet, remote is via wifi over the network.

Have you rebooted the server?

Hi @Richey_Madison,

If you give the Core machine a reboot is there any change? Are you able to login?

Hi Dylan - I’ve tried rebooting the NUC, reinstalling ROCK, deleting the app off my iphone and ipad and reinstalling. Changing all my IP addresses back to automatic from fixed DCHP…I’ve rebooted my router…and changed my password for login to make sure I wasn’t typing the wrong password. Wifi network shows up correctly on both devices…as I can access the internet from my IPAD and they can both been seen on my network. The only odd thing that the ROCK Connection Type oon my device list shows as pending. Don’t know if this is typical.

Hi @Richey_Madison,

Please try the following and then try to login once more:

  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Dylan - moving the Cache folder out of the Roon application and Restarting Roon Server didn’t work the first time. I had to switch from fixed to automatic IP address first, then I did it again and it worked. I was able to switch back to my fixed IP address after it started working correctly. If you have any insight on what caused the problem, it would be appreciated! Thanks for your help! Richey

Hello @Richey_Madison,

I’m not sure what could have occurred here, but we’re obviously glad you’re back up and running.

My best guess would be that setting a static IP caused your Core to not pull in the DNS settings from the router correctly.

In any case, we strongly recommend that users stick with DHCP address reservation if at all possible. We have found that using static IP can cause a multitude of hard-to-diagnose issues on users’ networks, which is not fun for anyone involved.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.