Roon is not playing on my Meridian system

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

TP Link Model: Archer 500V AC 1200 Wireless DualBand Gigabit VoIP GPON Router connected to a Netgear 8 bit Ethernet Switch - no WiFi in the chain, all connections by wire. No VPN

Connected Audio Devices

Meridian 808.3 2-channel processor which is connected to Meridian 7200SE speakers

Number of Tracks in Library

~ 6000 tracks + Tidal subscription

Description of Issue

I touch the play button and it changes to pause (as it should) but nothing happens. There’s no sound although I can see that the Meridian 808.3 has been selected.

  1. I have changed nothing in my system for the last 2 years and this was working till Saturday. Has not worked from Sunday
  2. I can play through the speakers of my ipad or macbook Pro if I select that as the audio device
  3. The Meridian system works fine with the other sources

What basic troubleshooting have you tried, like rebooting everything?

I have restarted Nucleus and the 808.3

More detail - I have restarted the Roon Server Software and rebooted the Nucleus from the Nucleus Web Administration Interface.

Would it be possible for me to talk to a Roon employee? I have a life membership for Roon and have also invested in a Nucleus. I need to figure out how to get it working again. Could it be the latest update that’s the problem?

Support from the Roon Labs team is only available via this #support category in the forum, I’m afraid. The support team is a small team, and they work on the queue of support requests.

1 Like

Switch the audio and network equipment off then switch the network on then the meridian then the nucleus.

1 Like

It works now! Thanks @ged_hickman1 - your instructions were spot on!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.