Roon is very slow; loading album is very slow; Qobuz is loading slowly and drops out, skips to next track

Roon on Nucleus+

Things have become very difficult with Roon for me lately. The situation is not consistently bad, sometimes Roon becomes unusable, other times it works well. Often everything loads very slowly, or not at all; and when I try to play something via Qobuz, I often get an error message saying that Qobuz is loading very slowly. It will stop playing, nothing for a minute or so, and then skip to the next track. My wifi and cable connection are quite good, I get around 350 Mbps download speeds. I’m using Roon on a Nucleus+ controlled by an Ipad Pro. Files stored on the Nucleus+ seem to play without problem, once I get them going – the slow loading seems to happen with them too. Help!

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
I’m using a ARRIS SURFboard SB8200 DOCSIS 3.1 Gigabit Cable Modem and a Netgear Orbi router with a Netgear S8000 switch.


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
From the Nucleus+ my signal goes to an Aqua LaVoce DAC, from there to a PrimaLuna preamp, then to Macintosh room correction, and then to a Pass amp, finally going to my Magnepan speakers.


Description Of Issue


Restarted the nucleus? And the modem and router while you are at it…leave it all off for a few mins at least

Thank you! So far that seems to have done the trick; I’ll continue to monitor it…

1 Like

A post was merged into an existing topic: Ios and Mac Remotes are unresposive

Hi @Kenneth_Reinhard

Thanks for letting us know that the reboot helped clear up this issue! If the issue re-occurs, I would also check to see if other zones also have this issue, that way we would know if the issue is just on the Aqua LaVoce DAC or if the issue impacts multiple zones, that would be a good data point to have.

My problems continue, and I can now specify a bit more what is going on. I get extremely fast cable internet (425 Mbps download is about average) and my wifi is very strong. Streaming internet music works well with standard resolution files, but high resolution files from Qobuz and Tidal basically won’t play, or they play for several seconds and then stop, with an error message indicating that there is a problem loading Qobuz or Tidal, as the case may be (“Qobuz media is loading slowly. This may indicate a networking or connectivity issue.”); after a period of silence, the next track on the album plays, and again stops with the same error message after a few seconds; this continues. High resolution files that I have on my Nucleus+ internal drive and attached USB SS drive play fine. I have this problem on my main system, connected via ethernet to the router as well as on various other wifi speakers. Can you help with this? Thanks!

What DNS servers are you using? Try one of the others like CloudFlare or Google.

I tried switching to manual selection of DNS servers (I tried CloudFlare and Google) on my computer – is that what you mean? Or is there some way to shift the DNS server that the Nucleus+ uses? In any case, streaming files still don’t work (after a delay, they play, but only for a few seconds before stopping and skipping to the next track, and it continues like that). And everything I do in Roon, just trying to access an album in my library, for example) takes a long time, just the “loading album” notice for 20-45 seconds, if I’m trying to see something on line. Regular resolution streaming files seem to be ok, but I really can’t listen to high resolution streaming files.

I’m not sure if this is connected, but when I try to move a file from a hard drive in my computer to the Nucleus+ or its attached SS USB drive, it takes a LONG time, and sometimes I get a notice saying “an unexpected error is keeping you from copying the file…” with error code 0x8007003B: an unexpected network error occurred." I have recently switched computers, upgrading to a very powerful custom made one from AVA. Maybe something was messed up in the process of transitioning?

Thank you for any help you can offer!

OR… are you suggesting that I can change the DNS server in the Nucleus+?? I see that there is a place for DNS server in the static IP address setup tab.

One more piece of information: when I try to move a music file from my desktop computer to the hard drive on my Nucleus+, it is VERY slow, about 350 Kbs. This seems to be an important clue to the problem, but I don’t know how to interpret it.

Well now it hit me - Roon is extremely slow. Practically unusable - for the local library and even worse with Qobuz. Search takes forever and when I select a title, nothing happens. Then after I have nearly given up, the title plays. Got Google as DNS.
Checked internet and is very fast as usual - also changed nothing at all. Qobuz using own app is running perfectly. Got Roon running on a Nuc.

UPDATE: Restarted the Nuc and it got better again - working at the moment. So the - when in doubt, restart - trick helped.

Hi @Kenneth_Reinhard,

I’d like to second the DNS change using either Google DNS or Cloudflare. There are two ways to do this:

  1. Recommended: Change the DNS settings on your router for the entire network
  2. Advanced: You can set a static IP on the Nucleus (which we only recommend if you’re familiar with doing this) and when doing so you can set a custom DNS.

Let us know if this results in any changes!

Ok, I finally found the problem: when I unplugged the ethernet cable going to my Nucleus+ from my Nighthawk switch and plugged it directly into my Orbi router, I am able to listen to high resolution. I assume there must be a problem with the switch, although there is no other indication of a problem. Thank you all for helping me to work this out!

1 Like

Hello @Kenneth_Reinhard,

Thanks for letting us know you were able to identify the root cause of the issue and that bypassing the switch has helped! It does sound like you’ll want to keep the direct connection or replace that switch with another un-managed one.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.