Roon is very slow while playing Qobuz tracks

Roon Server Machine

M1 Mac Mini
Roon v2.0 (Build 1357)

Networking Gear & Setup Details


Connected Audio Devices

Sonos Soundbar, SOtM Network Streamer, HomePods

Number of Tracks in Library


Description of Issue

Roon is running extremely slow most of the time. Library content is fast, but anything streamed from Qobuz take anywhere from 20 seconds to minutes to begin playing.

Where is your DNS service pointing to? If it’s to the isp DNS try pointing it at Google or cloudflare

Thank you, Ged.

I confirmed that it is already pointing to

1 Like

Hey @Ali_Shafai,

Thanks for writing in! Could you please reproduce the issue and share the specific date, time and name of the track playing when the issue occurs?

Once you let me know this info, I’ll go ahead and enable diagnostics for your account so I can review the logging for clues.

If you’d rather do it yourself manually, please use the directions found here and send over a set of logs to our File Uploader.


Thank you, @benjamin.

I was just about to reproduce it moments ago, 12/22/2023 at 1:23pm PT. I was trying to play Alice Sara Ott’s Nightfall Album, and it has been more than a minute and the 1st track still won’t play.

The track progress bar has a purple line going back and forth, and the track won’t start.

Tracks that I own in my library play quickly.

Please let me know what you can find out.

Hi @Ali_Shafai,

Thanks for the update, and for your patience! From your account page, I see you are running an M2 mac as your Roon Server. Are you still experiencing issues?

Can you provide more information around how your Roon Server is connected to your router/network? Thanks! :+1:

I switched to a different Mac mini, and the problem as gone away!

Thank you.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.