Roon Library Closed for Renovations?

My system (see profile) has worked fine until recently. I copied some recognized Roon albums to my local drive (for some tagging and maintenance), deleted the Roon storage versions, cleaned up the library database, did my maintenance work, then copied the folders back into the Storage drive.

Result: no acknowledgement, no “new album processing”, no nothing as far as a Roon recognition. I have: rebooted and power cycled the server and remote; forced several rescans; checked the skipped file list; checked the hidden files; and manually and electronically searched for the albums within Roon. I have also re-enacted the drag-and-drop process several times with small tweaks.

At first I thought the fact that they were “previous Roon albums” might be a source of the problem, so I drag-and-dropped a album new to the Roon storage drive. And still no recognition.

Oh, and, according to my MacOS remote, the files were and are physically on the Storage drive. And I’m up to date on software versions.

I must stop until I find out what I’m doing to create this unexpected behavior. What would be the next troubleshooting step? I’ve never had a drive or computer hardware failure (knock on plastic) so I wouldn’t recognize the symptoms. But I’m stumped. Any advice welcome.

Hello @John_V,

Thanks for contacting support, I’d be happy to take a look over this issue with you.

  • Did you by any chance have Roon running when you performed the copying of the albums back and forth? If you are moving files between drives we always recommend using the following steps to avoid Roon seeing two version of the same files at the same time.
  • You mention that you have tried to perform a “force rescan” on the watched folder already, can you please try to “disable” and then “re-enable” the folder as well to see if that has any change?
  • I would also try restarting the Core and if the Storage drive is a NAS, I would try rebooting that as well.
  • Can you please post a screenshot of your Roon Settings -> Storage that highlights this issue and a screenshot of where the files reside on the storage location?

Please let me know your findings when possible and we can continue troubleshooting from there.


Core was running and not disabled. Un- and re-enable not successful.

My music is on an external drive connected to a Rock. No changes to that in over six months.

I’ve rebooted and Recycled both Rock and drive.

Should I Remove and re-attach the subject watch folder now?

Hello @John_V,

That’s certainly strange that they are not appearing, and you’re positive you have dropped the files in /MusicDrive/Roon or /MusicDrive/iTunes/iTunes Media/Music?

You also mentioned that you have dragged and dropped a new album to Roon storage drive and the new album still has failed to be recognized? I can see in our system that we’ve looked at issues in your database before, so id like to confirm these issues occur with you temporarily running a fresh database, that way we can be sure about whether this is related your database or something else, like specific steps you’re taking, your files, etc. To temporarily set your current ROCK database aside, please:

  • Create a Backup of your ROCK Database first and save it in a safe location
  • Navigate to your ROCK Data Directory
  • Rename the current RoonServer folder to RoonServer_old
  • Reboot the ROCK
  • Configure the new database
  • Try adding the same files again

After you have performed the above steps, please let me know your findings and if the files appear.